summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/xscorch/ChangeLog7
-rw-r--r--games-strategy/xscorch/Manifest6
-rw-r--r--games-strategy/xscorch/files/digest-xscorch-0.2.01
-rw-r--r--games-strategy/xscorch/xscorch-0.2.0.ebuild31
4 files changed, 27 insertions, 18 deletions
diff --git a/games-strategy/xscorch/ChangeLog b/games-strategy/xscorch/ChangeLog
index 673b84511cdd..da3c69613c00 100644
--- a/games-strategy/xscorch/ChangeLog
+++ b/games-strategy/xscorch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/xscorch
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/ChangeLog,v 1.7 2004/12/28 23:43:15 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/ChangeLog,v 1.8 2005/05/26 01:00:44 mr_bones_ Exp $
+
+ 26 May 2005; Michael Sterrett <mr_bones_@gentoo.org> xscorch-0.2.0.ebuild:
+ add 64bit patch from upstream; tidy
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-strategy/xscorch/Manifest b/games-strategy/xscorch/Manifest
index 9809ec4e32e4..276439128213 100644
--- a/games-strategy/xscorch/Manifest
+++ b/games-strategy/xscorch/Manifest
@@ -1,8 +1,8 @@
-MD5 ed2145a7a24a12cca16661054a3d4c23 xscorch-0.2.0.ebuild 1052
-MD5 3df6bbb32e1c79f85ec0bb27fd0821a4 ChangeLog 1765
MD5 e9c1b03130f1e4097670bad914a1bde2 xscorch-0.1.16_rc2.ebuild 1711
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 bf6a18e8e4f45889c152d0fd6f7d066d xscorch-0.1.15.ebuild 1026
+MD5 11368348edd8758e923ff52d880bfe30 xscorch-0.2.0.ebuild 1143
+MD5 f5ea7000f0579a0295d4ff8dd060728b ChangeLog 1883
MD5 55df04a5274350d9163f058c65509b99 files/digest-xscorch-0.1.15 66
+MD5 92ea30d254ef58b265d00b82d021ab50 files/digest-xscorch-0.2.0 136
MD5 21b333517732c38ac13aff581866c2ba files/digest-xscorch-0.1.16_rc2 145
-MD5 7d56545602c4f4d87a31a7d0287b58b0 files/digest-xscorch-0.2.0 65
diff --git a/games-strategy/xscorch/files/digest-xscorch-0.2.0 b/games-strategy/xscorch/files/digest-xscorch-0.2.0
index 29669755642c..56ecc2ee71de 100644
--- a/games-strategy/xscorch/files/digest-xscorch-0.2.0
+++ b/games-strategy/xscorch/files/digest-xscorch-0.2.0
@@ -1 +1,2 @@
MD5 42862dbde1d0ebf87be30f7e04462a66 xscorch-0.2.0.tar.gz 818449
+MD5 00c6b5e67683ac8562488547659a72f3 xscorch-0.2.0-64bit.patch.gz 3122
diff --git a/games-strategy/xscorch/xscorch-0.2.0.ebuild b/games-strategy/xscorch/xscorch-0.2.0.ebuild
index 1fa1137b0ca0..49a8b6434223 100644
--- a/games-strategy/xscorch/xscorch-0.2.0.ebuild
+++ b/games-strategy/xscorch/xscorch-0.2.0.ebuild
@@ -1,32 +1,37 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.2.0.ebuild,v 1.2 2004/06/24 23:30:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.2.0.ebuild,v 1.3 2005/05/26 01:00:44 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="clone of the classic DOS game, 'Scorched Earth'"
-HOMEPAGE="http://chaos2.org/xscorch/"
-SRC_URI="http://chaos2.org/xscorch/${P}.tar.gz"
+HOMEPAGE="http://xscorch.org"
+SRC_URI="http://xscorch.org./releases/${P}.tar.gz
+ http://xscorch.org./releases/${P}-64bit.patch.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc alpha"
-IUSE="gtk mikmod gnome" #readline
+KEYWORDS="alpha ppc x86"
+IUSE="gnome gtk mikmod"
-#readline? ( sys-libs/readline )
DEPEND="gtk? ( =x11-libs/gtk+-1* )
mikmod? ( media-libs/libmikmod )
gnome? ( gnome-base/gnome-libs )"
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}/${P}-64bit.patch.gz"
+}
+
src_compile() {
#configure failed on readline support
egamesconf \
--enable-network \
--without-readline \
- `use_enable mikmod sound` \
- `use_with gtk` \
- `use_with gnome` \
- ${myconf} \
+ $(use_enable mikmod sound) \
+ $(use_with gtk) \
+ $(use_with gnome) \
|| die
emake || die "emake failed"
}
@@ -35,6 +40,6 @@ src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
# remove unneeded, empty directory
- rmdir ${D}/usr/games/include
+ rmdir "${D}"/usr/games/include
prepgamesdirs
}