summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/Manifest4
-rw-r--r--app-i18n/ibus/ibus-0.1.1.20080923.ebuild90
3 files changed, 100 insertions, 2 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 822a5008a284..ea19f6779fa6 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.4 2008/09/20 00:17:13 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.5 2008/09/24 12:07:11 matsuu Exp $
+
+*ibus-0.1.1.20080923 (24 Sep 2008)
+
+ 24 Sep 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-0.1.1.20080923.ebuild:
+ Version bumped.
20 Sep 2008; MATSUU Takuto <matsuu@gentoo.org>
-ibus-0.1.1.20080901.ebuild, -ibus-0.1.1.20080908.ebuild,
diff --git a/app-i18n/ibus/Manifest b/app-i18n/ibus/Manifest
index df92907f17b9..4887df4e36c9 100644
--- a/app-i18n/ibus/Manifest
+++ b/app-i18n/ibus/Manifest
@@ -1,4 +1,6 @@
DIST ibus-0.1.1.20080917.tar.gz 680616 RMD160 67aa19c7c45210722627f369374ec8aa1c4376e9 SHA1 9bfc70f0014cc8cfab7277ea4f0551a12334a4e7 SHA256 b9e5d19bfa5fd511d6d56605726ebe0eca220286e1be503d9e84b7b2271f1dd4
+DIST ibus-0.1.1.20080923.tar.gz 674530 RMD160 b1ab52d717ce00babce6093f76b1961b27ca55ea SHA1 12eba18cddcedeea2cb9746bc680a1d1bbd3c03d SHA256 c4b5e2e752106ef9fd9a42162b16246a8f461dc805054ae1be03131afa097f43
EBUILD ibus-0.1.1.20080917.ebuild 2250 RMD160 dd88dec6603a60ae74bf54a3484b620a3bfa3fe7 SHA1 601ac1d02d55629fbef8e0bf5d9b3864ab1309f4 SHA256 4336622cbab48f5ea399f1bfdab7a4d4a2f761ac1f115114b1b09c32b275f71e
-MISC ChangeLog 849 RMD160 1b9dcae1358cfe4ec7a2f0c259247cc1509d78e8 SHA1 bc19094b3101a87882775735316ff3b2a9bf1947 SHA256 96ed9d73b19d19f9307f4f2794cb8bca00f860d3f7b437f9630661ff584df381
+EBUILD ibus-0.1.1.20080923.ebuild 2270 RMD160 ab8c46a894dcec5bc6eef356965abfd24862c7a7 SHA1 a7f420d626787911bf5ea55774ab27d2cfcaee9e SHA256 189db4d556699dcde7e7c66787f3e38c81c37e876026f69ba2b42ad72fb3c2b3
+MISC ChangeLog 984 RMD160 df35b4dcfd8fa1143581a8138b7e1693f0cb4199 SHA1 667861c87f9e0a21bf0569f99a78bd05d3e1280e SHA256 6d3055691d2e964bc247227cf4fa7cfff19dca306fb9298564279d54e1fa4d49
MISC metadata.xml 413 RMD160 78bf392cb0f922f9b1dbc39475d27dc90bd5c3e8 SHA1 8a2bcbd11ee50f43bd1211c6e484fe16126debe1 SHA256 fc7288848e696d0b27471658ee44467d2cdc7d7d40d38287cafa1299c20e00d4
diff --git a/app-i18n/ibus/ibus-0.1.1.20080923.ebuild b/app-i18n/ibus/ibus-0.1.1.20080923.ebuild
new file mode 100644
index 000000000000..60d7a5e36c80
--- /dev/null
+++ b/app-i18n/ibus/ibus-0.1.1.20080923.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-0.1.1.20080923.ebuild,v 1.1 2008/09/24 12:07:11 matsuu Exp $
+
+EAPI="1"
+inherit multilib
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls qt4"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ dev-libs/dbus-glib
+ qt4? ( || (
+ (
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ )
+ >=x11-libs/qt-4.4:4
+ ) )
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg
+ dev-python/gconf-python"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable qt4 qt4-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bug to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog "2. Set the following in your"
+ elog " user startup scripts such as .xinitrc or .bashrc"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"ibus\""
+ elog " ibus &"
+ elog
+ if ! use qt4; then
+ ewarn "Missing qt4 use flag, ibus will not work in qt4 applications."
+ ebeep 3
+ fi
+ elog
+
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+pkg_postrm() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}