summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/kpopup/ChangeLog5
-rw-r--r--net-im/kpopup/Manifest6
-rw-r--r--net-im/kpopup/kpopup-0.9.7.ebuild28
3 files changed, 28 insertions, 11 deletions
diff --git a/net-im/kpopup/ChangeLog b/net-im/kpopup/ChangeLog
index 917ae1fffb23..9843a2e8753d 100644
--- a/net-im/kpopup/ChangeLog
+++ b/net-im/kpopup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/kpopup
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kpopup/ChangeLog,v 1.4 2004/06/29 16:50:37 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kpopup/ChangeLog,v 1.5 2004/07/31 15:25:19 centic Exp $
+
+ 31 Jul 2004; Dominik Stadler <centic@gentoo.org> kpopup-0.9.7.ebuild:
+ Add einfo and create missing dir, reported in Bug 56633, thanks.
*kpopup-0.9.7 (29 Jun 2004)
diff --git a/net-im/kpopup/Manifest b/net-im/kpopup/Manifest
index 1e07cc37d02f..de562ecc5e74 100644
--- a/net-im/kpopup/Manifest
+++ b/net-im/kpopup/Manifest
@@ -1,6 +1,6 @@
-MD5 6950855d4009b56d545c22ac2d1f107b ChangeLog 605
-MD5 f2e0aea979ba778380fd81501cde1780 kpopup-0.9.6_pre1.ebuild 501
+MD5 6c74aecfcb2c74f1059c65224850cf68 ChangeLog 746
+MD5 c380233114d3f82728c92d547d3f4c74 kpopup-0.9.7.ebuild 916
MD5 1b6808bbd78c9161f8b7efb090d966f8 metadata.xml 162
-MD5 8285555c5c0b421db0d5bc5a6748077d kpopup-0.9.7.ebuild 501
+MD5 f2e0aea979ba778380fd81501cde1780 kpopup-0.9.6_pre1.ebuild 501
MD5 98669fef3c4d089a9a387e84dd5c8884 files/digest-kpopup-0.9.6_pre1 68
MD5 f286f8494aae2ec4b2ad6ea845aeb18e files/digest-kpopup-0.9.7 64
diff --git a/net-im/kpopup/kpopup-0.9.7.ebuild b/net-im/kpopup/kpopup-0.9.7.ebuild
index 6ae24061cffb..db5fc169ba43 100644
--- a/net-im/kpopup/kpopup-0.9.7.ebuild
+++ b/net-im/kpopup/kpopup-0.9.7.ebuild
@@ -1,20 +1,34 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kpopup/kpopup-0.9.7.ebuild,v 1.2 2004/06/29 16:50:37 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kpopup/kpopup-0.9.7.ebuild,v 1.3 2004/07/31 15:25:19 centic Exp $
inherit kde
-MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
-
DESCRIPTION="An SMB Network Messenger"
HOMEPAGE="http://www.henschelsoft.de/kpopup.html"
-SRC_URI="http://www.henschelsoft.de/kpopup/${MY_P}.tar.gz"
+SRC_URI="http://www.henschelsoft.de/kpopup/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
IUSE=""
-DEPEND=">=net-fs/samba"
-need-kde 3 \ No newline at end of file
+DEPEND=">=net-fs/samba-2.2"
+need-kde 3
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+# make DESTDIR=${D} create_kpopup_data_dir || die "create data dir failed"
+ diropts -m0777
+ dodir /var/lib/kpopup
+ diropts -m0755
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Locate the [global] section of your Samba configuration file (smb.conf) and"
+ einfo "add the following line:"
+ einfo ""
+ einfo "message command = sh -c '/usr/bin/receivepopup.sh \"%s\" \"%f\"'"
+ einfo ""
+}