summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/lhinv/lhinv-1.1-r1.ebuild4
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r1.ebuild4
-rw-r--r--app-shells/esh/esh-0.8-r1.ebuild6
-rw-r--r--app-shells/pdksh/pdksh-5.2.14-r1.ebuild4
-rw-r--r--app-shells/psh/psh-0.008-r1.ebuild4
-rw-r--r--app-shells/sash/sash-3.4-r2.ebuild6
-rw-r--r--app-shells/tcsh/tcsh-6.09-r1.ebuild5
-rw-r--r--app-shells/zsh/zsh-3.1.9.ebuild6
8 files changed, 31 insertions, 8 deletions
diff --git a/app-misc/lhinv/lhinv-1.1-r1.ebuild b/app-misc/lhinv/lhinv-1.1-r1.ebuild
index ca8849d68975..a5cf342f74dd 100644
--- a/app-misc/lhinv/lhinv-1.1-r1.ebuild
+++ b/app-misc/lhinv/lhinv-1.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lhinv/lhinv-1.1-r1.ebuild,v 1.3 2000/09/15 20:08:45 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lhinv/lhinv-1.1-r1.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
P=lhinv-1.1
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="Linux Hardware Inventory"
SRC_URI="http://download.sourceforge.net/lhinv/"${A}
HOMEPAGE="http://lhinv.sourceforge.net"
+DEPEND=">=sys-devel/perl-5"
+
src_compile() {
cd ${S}/cgi
cp w3hinv w3hinv.orig
diff --git a/app-shells/ccsh/ccsh-0.0.4-r1.ebuild b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
index 5b26954ec653..7bbbdd5ee72f 100644
--- a/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
+++ b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r1.ebuild,v 1.4 2000/10/05 00:12:58 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r1.ebuild,v 1.5 2000/11/01 04:44:12 achim Exp $
P=ccsh-0.0.4
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="UNIX Shell for people already familiar with the C language"
SRC_URI="http://download.sourceforge.net/ccsh/"${A}
HOMEPAGE="http://ccsh.sourceforge.net"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
src_compile() {
cd ${S}
diff --git a/app-shells/esh/esh-0.8-r1.ebuild b/app-shells/esh/esh-0.8-r1.ebuild
index 2c11af55a4dc..c83a5316cd19 100644
--- a/app-shells/esh/esh-0.8-r1.ebuild
+++ b/app-shells/esh/esh-0.8-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r1.ebuild,v 1.3 2000/09/15 20:08:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r1.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
P=esh-0.8
A=${P}.tar.gz
@@ -10,6 +10,10 @@ DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
SRC_URI="http://esh.netpedia.net/"${A}
HOMEPAGE="http://esh.netpedia.net/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
src_compile() {
cd ${S}
cp Makefile Makefile.orig
diff --git a/app-shells/pdksh/pdksh-5.2.14-r1.ebuild b/app-shells/pdksh/pdksh-5.2.14-r1.ebuild
index 15ae727b62b1..256898cd552c 100644
--- a/app-shells/pdksh/pdksh-5.2.14-r1.ebuild
+++ b/app-shells/pdksh/pdksh-5.2.14-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r1.ebuild,v 1.3 2000/09/15 20:08:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r1.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
P=pdksh-5.2.14
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="The Public Domain Korn Shell"
SRC_URI="ftp://ftp.cs.mun.ca/pub/pdksh/"${A}
HOMEPAGE="http://ww.cs.mun.ca/~michael/pdksh/"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
src_compile() {
cd ${S}
try ./configure --prefix=/usr --host=${CHOST}
diff --git a/app-shells/psh/psh-0.008-r1.ebuild b/app-shells/psh/psh-0.008-r1.ebuild
index 6d80207bc6c8..c686a840e9cb 100644
--- a/app-shells/psh/psh-0.008-r1.ebuild
+++ b/app-shells/psh/psh-0.008-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.008-r1.ebuild,v 1.4 2000/10/05 00:12:58 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.008-r1.ebuild,v 1.5 2000/11/01 04:44:12 achim Exp $
P=psh-0.008
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="Combines the interactive nature of a Unix shell with the power of P
SRC_URI="http://www.focusresearch.com/gregor/psh/"${A}
HOMEPAGE="http://www.focusresearch.com/gregor/psh/"
+DEPEND=">=sys-devel/perl-5"
+
src_compile() {
cd ${S}
perl Makefile.PL $PERLINSTALL
diff --git a/app-shells/sash/sash-3.4-r2.ebuild b/app-shells/sash/sash-3.4-r2.ebuild
index e98fd3f513e4..71ca950bea6d 100644
--- a/app-shells/sash/sash-3.4-r2.ebuild
+++ b/app-shells/sash/sash-3.4-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.3 2000/09/15 20:08:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r2.ebuild,v 1.4 2000/11/01 04:44:12 achim Exp $
P=sash-3.4
A="${P}.tar.gz sash-3.x-readline.diff.gz"
@@ -10,6 +10,10 @@ DESCRIPTION="A small UNIX Shell with readline suppport"
SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/zlib-1.1.3
+ >=sys-libs/readline-4.1"
+
HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
src_unpack() {
diff --git a/app-shells/tcsh/tcsh-6.09-r1.ebuild b/app-shells/tcsh/tcsh-6.09-r1.ebuild
index a1baa0a3cbb6..e566daef5646 100644
--- a/app-shells/tcsh/tcsh-6.09-r1.ebuild
+++ b/app-shells/tcsh/tcsh-6.09-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.09-r1.ebuild,v 1.5 2000/10/23 11:27:12 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.09-r1.ebuild,v 1.6 2000/11/01 04:44:12 achim Exp $
P=tcsh-6.09
A=${P}.tar.gz
@@ -9,6 +9,9 @@ S=${WORKDIR}/${P}.00
DESCRIPTION="The standard GNU Bourne again shell"
#ugh, astron.com doesn't support passive ftp... maybe another source?
SRC_URI="ftp://ftp.astron.com/pub/tcsh/"${A}
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
src_compile() {
cd ${S}
diff --git a/app-shells/zsh/zsh-3.1.9.ebuild b/app-shells/zsh/zsh-3.1.9.ebuild
index 93ceefe0c647..1a94d8c44787 100644
--- a/app-shells/zsh/zsh-3.1.9.ebuild
+++ b/app-shells/zsh/zsh-3.1.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-3.1.9.ebuild,v 1.2 2000/09/15 20:08:46 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-3.1.9.ebuild,v 1.3 2000/11/01 04:44:12 achim Exp $
P=zsh-3.1.9
A=${P}.tar.gz
@@ -10,6 +10,10 @@ DESCRIPTION="UNIX Shell similar to the Korn shell"
SRC_URI="ftp://ftp.zsh.org/pub/"${A}
HOMEPAGE="www.zsh.org/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
src_compile() {
cd ${S}
try ./configure --prefix=/ --mandir=/usr/man --infodir=/usr/info --host=${CHOST}