summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/aumix/ChangeLog8
-rw-r--r--media-sound/aumix/Manifest16
-rw-r--r--media-sound/aumix/files/aumix.rc68
3 files changed, 23 insertions, 9 deletions
diff --git a/media-sound/aumix/ChangeLog b/media-sound/aumix/ChangeLog
index d3382081ce21..4e35f60913cb 100644
--- a/media-sound/aumix/ChangeLog
+++ b/media-sound/aumix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/aumix
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.48 2004/12/29 01:09:48 ciaranm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.49 2005/07/07 19:36:39 eradicator Exp $
+
+ 07 Jul 2005; Jeremy Huddleston <eradicator@gentoo.org> files/aumix.rc6:
+ Updated init script to work with sparc audio. Closes bug #84412 thanks to
+ Peter Schloemer <dapete@dapete.de>.
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/media-sound/aumix/Manifest b/media-sound/aumix/Manifest
index 117bce3c68b3..f828ee463106 100644
--- a/media-sound/aumix/Manifest
+++ b/media-sound/aumix/Manifest
@@ -1,10 +1,20 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 cb709e469cc3b60af59e1a8ffa21a8b8 ChangeLog 5981
MD5 92391e16e18a77102b7975e5dc1ce49d aumix-2.8-r2.ebuild 1848
-MD5 a93bd06c7b7f49617eff4ff143aef1d1 ChangeLog 5789
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 857a1fe260905ab09b7befd877affafd files/digest-aumix-2.8-r2 62
MD5 00da88dc336799f1385f518dd005dd5a files/aumix-2.8-close-dialogs.patch 613
MD5 a685fd4f0649bfb0c7fd4860eda0caa7 files/aumix-2.8-nls.patch 829
-MD5 8e3a1693ed2d3ff2941578494362b0a7 files/aumix.rc6 1140
MD5 6c8d691beb495257d8309e58c127acd2 files/aumix-2.8-nohome.patch 529
MD5 221509621be1606c1a61dfc8fcd4991e files/aumix-2.8-save_load.patch 1331
MD5 f39abfbf49ff4a33e109eeb14a4325c2 files/aumix.desktop 124
+MD5 a1f578192b59b3535a982ff7dd9e2643 files/aumix.rc6 1151
+MD5 857a1fe260905ab09b7befd877affafd files/digest-aumix-2.8-r2 62
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCzYSPArHZZzCEUG0RAhIbAJ44pZmpkO12MwWZuaHnBqFSbhEA/ACdHgsj
+BlNO1k9OpqMwxkzHcbmrPbk=
+=4iYi
+-----END PGP SIGNATURE-----
diff --git a/media-sound/aumix/files/aumix.rc6 b/media-sound/aumix/files/aumix.rc6
index bdfdfbfcc192..21430103ec8a 100644
--- a/media-sound/aumix/files/aumix.rc6
+++ b/media-sound/aumix/files/aumix.rc6
@@ -1,14 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/files/aumix.rc6,v 1.9 2004/10/31 10:17:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/files/aumix.rc6,v 1.10 2005/07/07 19:36:39 eradicator Exp $
depend() {
use modules hotplug coldplug alsasound
}
checkconfig() {
- if [ -z "`egrep 'sound|OSS' /proc/devices`" ] && [ ! -d /proc/asound ]
+ if ! grep -q 'sound|OSS|sparcaudio' /proc/devices && [[ ! -d /proc/asound ]]
then
eerror "Sound support has not been compiled into the kernel,"
eerror "or is disabled. Please check that the correct modules"
@@ -16,7 +16,7 @@ checkconfig() {
return 1
fi
# /dev/mixer can be a symlink
- if [ ! -e /dev/mixer ] ; then
+ if [[ ! -e /dev/mixer ]] ; then
eerror "/dev/mixer does not exist, please create it, or load the"
eerror "correct modules to enable your card's mixer"
return 1
@@ -25,7 +25,7 @@ checkconfig() {
start() {
checkconfig || return 1
- if [ -f /etc/aumixrc ] ; then
+ if [[ -f /etc/aumixrc ]] ; then
ebegin "Loading Mixer settings"
/usr/bin/aumix -f /etc/aumixrc -L >/dev/null 2>&1
else