summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vmware-workstation/ChangeLog12
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230/90vmware3
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230/VMwareWorkstation.desktop12
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230/vmware73
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230/vmware.pngbin0 -> 470 bytes
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.22301
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230.ebuild175
7 files changed, 273 insertions, 3 deletions
diff --git a/app-emulation/vmware-workstation/ChangeLog b/app-emulation/vmware-workstation/ChangeLog
index a2a2a8bdc0e8..88c3baf9e801 100644
--- a/app-emulation/vmware-workstation/ChangeLog
+++ b/app-emulation/vmware-workstation/ChangeLog
@@ -1,14 +1,20 @@
# ChangeLog for app-emulation/vmware-workstation
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.4 2002/08/31 18:54:54 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/ChangeLog,v 1.5 2002/09/16 20:24:30 prez Exp $
+
+*vmware-workstation-3.2.0.2230 (2002/9/16)
+
+ 16 Sep 2002; Preston A. Elder <prez@gentoo.org> :
+
+ Added VMware 3.2.0 (2230), a direct copy of 3.1.1 (1790).
+
+*vmware-workstation-3.1.1.1790 (2002/4/13)
31 Aug 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
Fix part of bug #5359: remove deprecated KDE2DIR, KDE3DIR variables and
install into /usr
-*vmware-workstation-3.1.1.1790 (2002/4/13)
-
06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
Added -ppc -sparc -sparc64 to keywords
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230/90vmware b/app-emulation/vmware-workstation/files/3.2.0.2230/90vmware
new file mode 100644
index 000000000000..8e00d2bb0587
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.0.2230/90vmware
@@ -0,0 +1,3 @@
+PATH=/opt/vmware/bin
+ROOTPATH=/opt/vmware/bin
+MANPATH=/opt/vmware/man
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230/VMwareWorkstation.desktop b/app-emulation/vmware-workstation/files/3.2.0.2230/VMwareWorkstation.desktop
new file mode 100644
index 000000000000..9e42f9c1b4c6
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.0.2230/VMwareWorkstation.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=VMware Workstation
+Comment=VMware Workstation
+GenericName=Virtual PC Emulator
+Exec=vmware
+Icon=/opt/vmware/lib/icon/vmware.png
+Path=
+Terminal=0
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230/vmware b/app-emulation/vmware-workstation/files/3.2.0.2230/vmware
new file mode 100644
index 000000000000..8183578d7ba5
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.0.2230/vmware
@@ -0,0 +1,73 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/3.2.0.2230/vmware,v 1.1 2002/09/16 20:24:30 prez Exp $
+
+depend() {
+ need localmount net
+ use logger
+}
+
+vmware-prettify() {
+ # Yea, the code is ugly but the output is pretty
+ state=$1
+ waserror=0
+ msgtype=0
+ while read line
+ do
+ [ "$line" == "" ] && continue
+ if [ "$msgtype" -le "0" ]
+ then
+ if [ "$msgtype" == "-1" ]
+ then
+ ewarn $line
+ continue
+ fi
+ if [ "${line/*:*/}" == "" ]
+ then
+ einfon $line
+ echo
+ eend 0
+ msgtype=1
+ else
+ ewarn $line
+ msgtype=-1
+ waserror=1
+ fi
+ continue
+ fi
+
+ # Strip out anything after the <esc> code
+ message=`echo $line | sed -e "s/^\(.*\).*$/\1/"`
+ einfon " $message"
+ echo
+
+ echo $line | grep done > /dev/null
+ status=$?
+ eend $status
+
+ if [ "$status" != "0" ]
+ then
+ logger -p local0.err -t vmware-${state} "$line"
+ waserror=$status
+ fi
+ done
+ if [ "$msgtype" == "-1" ]
+ then
+ eend 1 "VMware is not properly configured! See above."
+ fi
+ return $waserror
+}
+
+start() {
+ test -x /etc/vmware/init.d/vmware || \
+ eend 1 "vmware init script not found. Aborting" || return 1
+
+ /etc/vmware/init.d/vmware start | vmware-prettify start
+ return $?
+}
+
+stop() {
+ /etc/vmware/init.d/vmware stop | vmware-prettify stop
+ return $?
+}
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230/vmware.png b/app-emulation/vmware-workstation/files/3.2.0.2230/vmware.png
new file mode 100644
index 000000000000..06672aa3f0bf
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.0.2230/vmware.png
Binary files differ
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230
new file mode 100644
index 000000000000..3fcf4a53a48b
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230
@@ -0,0 +1 @@
+MD5 be6a12e7c835d027adfe533e1744759e VMware-workstation-3.2.0-2230.tar.gz 12575521
diff --git a/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230.ebuild b/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230.ebuild
new file mode 100644
index 000000000000..e589a3952a4c
--- /dev/null
+++ b/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-3.2.0.2230.ebuild,v 1.1 2002/09/16 20:24:30 prez Exp $
+
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators."
+S=${WORKDIR}/vmware-distrib
+NP="VMware-workstation-3.2.0-2230"
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VM Ware. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+SRC_PATH0="http://vmware-svca.www.conxion.com/software"
+SRC_PATH1="http://www.vmware.com/download1/software"
+SRC_PATH2="ftp://download1.vmware.com/pub/software"
+SRC_PATH3="http://vmware-chil.www.conxion.com/software"
+SRC_PATH4="http://vmware-heva.www.conxion.com/software"
+SRC_PATH5="http://vmware.wespe.de/software"
+SRC_PATH6="ftp://vmware.wespe.de/pub/software"
+
+SRC_URI="$SRC_PATH0/${NP}.tar.gz
+ $SRC_PATH1/${NP}.tar.gz
+ $SRC_PATH2/${NP}.tar.gz
+ $SRC_PATH3/${NP}.tar.gz
+ $SRC_PATH4/${NP}.tar.gz
+ $SRC_PATH5/${NP}.tar.gz
+ $SRC_PATH6/${NP}.tar.gz"
+
+HOMEPAGE="http://www.vmware.com/products/desktop/ws_features.html"
+SLOT="0"
+LICENSE="vmware"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="virtual/glibc virtual/x11 sys-kernel/linux-headers
+ >=sys-devel/perl-5 ~dev-lang/tcl-8.3.3"
+#debug is needed to prevent a segfault from stripping vmware executables
+export DEBUG="yes"
+RESTRICT="nostrip"
+
+src_install () {
+ # Copy:
+ dodir /opt/vmware/bin
+ cp -a bin/* ${D}/opt/vmware/bin/
+ # vmware and vmware-ping needs to be suid root.
+ chmod u+s ${D}/opt/vmware/bin/vmware
+ chmod u+s ${D}/opt/vmware/bin/vmware-ping
+
+ dodir /opt/vmware/lib
+ cp -a lib/* ${D}/opt/vmware/lib/
+ # Since with Gentoo we compile everthing it doesn't make sense to keep
+ # the precompiled modules arround. Saves about 4 megs of disk space too.
+ rm -rf ${D}/opt/vmware/lib/modules/binary
+
+ dodir /opt/vmware/doc
+ cp -a doc/* ${D}/opt/vmware/doc/
+
+ dodir /opt/vmware/man/
+ cp -a man/* ${D}/opt/vmware/man/
+
+ # vmware service loader
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/vmware vmware
+
+ # vmware enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/90vmware
+
+ dodir /etc/vmware/
+ cp -a etc/* ${D}/etc/vmware/
+
+ dodir /etc/vmware/init.d
+ dodir /etc/vmware/init.d/rc0.d
+ dodir /etc/vmware/init.d/rc1.d
+ dodir /etc/vmware/init.d/rc2.d
+ dodir /etc/vmware/init.d/rc3.d
+ dodir /etc/vmware/init.d/rc4.d
+ dodir /etc/vmware/init.d/rc5.d
+ dodir /etc/vmware/init.d/rc6.d
+ cp -a installer/services.sh ${D}/etc/vmware/init.d/vmware
+
+ # This is to fix a problem where if someone merges vmware and then
+ # before configuring vmware they upgrade or re-merge the vmware
+ # package which would rmdir the /etc/vmware/init.d/rc?.d directories.
+ touch ${D}/etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d/.keep
+
+ # A simple icon I made
+ dodir /opt/vmware/lib/icon
+ insinto /opt/vmware/lib/icon
+ doins ${FILESDIR}/${PVR}/vmware.png
+
+ if [ "`use kde`" ]
+ then
+ # KDE 2 - not supported anymore
+ # recent setups:
+ dodir /usr/share/applnk/Applications
+ insinto /usr/share/applnk/Applications
+ doins "${FILESDIR}/${PVR}/VMwareWorkstation.desktop"
+ fi
+
+ # Questions:
+ einfo "Adding answers to /etc/vmware/locations"
+ locations="${D}/etc/vmware/locations"
+ echo "answer BINDIR /opt/vmware/bin" >> ${locations}
+ echo "answer LIBDIR /opt/vmware/lib" >> ${locations}
+ echo "answer MANDIR /opt/vmware/man" >> ${locations}
+ echo "answer DOCDIR /opt/vmware/doc" >> ${locations}
+ echo "answer RUN_CONFIGURATOR no" >> ${locations}
+ echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
+ echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
+}
+
+pkg_preinst () {
+ # This must be done after the install to get the mtimes on each file
+ # right. This perl snippet gets the /etc/vmware/locations file code:
+ # perl -e "@a = stat('bin/vmware'); print \$a[9]"
+ # The above perl line and the find line below output the same thing.
+ # I would think the find line is faster to execute.
+ # find /opt/vmware/bin/vmware -printf %T@
+
+ #Note: it's a bit weird to use ${D} in a preinst script but it should work
+ #(drobbins, 1 Feb 2002)
+
+ einfo "Generating /etc/vmware/locations file."
+ d=`echo ${D} | wc -c`
+ for x in `find ${D}/opt/vmware ${D}/etc/vmware`
+ do
+ x="`echo ${x} | cut -c ${d}-`"
+ if [ -d ${D}/${x} ]
+ then
+ echo "directory ${x}" >> ${D}/etc/vmware/locations
+ else
+ echo -n "file ${x}" >> ${D}/etc/vmware/locations
+ if [ "${x}" == "/etc/vmware/locations" ]
+ then
+ echo "" >> ${D}/etc/vmware/locations
+ elif [ "${x}" == "/etc/vmware/not_configured" ]
+ then
+ echo "" >> ${D}/etc/vmware/locations
+ else
+ echo -n " " >> ${D}/etc/vmware/locations
+ #perl -e "@a = stat('${D}${x}'); print \$a[9]" >> ${D}/etc/vmware/locations
+ find ${D}${x} -printf %T@ >> ${D}/etc/vmware/locations
+ echo "" >> ${D}/etc/vmware/locations
+ fi
+ fi
+ done
+}
+
+pkg_postinst () {
+ # This is to fix the problem where the not_configured file doesn't get
+ # removed when the configuration is run. This doesn't remove the file
+ # It just tells the vmware-config.pl script it can delete it.
+ einfo "Updating /etc/vmware/locations"
+ for x in /etc/vmware/._cfg????_locations
+ do
+ if [ -f $x ]
+ then
+ cat $x >> /etc/vmware/locations
+ rm $x
+ fi
+ done
+
+ einfo "Activating vmware init scripts..."
+ rc-update add vmware default
+ einfo
+ einfo "You need to run /opt/vmware/bin/vmware-config.pl to complete the install."
+ einfo
+}
+
+pkg_postrm () {
+ einfo
+ einfo "To remove all traces of vmware you will need to remove the files"
+ einfo "in /etc/vmware/, /etc/init.d/vmware, /lib/modules/*/misc/vm*.o,"
+ einfo "and .vmware/ in each users home directory."
+ einfo
+}