summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-sports/xmoto/ChangeLog8
-rw-r--r--games-sports/xmoto/files/digest-xmoto-0.2.2-r13
-rw-r--r--games-sports/xmoto/xmoto-0.2.2-r1.ebuild60
3 files changed, 70 insertions, 1 deletions
diff --git a/games-sports/xmoto/ChangeLog b/games-sports/xmoto/ChangeLog
index 7ae9967b4f38..a519f50d93f8 100644
--- a/games-sports/xmoto/ChangeLog
+++ b/games-sports/xmoto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/xmoto
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.8 2006/11/13 02:52:25 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/ChangeLog,v 1.9 2006/12/16 08:51:12 nyhm Exp $
+
+*xmoto-0.2.2-r1 (16 Dec 2006)
+
+ 16 Dec 2006; Tristan Heaven <nyhm@gentoo.org> -xmoto-0.2.2.ebuild,
+ +xmoto-0.2.2-r1.ebuild:
+ Fix nls support and web access, bug #158089
13 Nov 2006; Luis Medinas <metalgod@gentoo.org> xmoto-0.2.0.ebuild:
Stable on amd64. Closes bug #153468.
diff --git a/games-sports/xmoto/files/digest-xmoto-0.2.2-r1 b/games-sports/xmoto/files/digest-xmoto-0.2.2-r1
new file mode 100644
index 000000000000..f86dd5405352
--- /dev/null
+++ b/games-sports/xmoto/files/digest-xmoto-0.2.2-r1
@@ -0,0 +1,3 @@
+MD5 bbf2f0c02ba2ffe1f65e4ca78b0a0bd3 xmoto-0.2.2-src.tar.gz 5938064
+RMD160 c86df47c61f5755858e3294d12ad3ecee6b16aec xmoto-0.2.2-src.tar.gz 5938064
+SHA256 478b9f54c79878f3ff384298b8679f6aece1069b8d41bcdd66dc1951fe803648 xmoto-0.2.2-src.tar.gz 5938064
diff --git a/games-sports/xmoto/xmoto-0.2.2-r1.ebuild b/games-sports/xmoto/xmoto-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..c8a3081518a5
--- /dev/null
+++ b/games-sports/xmoto/xmoto-0.2.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/xmoto/xmoto-0.2.2-r1.ebuild,v 1.1 2006/12/16 08:51:12 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="A challenging 2D motocross platform game"
+HOMEPAGE="http://xmoto.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ net-misc/curl
+ dev-lang/lua
+ dev-games/ode
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./*.gz
+
+ sed -i 's:xmoto.free.fr:xmoto.tuxfamily.org:' src/WWW.h \
+ || die "sed WWW.h failed"
+
+ sed -i 's:$(localedir):/usr/share/locale:' po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-localesdir=/usr/share/locale \
+ $(use_enable nls) \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doman xmoto{,-edit}.6
+ dodoc README TODO ChangeLog
+
+ doicon extra/xmoto.xpm
+ domenu extra/xmoto{,-edit}.desktop
+
+ prepgamesdirs
+}