summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.15.ebuild42
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.15.ebuild69
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.15.ebuild44
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.15.ebuild70
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.15.ebuild41
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.15.ebuild45
-rw-r--r--dev-ruby/mocha/Manifest14
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.0.15.ebuild50
-rw-r--r--dev-ruby/railties/ChangeLog7
-rw-r--r--dev-ruby/railties/railties-3.0.15.ebuild47
17 files changed, 461 insertions, 18 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index ac9b9d835760..aa2648cebd20 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.189 2012/06/13 06:25:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.190 2012/06/13 17:42:54 graaff Exp $
+
+*actionmailer-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*actionmailer-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.15.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.15.ebuild
new file mode 100644
index 000000000000..8f7405c717d6
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.15.ebuild,v 1.1 2012/06/13 17:42:54 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.19"
+ruby_add_bdepend "test? (
+ =dev-ruby/mocha-0.10.5
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Rename private method to avoid conflict with the simple_format
+ # TextHelper. Already fixed in Rails 3.1.
+ sed -i -e 's/simple_format/format_paragraph/' lib/action_mailer/mail_helper.rb || die
+}
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 4807c172c732..db492929bec8 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.207 2012/06/13 06:24:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.208 2012/06/13 17:42:31 graaff Exp $
+
+*actionpack-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*actionpack-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/actionpack/actionpack-3.0.15.ebuild b/dev-ruby/actionpack/actionpack-3.0.15.ebuild
new file mode 100644
index 000000000000..bd1ba4662431
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.15.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.15.ebuild,v 1.1 2012/06/13 17:42:31 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2:0
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.5.0:0.5
+ >=dev-ruby/rack-1.2.5:1.2
+ >=dev-ruby/rack-mount-0.6.14:0.6
+ >=dev-ruby/rack-test-0.5.7:0.5
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ =dev-ruby/mocha-0.10.5
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\)/d' ../Gemfile || die
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' actionpack.gemspec || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+
+ # Ignore one failure that does not seem to be caused by changes in
+ # this version of Rails and that is unlikely to get upstream
+ # attention due to this version being old.
+ sed -i -e '/rendering a partial in an RJS template should pick the JS template over the HTML one/, / end/ s:^:#:' test/controller/new_base/render_rjs_test.rb || die
+}
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 32f144ee1ccb..a16aed5c0221 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.29 2012/06/13 06:23:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.30 2012/06/13 17:41:03 graaff Exp $
+
+*activemodel-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activemodel-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activemodel/activemodel-3.0.15.ebuild b/dev-ruby/activemodel/activemodel-3.0.15.ebuild
new file mode 100644
index 000000000000..4d7fa89543f6
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.15.ebuild,v 1.1 2012/06/13 17:41:03 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.5.0:0.5"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index cc6f3048b451..ce0307517299 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.186 2012/06/13 06:26:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.187 2012/06/13 17:43:17 graaff Exp $
+
+*activerecord-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activerecord-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activerecord-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activerecord/activerecord-3.0.15.ebuild b/dev-ruby/activerecord/activerecord-3.0.15.ebuild
new file mode 100644
index 000000000000..cc45b263bb72
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.15.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.15.ebuild,v 1.1 2012/06/13 17:43:17 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ =dev-ruby/mocha-0.10.5
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+# sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\)/d' ../Gemfile || die
+# sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+# sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+ sed -i -e '/\(system_timer\|horo\|faker\|rbench\|ruby-debug\|pg\)/d' ../Gemfile || die
+
+ # Loosen erubis dependency since this is not slotted.
+ sed -i -e 's/~> 2.6.6/>= 2.6.6/' ../actionpack/actionpack.gemspec || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index acc2b64c1ec6..84ff8cb92a09 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.111 2012/06/13 06:24:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.112 2012/06/13 17:41:26 graaff Exp $
+
+*activeresource-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activeresource-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activeresource/activeresource-3.0.15.ebuild b/dev-ruby/activeresource/activeresource-3.0.15.ebuild
new file mode 100644
index 000000000000..d83530c92ebe
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.15.ebuild,v 1.1 2012/06/13 17:41:26 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 75a321fb3266..0bd874d7d72f 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.172 2012/06/13 06:23:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.173 2012/06/13 17:40:36 graaff Exp $
+
+*activesupport-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*activesupport-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.0.15.ebuild b/dev-ruby/activesupport/activesupport-3.0.15.ebuild
new file mode 100644
index 000000000000..a9cf1d05bc30
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.15.ebuild,v 1.1 2012/06/13 17:40:36 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri =dev-ruby/mocha-0.10.5 )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/mocha/Manifest b/dev-ruby/mocha/Manifest
index d8df6ec65b92..b7a3bbea6764 100644
--- a/dev-ruby/mocha/Manifest
+++ b/dev-ruby/mocha/Manifest
@@ -1,24 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
-DIST mocha-0.10.0.gem 71168 RMD160 96075a586c50e8fdadd3017ef72b2b4bc48c5e27 SHA1 9fe4c957e1eb1634d97e8621ce62e3e8330b7ec7 SHA256 dd07d585a48603f475d1d10d22ac46bca11d4ab5366cd8095af4d43e9c183a06
-DIST mocha-0.10.3.gem 72192 RMD160 a623b882f403e3512bfa70251a3f338dda55625a SHA1 2369aa772502842ade413b3895358b1e82eb8c61 SHA256 92213fafe4c15469dabb77e92cee8a1dc5ec02a409dec8607b2e727aab271dbf
DIST mocha-0.10.5.gem 73728 RMD160 5e29c4701db4fdd90012cf3e1c4ebe46a254e972 SHA1 b3490deeb5a2e50b86df3cdacf27f19b67fc6f3f SHA256 cb511ef036cf411a128175e0dca69081d97a58ec70beff5077f87d74eda6940a
DIST mocha-0.11.4.gem 75776 RMD160 9d316ce200f56483829d14f30f420364151e1add SHA1 9890bf985e62e92c7b2fdf61771f0f6f451a80e8 SHA256 12e901203211af113231d539c92390d456d2f0be37339917b5a35efbee6bb3cc
-DIST mocha-0.9.10.gem 66048 RMD160 84e21fd238f0e6a768cef3cad5ddfebdb8ba5625 SHA1 d4800469173efb69183f2f5598f2ed528bafe8cd SHA256 8ad43f1fd75659c01b63e0e36a5fdfbe1a6a79e20c4bab12feced2bd938f9b15
DIST mocha-0.9.12.gem 67584 RMD160 e15617c7074d1e7fea24f5344341a805bbbbc3df SHA1 9608f143af20514be95ac4385f693f9fe865acb6 SHA256 2fc7e3e00e920772b5a5cba16809b567f6f623f62e5c3c95f5c51d0935575f8f
-EBUILD mocha-0.10.0.ebuild 1088 RMD160 f057bab09cd124af58b731f4dac434cca68f157c SHA1 db6a44082ec87a28c9ab320220393acb3d64ddd9 SHA256 b501d970eb45ad217d27426dc0797c612ff0e77ebc9c789f8be2bf5e95522f9e
-EBUILD mocha-0.10.3.ebuild 1186 RMD160 1f3ea2c562bf1e93b972e506c1cdca74ad3e7e12 SHA1 889d9d0d38dc543d1087bba6355ed1ddaa737896 SHA256 0240c5e10b36cad4406b5f18a48eb0bb82d3221419292024ec1012f531d40f2e
EBUILD mocha-0.10.5.ebuild 1202 RMD160 8c96931a9c1bb3b02a0caa48f6bc3735bdd7d721 SHA1 c9ef39537fb672841923ecf709ed658e82d63381 SHA256 14d1fe4da5a76e163ced0fb498d7317eb266026c6950b972e64d72eff039ab42
EBUILD mocha-0.11.4.ebuild 1208 RMD160 c911c4e4f1845a894ca3bbfd6b6f49734cad3beb SHA1 b9a31620e655d22bd035712ee494bb2d7a13b6a5 SHA256 835ec993116f192c0356daa3a2e03e590a5b89a2cf0ecc837ec7b2c7aa661c46
-EBUILD mocha-0.9.10.ebuild 942 RMD160 721babfaa68588474925e8db1c751b5561413a5d SHA1 3b15e49dad9c84b97f3ca86d198e18da50395ee2 SHA256 520334d1a11b1da6ea8921f7a93054a7684f40cf759fcd8059919c42bd8194d4
EBUILD mocha-0.9.12.ebuild 990 RMD160 4db1709def85c919244083de2b9fe7e08d81e757 SHA1 1fd03a35d62dadf57090926fe824c4ed4f39d9c4 SHA256 f9878a77cca0ce9ae7caee9bcc599abb821e1405ce494f6041ed31b1d07a2b0e
-MISC ChangeLog 7655 RMD160 92e78dc88afcfce22f5d1b62f9722a8d74c31544 SHA1 5ee8739158f252811b48df97ffa18f2927670f8a SHA256 e24d3ccb0e56750d967d01461c9f034fb1711530f254719e5a224e3dcf86deba
+MISC ChangeLog 7797 RMD160 514682fc66c189fa7b19c4dfda14cd1a9ed00782 SHA1 9d2c469a9e53953fcf32ada9f15d2e9a26f162d5 SHA256 de8cf78df3d0eef7549b07d6df0b669fd7632384116996e4a9182ff0410fa459
MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
-iF4EAREIAAYFAk/Y0GsACgkQiIP6VqMIqNdx6wD+ON/xtZsU7z9g83Fm/bk8c67T
-vzf3RZn9Zwpl4iCxN/MA/1Hm2yO2pJbBrCftm8Ufmg1QmE6vdhuPFAj88F9UDGFq
-=MnwO
+iF4EAREIAAYFAk/Y0hoACgkQiIP6VqMIqNfsaAD8Ce9Qva5f88JmEab9P7lTekcg
+mqGrcBQ+bU5THPzt9IQA/itxgtmZgBA6il7R3yz+wS0yHRfsw1y+382U//RpcoyI
+=WOqa
-----END PGP SIGNATURE-----
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 3ba08b3d6cd3..6ba1c53176f2 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.222 2012/06/13 06:27:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.223 2012/06/13 17:44:02 graaff Exp $
+
+*rails-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +rails-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*rails-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/rails/rails-3.0.15.ebuild b/dev-ruby/rails/rails-3.0.15.ebuild
new file mode 100644
index 000000000000..6ab793847a74
--- /dev/null
+++ b/dev-ruby/rails/rails-3.0.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.0.15.ebuild,v 1.1 2012/06/13 17:44:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.16"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1.0*
+ ~dev-ruby/railties-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}
diff --git a/dev-ruby/railties/ChangeLog b/dev-ruby/railties/ChangeLog
index 780c42a5ee73..52112ffe47cb 100644
--- a/dev-ruby/railties/ChangeLog
+++ b/dev-ruby/railties/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/railties
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.26 2012/06/13 06:26:32 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/ChangeLog,v 1.27 2012/06/13 17:43:37 graaff Exp $
+
+*railties-3.0.15 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +railties-3.0.15.ebuild:
+ Version bump for Rails 3.0.15.
*railties-3.2.6 (13 Jun 2012)
diff --git a/dev-ruby/railties/railties-3.0.15.ebuild b/dev-ruby/railties/railties-3.0.15.ebuild
new file mode 100644
index 000000000000..94eb1f102266
--- /dev/null
+++ b/dev-ruby/railties/railties-3.0.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/railties/railties-3.0.15.ebuild,v 1.1 2012/06/13 17:43:37 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:regular"
+RUBY_FAKEGEM_TASK_DOC="generate_guides"
+RUBY_FAKEGEM_DOCDIR="guides/output"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="railties.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools for creating, working with, and running Rails applications."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/railties"
+
+# The test suite has many failures, most likely due to a mismatch in
+# exact dependencies or environment specifics. Needs further
+# investigation.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/rdoc-3.4
+ >=dev-ruby/thor-0.14.4
+ >=dev-ruby/rake-0.8.7"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )
+ doc? (
+ >=dev-ruby/redcloth-4.1.1
+ )"