summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.8.102
-rw-r--r--games-strategy/wesnoth/wesnoth-0.8.10.ebuild72
4 files changed, 83 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index a5f9dfc4ac38..c6285e47a04a 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.43 2005/02/01 07:01:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.44 2005/02/07 16:19:02 mr_bones_ Exp $
+
+*wesnoth-0.8.10 (07 Feb 2005)
+
+ 07 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-0.8.10.ebuild:
+ version bump
*wesnoth-0.8.9 (01 Feb 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 268183b834e2..643705ccbce0 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
MD5 7dbfa3e79b5d4b5b0a6fa4eaa6e335e2 wesnoth-0.8.9.ebuild 1744
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 9d7db035fe709ce6d8c0982b01cf9432 ChangeLog 5943
+MD5 079e52aeb0f9cb6f3a2f992968779f0e ChangeLog 6069
+MD5 f792925e6236c6a59ad80fac7b04753c wesnoth-0.8.10.ebuild 1745
MD5 1485d9b022c1ae232f8d0eda6b038dbf wesnoth-0.8.7.ebuild 1333
MD5 288eca357f469e3d2b436d0e623841bb wesnoth-0.8.8.ebuild 1333
MD5 be40813150a00652684a313698ec1ae5 files/digest-wesnoth-0.8.9 139
+MD5 b7e6563ad1ede86d02ff1afcaa76e84e files/digest-wesnoth-0.8.10 141
MD5 b06353437e93f7484c151125d36e5d73 files/digest-wesnoth-0.8.7 67
MD5 904fb0e4137a854d6e5ea5375f3d9922 files/digest-wesnoth-0.8.8 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.8.10 b/games-strategy/wesnoth/files/digest-wesnoth-0.8.10
new file mode 100644
index 000000000000..f1d26aee0833
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.8.10
@@ -0,0 +1,2 @@
+MD5 0fbda4c35f0a6cf9f18df453a7f83f7c wesnoth-0.8.10.tar.gz 36687797
+MD5 cb1ee68e19958a0a38e9a5a0af31161a wesnoth-lite-0.8.10.tar.gz 20886365
diff --git a/games-strategy/wesnoth/wesnoth-0.8.10.ebuild b/games-strategy/wesnoth/wesnoth-0.8.10.ebuild
new file mode 100644
index 000000000000..02ed9e7340a2
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.8.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.8.10.ebuild,v 1.1 2005/02/07 16:19:02 mr_bones_ Exp $
+
+inherit eutils flag-o-matic gcc games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="!lite? ( mirror://sourceforge/wesnoth/${P}.tar.gz )
+ lite? ( mirror://sourceforge/wesnoth/${PN}-lite-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_unpack() {
+ if use lite ; then
+ unpack ${PN}-lite-${PV}.tar.gz
+ S=${WORKDIR}/${PN}-lite-${PV}
+ else
+ unpack ${P}.tar.gz
+ fi
+ cd "${S}"
+ sed -i \
+ -e 's/--expandvars//' configure \
+ || die "sed failed"
+ if use tools ; then
+ sed -i \
+ -e '/^DEFAULT_INCLUDES/s:-I$(srcdir):-I$(srcdir) -I../sdl_ttf:' \
+ src/tools/Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ filter-flags -ftracer
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ if use lite ; then
+ S=${WORKDIR}/${PN}-lite-${PV}
+ fi
+ cd "${S}"
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}