summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/gle/gle-3.0.1-r1.ebuild6
-rw-r--r--media-libs/mesa/mesa-3.4-r1.ebuild7
-rw-r--r--media-libs/smpeg/smpeg-0.4.2-r1.ebuild5
3 files changed, 9 insertions, 9 deletions
diff --git a/media-libs/gle/gle-3.0.1-r1.ebuild b/media-libs/gle/gle-3.0.1-r1.ebuild
index 2036bf78f862..12ffcfb1a5fc 100644
--- a/media-libs/gle/gle-3.0.1-r1.ebuild
+++ b/media-libs/gle/gle-3.0.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r1.ebuild,v 1.2 2001/02/13 14:29:40 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r1.ebuild,v 1.3 2001/02/15 18:16:54 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GL extrusion library"
@@ -14,12 +14,12 @@ DEPEND="virtual/glibc
src_compile() {
- try ./configure --with-x --prefix=/usr
+ try ./configure --with-x --prefix=/usr --mandir=/usr/share/man
try make
}
src_install () {
- try make prefix=${D}/usr install
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
}
diff --git a/media-libs/mesa/mesa-3.4-r1.ebuild b/media-libs/mesa/mesa-3.4-r1.ebuild
index 804fecaac548..24936d3ffdd1 100644
--- a/media-libs/mesa/mesa-3.4-r1.ebuild
+++ b/media-libs/mesa/mesa-3.4-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-3.4-r1.ebuild,v 1.1 2001/02/13 14:29:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-3.4-r1.ebuild,v 1.2 2001/02/15 18:16:54 achim Exp $
P=MesaLib-${PV}
A0=${P}.tar.bz2
@@ -97,7 +97,7 @@ src_compile() {
src_install () {
- try make DESTDIR=${D} install
+
if [ "`use ggi`" ]
then
cd ggi/ggiglut
@@ -107,7 +107,8 @@ src_install () {
sed -e "s:-L${S}/src/.libs::g" libglut.orig > libglut.la
rm libglut.orig
fi
-
+ cd ${S}
+ try make DESTDIR=${D} install
cd ${D}/usr/lib
if [ "$PN" = "mesa-glu" ]
then
diff --git a/media-libs/smpeg/smpeg-0.4.2-r1.ebuild b/media-libs/smpeg/smpeg-0.4.2-r1.ebuild
index 2085f67ba1dc..929e8bc05e84 100644
--- a/media-libs/smpeg/smpeg-0.4.2-r1.ebuild
+++ b/media-libs/smpeg/smpeg-0.4.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.2-r1.ebuild,v 1.1 2001/02/13 14:29:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.2-r1.ebuild,v 1.2 2001/02/15 18:16:54 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,8 +9,7 @@ DESCRIPTION="SDL MPEG Player Library"
SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${A}"
HOMEPAGE="http://www.lokigames.com/development/smpeg.php3"
-DEPEND="virtual/glibc
- >=media-libs/libsdl-1.1.7
+DEPEND=">=media-libs/libsdl-1.0.8
opengl? ( >=media-libs/mesa-3.4 )
gtk? ( >=dev-libs/glib-1.2.8
>=x11-libs/gtk+-1.2.8 )"