summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/gocr/ChangeLog9
-rw-r--r--app-text/gocr/files/digest-gocr-0.3.61
-rw-r--r--app-text/gocr/files/gocr-0.3.6-gentoo.diff11
-rw-r--r--app-text/gocr/gocr-0.3.4.ebuild9
-rw-r--r--app-text/gocr/gocr-0.3.6.ebuild83
5 files changed, 110 insertions, 3 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index 81868211682e..450ec0e11703 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gocr
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.1 2002/02/01 21:53:10 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.2 2002/06/28 18:19:07 rphillips Exp $
+
+*gocr-0.3.6 (28 Jun 2002)
+
+ 28 Jun 2002; Ryan Phillips <rphillips@gentoo.org> gocr-0.3.6.ebuild :
+
+ Added a new version, and disabled the sandbox temporarily. The
+ sandbox fails on latex font installations. Anybody know a workaround?
*gocr-0.3.4 (1 Feb 2002)
diff --git a/app-text/gocr/files/digest-gocr-0.3.6 b/app-text/gocr/files/digest-gocr-0.3.6
new file mode 100644
index 000000000000..9dfd2823000b
--- /dev/null
+++ b/app-text/gocr/files/digest-gocr-0.3.6
@@ -0,0 +1 @@
+MD5 47dadd37fe434c9e33443288119878a5 gocr-0.3.6.tar.gz 668653
diff --git a/app-text/gocr/files/gocr-0.3.6-gentoo.diff b/app-text/gocr/files/gocr-0.3.6-gentoo.diff
new file mode 100644
index 000000000000..43ed0e564a10
--- /dev/null
+++ b/app-text/gocr/files/gocr-0.3.6-gentoo.diff
@@ -0,0 +1,11 @@
+--- gocr-0.3.6/configure.in.orig Fri Jun 28 08:57:58 2002
++++ gocr-0.3.6/configure.in Fri Jun 28 08:58:25 2002
+@@ -12,7 +12,7 @@
+ AC_CHECK_PROG(LATEX,latex,latex)
+ AC_CHECK_PROG(DVIPS,dvips,dvips)
+
+-CPPFLAGS=-I/usr/X11R6/include
++CPPFLAGS=-I/usr/X11R6/include -I/usr/include/pbm
+ #LDFLAGS="-L/usr/X11R6/lib -lpbm -lpgm -lppm -lpnm"
+ LDFLAGS="-L/usr/X11R6/lib -L/usr/local/netpbm/lib"
+
diff --git a/app-text/gocr/gocr-0.3.4.ebuild b/app-text/gocr/gocr-0.3.4.ebuild
index ec00e7525019..17684ed35efb 100644
--- a/app-text/gocr/gocr-0.3.4.ebuild
+++ b/app-text/gocr/gocr-0.3.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.3.4.ebuild,v 1.3 2002/05/27 17:27:36 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.3.4.ebuild,v 1.4 2002/06/28 18:19:07 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Converts PNM to ASCII"
@@ -44,7 +44,12 @@ src_compile() {
export CFLAGS="${CFLAGS} -I/usr/include/pbm"
./configure --prefix=/usr --host=${CHOST} || die
make src frontend database
- use tetex && make doc || die
+ use tetex && make \
+ prefix=${D}/usr \
+ sysconfdir=/${D}/etc \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ doc || die
}
diff --git a/app-text/gocr/gocr-0.3.6.ebuild b/app-text/gocr/gocr-0.3.6.ebuild
new file mode 100644
index 000000000000..060a7974efe8
--- /dev/null
+++ b/app-text/gocr/gocr-0.3.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.3.6.ebuild,v 1.1 2002/06/28 18:19:07 rphillips Exp $
+
+# this is just TEMPORARY until we can get to the core of the problem
+# The problem is in the generation of the fonts
+SANDBOX_DISABLED="1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Converts PNM to ASCII"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+HOMEPAGE="http://altmark.nat.uni-magdeburg.de/~jschulen/ocr/"
+
+DEPEND="virtual/glibc
+ app-text/tetex
+ app-text/ghostscript
+ >=media-libs/netpbm-9.12-r1"
+
+RDEPEND="virtual/glibc
+ >=media-libs/netpbm-9.12-r1"
+
+src_unpack() {
+
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+ cd ${S}
+ autoconf
+ cd ${S}/doc
+ cp Makefile.in Makefile.orig
+ sed -e "s:\$(DVIPS) \$?:\$(DVIPS) -o \$(OCRDOC).ps \$?:" \
+ Makefile.orig > Makefile.in
+ cd ../bin
+ mv gocr.tcl gocr.orig
+ sed -e "s:\.\./examples:/usr/share/gocr/fonts:" \
+ gocr.orig > gocr.tcl
+ cd ../src
+ cp database.c database.orig
+ sed -e "s:\./db/:${D}/usr/share/gocr/db/:" database.orig > database.c
+ cd ../examples
+ cp Makefile Makefile.orig
+ sed -e "s:polish.pbm man.pbm:polish.pbm:" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ export CFLAGS="${CFLAGS} -I/usr/include/pbm"
+ ./configure --prefix=/usr --host=${CHOST} || die
+ make src frontend database
+ use tetex && (\
+ make \
+ prefix=${D}/usr \
+ sysconfdir=/${D}/etc \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ doc || die
+ )
+}
+
+src_install () {
+
+ dobin bin/gocr
+ exeinto /usr/bin
+ doexe bin/gocr.tcl
+ dolib.a src/libPgm2asc.a
+ insinto /usr/include
+ doins src/gocr.h
+ insinto /usr/share/gocr/db
+ doins db/*
+ doman man/man1/gocr.1
+ dodoc AUTHORS BUGS CREDITS HISTORY README* REMARK.txt REVIEW TODO gpl.html
+ docinto txt
+ dodoc doc/*.txt
+
+ use tetex && ( \
+ insinto /usr/share/gocr/db
+ docinto ps
+ dodoc doc/ocr.ps
+ )
+
+}
+