summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/xinetd/ChangeLog7
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.101
-rw-r--r--sys-apps/xinetd/xinetd-2.3.10.ebuild63
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index f2f80e9494e1..bb234b156dd3 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-apps/xinetd
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.15 2003/02/12 09:12:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.16 2003/03/27 04:34:17 drobbins Exp $
+*xinetd-2.3.10 (26 Mar 2003)
+
+ 26 Mar 2003; Daniel Robbins <drobbins@gentoo.org>: new upstream release, unstable for
+ x86.
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*xinetd-2.3.9 (24 Oct 2002)
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.10 b/sys-apps/xinetd/files/digest-xinetd-2.3.10
new file mode 100644
index 000000000000..e2cb6ed6b901
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.10
@@ -0,0 +1 @@
+MD5 c5178a634c0e621d644119f24d274885 xinetd-2.3.10.tar.gz 284814
diff --git a/sys-apps/xinetd/xinetd-2.3.10.ebuild b/sys-apps/xinetd/xinetd-2.3.10.ebuild
new file mode 100644
index 000000000000..72b9671e43f1
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.10.ebuild,v 1.1 2003/03/27 04:34:17 drobbins Exp $
+
+
+#SPV=the directory in files/ to grab the goodies from
+SPV=2.3.9
+
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="BSD"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="${DEPEND} dev-lang/perl"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ # the --with-inet6 is now obsolete. Services will default to IPv4 unless configured otherwise.
+
+ econf --with-loadavg ${myconf}
+
+ # Fix CFLAGS
+ sed "/^CFLAGS/s/+=/=/" < Makefile > makefile
+ mv --force makefile Makefile
+
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe xinetd/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/${SPV}/xinetd.conf xinetd.conf.default || die
+ dodoc AUDIT INSTALL README TODO xinetd/{CHANGELOG,COPYRIGHT}
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/${SPV}/etc.xinetd.d/* || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/${SPV}/xinetd.rc6 xinetd || die
+ insinto /etc/conf.d ; newins ${FILESDIR}/${SPV}/xinetd.confd xinetd || die
+ insinto /etc ; doins ${FILESDIR}/${SPV}/xinetd.conf || die
+}
+
+pkg_postinst(){
+ einfo "This ebuild introduces the /etc/xinetd.d includedir with a default"
+ einfo "/etc/xinetd.conf file. Check your config files if you're upgrading from an older"
+ einfo "ebuild version. You should browse /etc/xinetd.conf and the files in /etc/xinetd.d."
+ ewarn
+ ewarn "PLEASE NOTE: Everything is off by default with access restricted to localhost."
+ ewarn
+ einfo "Check /etc/conf.d/xinetd for the startup options."
+ echo ""
+}