summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/csh/ChangeLog6
-rw-r--r--app-shells/csh/Manifest14
-rw-r--r--app-shells/csh/csh-1.29-r1.ebuild139
-rw-r--r--app-shells/csh/csh-1.29.ebuild119
-rw-r--r--app-shells/csh/files/digest-csh-1.293
-rw-r--r--app-shells/csh/files/digest-csh-1.29-r13
-rw-r--r--app-shells/ksh/ChangeLog5
-rw-r--r--app-shells/ksh/Manifest4
-rw-r--r--app-shells/ksh/files/digest-ksh-93.200304223
-rw-r--r--app-shells/ksh/ksh-93.20030422.ebuild100
10 files changed, 15 insertions, 381 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index 0fc68814698d..a05d9216d3bd 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.10 2003/09/05 18:30:42 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.11 2003/09/17 11:16:15 taviso Exp $
+
+ 17 Sep 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r1.ebuild,
+ csh-1.29.ebuild:
+ cleaning up
05 Sep 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r2.ebuild:
stable on x86 and alpha.
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index e8350534f42a..891b165fd903 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,13 +1,9 @@
-MD5 3019bbce2833e8d5a8fd63babed04252 ChangeLog 2127
-MD5 c8862976a0b170f264c5ad49eea885f3 csh-1.29.ebuild 3796
-MD5 a4db08fd328f9b461fd2db64f8dd401c csh-1.29-r1.ebuild 4044
-MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
MD5 5ecf5bef3e3cad1ca1311c11fe6fe8a0 csh-1.29-r2.ebuild 4314
-MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
-MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
+MD5 69e5c647ce981f20c55f0cb91994b5e7 ChangeLog 2230
+MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
-MD5 70a304fe872eabbec7c515095af358fc files/digest-csh-1.29-r1 162
-MD5 56092454f21f9d462f4514aadf4c78cd files/dot.cshrc 1549
-MD5 2365e5e2ca11496be2169a6944a38994 files/dot.login 224
+MD5 213922a7d6fdee0a89e9a349653be22d files/linux-vs-bsd.diff 7483
MD5 8eb726131df145785642164034fb5a74 files/digest-csh-1.29-r2 60
MD5 9a4c41baf0e48fb12e83a51b0b15f297 files/retype-input.diff 2352
+MD5 56092454f21f9d462f4514aadf4c78cd files/dot.cshrc 1549
+MD5 2365e5e2ca11496be2169a6944a38994 files/dot.login 224
diff --git a/app-shells/csh/csh-1.29-r1.ebuild b/app-shells/csh/csh-1.29-r1.ebuild
deleted file mode 100644
index 040f6305ea7c..000000000000
--- a/app-shells/csh/csh-1.29-r1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r1.ebuild,v 1.7 2003/09/06 22:23:39 msterret Exp $
-
-inherit flag-o-matic eutils ccc
-
-DESCRIPTION="Classic UNIX shell with C like syntax"
-HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="http://cvs.gentoo.org/~taviso/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 alpha"
-IUSE="static doc"
-
-DEPEND="virtual/glibc
- sys-devel/pmake
- >=sys-apps/sed-4
- doc? ( sys-apps/groff )"
-RDEPEND="virtual/glibc"
-
-S=${WORKDIR}/src/bin/csh
-
-src_compile() {
- # hide some BSDisms, mostly my work, got some hints from the
- # debian project (they use an older OpenBSD csh, though).
- cd ${S}; epatch ${FILESDIR}/linux-vs-bsd.diff || die "patching failed."
-
- # copy some required files over, from NetBSD
-
- cd ${S}; cp ${WORKDIR}/printf.c \
- ${WORKDIR}/vis.h \
- ${WORKDIR}/vis.c \
- ${FILESDIR}/dot.login \
- ${FILESDIR}/dot.cshrc \
- ${S}
-
- # this parses the output of the bash builtin `kill`
- # and creates an array of signal names for csh.
-
- einfo "Making a list of signal names..."
-
- local cnt=0
-
- printf "/* automatically generated during %s build */\n\n" ${PF} > ${S}/signames.h
- printf "const char *const sys_signame[NSIG + 3] = {\n" >> ${S}/signames.h
- printf "\t\"EXIT\",\t\n" >> ${S}/signames.h
-
- let cnt++
-
- for i in `kill -l`
- do
- let $((cnt++))%2 && continue
- einfo " Adding ${i}..."
- printf "\t\"%s\",\n" ${i} >> ${S}/signames.h
- done
-
- printf "\t\"DEBUG\",\n\t\"ERR\",\n\t(char *)0x0\n};\n\n" >> ${S}/signames.h
-
- einfo "Adding flags required for succesful compilation..."
- # this should be easier than maintaining a patch.
- for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
- do
- append-flags ${i}
- done
-
- einfo "Making some final tweaks..."
- sed -i 's#sys/tty.h#linux/tty.h#g' ${S}/file.c
- sed -i 's!\(#include "proc.h"\)!\1\n#include "signames.h"\n!g' ${S}/proc.c
- sed -i 's#\(strpct.c time.c\)#\1 vis.c#g' ${S}/Makefile
- sed -i 's!#include "namespace.h"!!g' ${S}/vis.c
- sed -i 's#/usr/games/fortune#/usr/bin/fortune#g' ${S}/dot.login
-
- # maybe they dont warn on BSD, but _damn_.
- export NOGCCERROR=1
-
- # if csh is a users preferred shell, they may want
- # a static binary to help on the event of fs emergency.
- use static && append-ldflags -static
-
- # pmake is a portage binary as well, so specify full path.
- # if yours isnt in /usr/bin, you can set PMAKE_PATH.
- einfo "Starting build..."
- ${PMAKE_PATH:-/usr/bin/}pmake || die "compile failed."
-
- echo
- size csh
- echo
-
- # make the c shell guide
- use doc && {
- einfo "Making documentation..."
- cd ${S}/USD.doc
- ${PMAKE_PATH:-/usr/bin/}pmake
- }
- cd ${S}
-
- einfo "Making empty configuration files.."
- printf "#\n# System-wide .cshrc file for csh(1).\n\n" > csh.cshrc
- printf "#\n# System-wide .login file for csh(1).\n\n" > csh.login
- printf "if ( -f /etc/csh.env ) source /etc/csh.env\n" >> csh.login
- printf "#\n# System-wide .logout file for csh(1).\n\n" > csh.logout
-}
-
-src_install() {
- exeinto /bin
- doexe csh
-
- doman csh.1
-
- use doc && dodoc USD.doc/paper.ps
- dodoc dot.cshrc dot.login
-
- insinto /etc
- doins csh.cshrc csh.login csh.logout
-}
-
-pkg_postinst() {
- echo
- use doc >/dev/null && {
- einfo "An Introduction to the C shell by William Joy, a "
- einfo "postscript document included with this shell has"
- einfo "been installed in /usr/share/doc/${PF}, if you are new"
- einfo "to the C shell, you may find it interesting."
- } || {
- einfo "You didnt have the \`doc\` use flag set, the"
- einfo "postscript document \"An Introduction to the C"
- einfo "shell by William Joy\" was not installed."
- }
- echo
- einfo "Example login scripts have been installed in /usr/share/doc/${PF}."
- einfo "You can install a simple dot.cshrc like this:"
- einfo
- einfo " % zcat /usr/share/doc/${PF}/dot.cshrc > ~/.cshrc"
- einfo " % zcat /usr/share/doc/${PF}/dot.login > ~/.login"
- einfo
- einfo "And then edit to your liking."
- echo
-}
diff --git a/app-shells/csh/csh-1.29.ebuild b/app-shells/csh/csh-1.29.ebuild
deleted file mode 100644
index 5de5d343b7f8..000000000000
--- a/app-shells/csh/csh-1.29.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29.ebuild,v 1.6 2003/09/06 22:23:39 msterret Exp $
-
-inherit cvs flag-o-matic eutils ccc
-
-ECVS_SERVER="anoncvs.netbsd.org:/cvsroot"
-ECVS_MODULE="src/bin/csh"
-ECVS_USER="anoncvs"
-ECVS_PASS="anoncvs"
-ECVS_BRANCH="netbsd-1-6"
-
-DESCRIPTION="Classic UNIX shell with C like syntax"
-HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/usr.bin/printf/printf.c
- ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/include/vis.h
- ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/src/lib/libc/gen/vis.c"
-
-RESTRICT="nomirror"
-
-# theres basically a choice of fetching the individual files via
-# ftp, and using nomirror to stop spamming the mirrors, or fetch
-# a tarball of the whole lot and waste bandwidth.
-#
-# the other option is to check it out of cvs, using tags to make
-# sure we get a consistent version.
-#
-# i decided to go with cvs.
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~alpha"
-IUSE="static doc"
-
-DEPEND="virtual/glibc
- sys-devel/pmake
- >=sys-apps/sed-4
- doc? ( sys-apps/groff )"
-RDEPEND="virtual/glibc"
-
-S=${WORKDIR}/${ECVS_MODULE}
-
-src_compile() {
- # hide some BSDisms, mostly my work, got some hints from the
- # debian project (they use an older OpenBSD csh, though).
- cd ${S}; epatch ${FILESDIR}/linux-vs-bsd.diff || die "patching failed."
-
- # copy some required files over, two from NetBSD
- # and one provided with the bash shell.
-
- # The file `mksignames.c` and the product of its execution
- # is the only reason this ebuild is dual license, without
- # this code (eg make your own array) this shell will be
- # 100% BSD. i borrowed it from bash-2.05b, btw.
-
- cd ${S}; cp ${DISTDIR}/printf.c \
- ${DISTDIR}/vis.h \
- ${FILESDIR}/mksignames.c \
- ${DISTDIR}/vis.c \
- ${S}
- # this utility spits out an array of signal names.
-
- einfo "Making a list of signal names..."
- ${CC:-gcc} ${CFLAGS} ${LDFLAGS} -o ${T}/mksignames ${S}/mksignames.c
- ${T}/mksignames > ${S}/signames.h || die "couldnt get a list of signals."
-
- einfo "Adding flags required for succesful compilation..."
- # this should be easier than maintaining a patch.
- for i in {-Dlint,-w,-D__dead="",-D__LIBC12_SOURCE__,-DNODEV="-1",-DTTYHOG=1024,-DMAXPATHLEN=4096,-D_GNU_SOURCE,-D_DIAGASSERT="assert"}
- do
- append-flags ${i}
- done
-
- einfo "Making some final tweaks..."
- sed -i 's#sys/tty.h#linux/tty.h#g' ${S}/file.c
- sed -i 's!\(#include "proc.h"\)!\1\n#include "signames.h"\n!g' ${S}/proc.c
- sed -i 's#\(strpct.c time.c\)#\1 vis.c#g' ${S}/Makefile
- sed -i 's!#include "namespace.h"!!g' ${S}/vis.c
-
- # maybe they dont warn on BSD, but _damn_.
- export NOGCCERROR=1
-
- # if csh is a users preferred shell, they may want
- # a static binary to help on the event of fs emergency.
- use static && append-ldflags -static
-
- # pmake is a portage binary as well, so specify full path.
- # if yours isnt in /usr/bin, you can set PMAKE_PATH.
- einfo "Starting build..."
- ${PMAKE_PATH:-/usr/bin/}pmake || die "compile failed."
-
- # make the c shell guide
- use doc && {
- einfo "Making documentation..."
- cd ${S}/USD.doc
- ${PMAKE_PATH:-/usr/bin/}pmake
- }
- cd ${S}
-}
-
-src_install() {
- exeinto /bin
- doexe csh
- doman csh.1
- use doc && dodoc USD.doc/paper.ps
-}
-
-pkg_postinst() {
- use doc >/dev/null && {
- einfo "An Introduction to the C shell by William Joy, a "
- einfo "postscript document included with this shell has"
- einfo "been installed in /usr/share/docs/${P}, if you are new"
- einfo "to the C shell, you may find it interesting."
- } || {
- einfo "You didnt have the \`doc\` use flag set, the"
- einfo "postscript document \"An Introduction to the C"
- einfo "shell by William Joy\" was not installed."
- }
-}
diff --git a/app-shells/csh/files/digest-csh-1.29 b/app-shells/csh/files/digest-csh-1.29
deleted file mode 100644
index 71a8e7c61076..000000000000
--- a/app-shells/csh/files/digest-csh-1.29
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d0c13a13ddd3348f2690ebce3ca31197 printf.c 10839
-MD5 1407b2e7112b8fafe35fdf4b922bb6b9 vis.h 3706
-MD5 6d4159b84708bbbc90cf0a6518ef2beb vis.c 9542
diff --git a/app-shells/csh/files/digest-csh-1.29-r1 b/app-shells/csh/files/digest-csh-1.29-r1
deleted file mode 100644
index c57f7df2d659..000000000000
--- a/app-shells/csh/files/digest-csh-1.29-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 9637b9572e66e992305dfed9909098e2 csh-1.29.tar.gz 179592
-MD5 7d9f25e1da5a927803c1a62d005ed502 dot.cshrc 582
-MD5 7951306dd2db4dbe54e4303094cf6c81 dot.login 271
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 90a869767a61..84f4f895be6e 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/ksh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.4 2003/09/10 17:57:30 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.5 2003/09/17 11:14:16 taviso Exp $
+
+ 17 Sep 2003; Tavis Ormandy <taviso@gentoo.org> ksh-93.20030422.ebuild:
+ removing old ebuilds.
*ksh-93.20030724 (10 Sep 2003)
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 1571002096ac..5c5ce0dd5e85 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,7 +1,5 @@
MD5 55a746ecc0b2c7f6be6912f63fcbcfab ksh-93.20030724.ebuild 2400
-MD5 7494a9475442734dfda7a7a3f4c86dc1 ksh-93.20030422.ebuild 3189
-MD5 5c9e0e8e4fb34deb57528a0976f5aed7 ChangeLog 812
+MD5 fa53ebd6a03e0d4f676da2fbac182a83 ChangeLog 910
MD5 e1baa44340503f92d40f821f1c389419 metadata.xml 1264
MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
-MD5 ae6a966c5c8702e7199266a3b73a9291 files/digest-ksh-93.20030422 206
MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
diff --git a/app-shells/ksh/files/digest-ksh-93.20030422 b/app-shells/ksh/files/digest-ksh-93.20030422
deleted file mode 100644
index 6ea50e872f14..000000000000
--- a/app-shells/ksh/files/digest-ksh-93.20030422
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ff404527ecdae4511d37dc1716055e45 INIT.2003-04-22.tgz 255836
-MD5 c80cc0be17484ad6868b07ab06877309 ast-ksh.2003-04-22.tgz 1429397
-MD5 a8288401b0a6984cac48864fc9a835b5 ast-ksh-locale.2003-04-22.tgz 516623
diff --git a/app-shells/ksh/ksh-93.20030422.ebuild b/app-shells/ksh/ksh-93.20030422.ebuild
deleted file mode 100644
index f096b0fa415a..000000000000
--- a/app-shells/ksh/ksh-93.20030422.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20030422.ebuild,v 1.6 2003/09/06 22:23:39 msterret Exp $
-
-inherit ccc eutils
-
-RELEASE="2003-04-22"
-DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
-HOMEPAGE="http://www.kornshell.com/"
-SRC_URI="http://www.research.att.com/~gsf/download/tgz/INIT.${RELEASE}.tgz
- http://www.research.att.com/~gsf/download/tgz/ast-ksh.${RELEASE}.tgz
- nls? ( http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.${RELEASE}.tgz )"
-
-LICENSE="ATT"
-SLOT="0"
-KEYWORDS="x86 alpha"
-IUSE="static nls"
-
-DEPEND="virtual/glibc
- >=sys-apps/sed-4"
-RDEPEND="virtual/glibc"
-
-S=${WORKDIR}
-
-src_unpack() {
- # the AT&T build tools look in here for packages.
- mkdir -p ${S}/lib/package/tgz
-
- # move the packages into place.
- cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
- use nls && {
- cp ${DISTDIR}/ast-ksh-locale.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
- }
-
- # INIT provides the basic tools to start building.
- cd ${S}; unpack INIT.${RELEASE}.tgz || die
-
- # `package read` will unpack any tarballs put in place.
- ${S}/bin/package read || die
-}
-
-src_compile() {
- # users who prefer ksh as there regular shell
- # may want to make it static, so it can be used
- # in the event of fs failure, for example
- # where shared libraries are not available
- use static && append-ldflags -static
-
- # just a quick message for any users who inadvertantly
- # typed `emerge ksh` but actually wanted `emerge pdksh`
- ewarn "This ebuild will install the original AT&T Korn Shell"
- ewarn "By David Korn, if you were looking for PDKSH, the Public"
- ewarn "Domain Korn SHell, please cancel this emerge and then"
- ewarn "emerge pdksh."
- sleep 3
-
- # set the optimisations for the build process
- export CCFLAGS="${CFLAGS}"
- cd ${S}; ./bin/package only make ast-ksh CC=${CC:-gcc} || true
-
- # if we set any optimisations, linking will fail.
- # but this isnt a problem, the optimisations will have already
- # been applied to the object files, we just need to link
- # them.
- einfo "Dont worry about any linker errors above, i need to rerun"
- einfo "the build to complete the linking process..."
- sleep 2 ; unset CCFLAGS
-
- # re-run to finish linking.
- ./bin/package only make ast-ksh CC=${CC:-gcc} || die "sorry, build failed."
-
- # install the optional locale data.
- # heh, check out locale fudd, or piglatin :)
- #
- # "Too many symbowic winks in paf name twavewsal"
-
- # david korn is a funny guy! :)
- use nls && {
- cd ${S}; ./bin/package only make ast-ksh-locale CC=${CC:-gcc}
- }
-}
-
-src_install() {
- # check where the build scripts put them
- local my_arch="${S}/arch/$(${S}/bin/package)"
- mv ${my_arch}/bin/ok/ksh ${my_arch}/bin/ok/ksh93
- exeinto /bin
- doexe ${my_arch}/bin/ok/ksh93
- [ ! -f /bin/ksh ] && dosym /bin/ksh93 /bin/ksh
- # i doubt anyone is fanatical enough to use
- # this as /bin/sh.
- mv ${my_arch}/man/man1/sh.1 ${my_arch}/man/man1/ksh.1
- doman ${my_arch}/man/man1/ksh.1
- dodoc ${S}/lib/package/LICENSES/ast
- dodoc ${S}/lib/package/gen/ast-ksh.txt
- use nls && {
- dodir /usr/share
- mv ${S}/share/lib/locale ${D}/usr/share
- }
-}