summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/rpm/ChangeLog7
-rw-r--r--app-arch/rpm/Manifest3
-rw-r--r--app-arch/rpm/rpm-4.4.7-r6.ebuild108
3 files changed, 116 insertions, 2 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index 027d0de23a0b..fbf72ce4955f 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.114 2010/06/22 19:59:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.115 2010/07/18 23:57:33 hwoarang Exp $
+
+*rpm-4.4.7-r6 (18 Jul 2010)
+
+ 18 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +rpm-4.4.7-r6.ebuild:
+ Revbump to remove pointless .la file. Bug #300096
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
rpm-4.4.6-r7.ebuild, rpm-4.4.7-r4.ebuild, rpm-4.4.7-r5.ebuild,
diff --git a/app-arch/rpm/Manifest b/app-arch/rpm/Manifest
index acb291be626e..b351f47f2224 100644
--- a/app-arch/rpm/Manifest
+++ b/app-arch/rpm/Manifest
@@ -18,7 +18,8 @@ DIST rpm-5.1.6.tar.gz 8305612 RMD160 88645f4a7c2e25fffaa5628d267e86eaac137b35 SH
EBUILD rpm-4.4.6-r7.ebuild 3161 RMD160 3d7c39878d2efe7e907b15fb5ebb166fbaa95c1a SHA1 c7ea4f4bcae49989f16929497e4544385521101b SHA256 448531ddb2a3416fb2b22ba4ea48ea2c705f31567ebb2063969e358dd6ae0da1
EBUILD rpm-4.4.7-r4.ebuild 3082 RMD160 3278b88d65de2cd388c0615de267899cff0787de SHA1 3d1d704cfbcd1f72f41027563e4ad2d569058f6e SHA256 badf567156853719f2a9fc72a0b5a3348802c4a9cf9bd5ad0c444d8089045b07
EBUILD rpm-4.4.7-r5.ebuild 3127 RMD160 a888aebf7428e7b57ebd9140902e4e097c054465 SHA1 df1ba8ab2b8afa16e004eeb35b41431a696dd596 SHA256 36ba24b0225d594617116d5a3da5d545507f8e955310f1fe59ff6b3ae65d3c60
+EBUILD rpm-4.4.7-r6.ebuild 3213 RMD160 94273f27a1674903663927816474a7757e95773a SHA1 ffd85e682288a90fb836000e1bc109bf3c441397 SHA256 4ed8b22f93fa47be90597609b21af7d7a13f45fd782a2ef57c7e07f1c90f9b26
EBUILD rpm-4.8.0.ebuild 2113 RMD160 cee88118ad9a9e8c73b104e596f74a30445719eb SHA1 ccb43ffb916072e4e456e29614e0d59f35a2916e SHA256 9a2fcb086a7ad6a2b9d54f34224e176d7f1aa69851abce2c88fb51e10617460e
EBUILD rpm-5.1.6.ebuild 2946 RMD160 bb6bcb6e3487bfbee5b5f702212c2cd25a62131f SHA1 8df0873d6c882ada7e26e620e0eed87401ef46f3 SHA256 0b59bf46c8ed6ab8873a513657413fa59f29f1d4d0df40cc997788e7b3f7607c
-MISC ChangeLog 17668 RMD160 13237cb7b50eeed562191b6efb21a8cbe86a428f SHA1 4de52c87183535dd5367eec6f8a4c8a085581b54 SHA256 6b952dc977eda0699964cf1280fa8d2b920eea47b5d30c54e3abb218b764cbb7
+MISC ChangeLog 17825 RMD160 405f9dcfe71a0fba2c261da124eac345b026addf SHA1 090517f10ce2c2f65852e4d23927f61bdca95e4c SHA256 fb0ce39ecf9c927880ff0a795c14587f908e00e88565b9966268b3494e509082
MISC metadata.xml 426 RMD160 9904f07a8cb50e88bf9e1ed6480ece557534edf6 SHA1 ae340a63eabf63e06a17ff5d3181e62451216404 SHA256 f1fabe7e5dd678e19daf214328e6e7f4f10be906b72fea76fc08855a73d9847c
diff --git a/app-arch/rpm/rpm-4.4.7-r6.ebuild b/app-arch/rpm/rpm-4.4.7-r6.ebuild
new file mode 100644
index 000000000000..b3a0e640eb56
--- /dev/null
+++ b/app-arch/rpm/rpm-4.4.7-r6.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.7-r6.ebuild,v 1.1 2010/07/18 23:57:33 hwoarang Exp $
+
+inherit eutils autotools distutils perl-module flag-o-matic
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm5.org/"
+SRC_URI="http://rpm5.org/files/rpm/rpm-4.4/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls python perl doc sqlite"
+
+RDEPEND=">=sys-libs/db-4
+ >=sys-libs/zlib-1.2.3-r1
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-libs/beecrypt-3.1.0-r1
+ python? ( >=dev-lang/python-2.2 )
+ perl? ( >=dev-lang/perl-5.8.8 )
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3.3.5 )
+ >=net-libs/neon-0.28"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/rpm-4.4.6-with-sqlite.patch
+ epatch "${FILESDIR}"/rpm-4.4.7-stupidness.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-autotools.patch
+ epatch "${FILESDIR}"/rpm-4.4.6-buffer-overflow.patch
+ epatch "${FILESDIR}"/${P}-qa-implicit-function-to-pointer.patch
+ epatch "${FILESDIR}"/${P}-qa-fix-undefined.patch
+ epatch "${FILESDIR}"/${P}-have-locale-h.patch
+ # bug 214799
+ epatch "${FILESDIR}"/${PN}-4.4.6-neon-0.28.patch
+
+ # rpm uses AM_GNU_GETTEXT() but fails to actually
+ # include any of the required gettext files
+ cp /usr/share/gettext/config.rpath . || die
+
+ # the following are additional libraries that might be packaged with
+ # the rpm sources. grep for "test -d" in configure.ac
+ cp file/src/{file,patchlevel}.h tools/
+ rm -rf beecrypt elfutils neon popt sqlite zlib intl file
+
+ sed -i -e "s:intl ::" Makefile.am
+ sed -i -e "s:intl/Makefile ::" configure.ac
+ AT_NO_RECURSIVE="yes" eautoreconf
+ # TODO Get rid of internal copies of lua, db and db3
+}
+
+src_compile() {
+ # Until strict aliasing is porperly fixed...
+ filter-flags -fstrict-aliasing
+ append-flags -fno-strict-aliasing
+ econf \
+ --enable-posixmutexes \
+ --without-javaglue \
+ --without-selinux \
+ $(use_with python python $(python_get_version)) \
+ $(use_with doc apidocs) \
+ $(use_with perl) \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor install || die "emake install failed"
+
+ mv "${D}"/bin/rpm "${D}"/usr/bin
+ rmdir "${D}"/bin
+
+ use nls || rm -rf "${D}"/usr/share/man/??
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CHANGES CREDITS GROUPS README* RPM*
+ use doc && dohtml -r apidocs/html/*
+
+ # Fix perllocal.pod file collision
+ use perl && fixlocalpod
+
+ #remove .la file. Bug #300096
+ rm "${D}"/$(python_get_sitedir)/${PN}/_rpmmodule.la
+}
+
+pkg_postinst() {
+ if [[ -f "${ROOT}"/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${ROOT}"/usr/bin/rpm --rebuilddb --root="${ROOT}"
+ else
+ einfo "No RPM database found... Creating database..."
+ "${ROOT}"/usr/bin/rpm --initdb --root="${ROOT}"
+ fi
+
+ distutils_pkg_postinst
+}