summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/php/php-4.0.6-r2.ebuild3
-rw-r--r--media-video/mplayer/files/digest-mplayer-0.50-r22
-rw-r--r--net-misc/openssh/openssh-3.0_p1-r6.ebuild17
-rw-r--r--sys-apps/parted/parted-1.4.17.ebuild6
-rw-r--r--sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild31
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild4
6 files changed, 46 insertions, 17 deletions
diff --git a/dev-lang/php/php-4.0.6-r2.ebuild b/dev-lang/php/php-4.0.6-r2.ebuild
index 3a59dbc0e3d5..805a5d07c221 100644
--- a/dev-lang/php/php-4.0.6-r2.ebuild
+++ b/dev-lang/php/php-4.0.6-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.0.6-r2.ebuild,v 1.3 2001/11/10 11:31:53 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.0.6-r2.ebuild,v 1.4 2001/11/17 07:35:22 drobbins Exp $
S=${WORKDIR}/${PN}-4.0.6
DESCRIPTION="HTML embedded scripting language"
@@ -9,7 +9,6 @@ SRC_URI="http://www.php.net/distributions/${P}.tar.gz"
HOMEPAGE="http://www.php.net/"
DEPEND="virtual/glibc
-
>=dev-libs/gmp-3.1.1
~media-libs/freetype-1.3.1
>=media-libs/jpeg-6b
diff --git a/media-video/mplayer/files/digest-mplayer-0.50-r2 b/media-video/mplayer/files/digest-mplayer-0.50-r2
index 5422e7e5aea8..070d2c4c385d 100644
--- a/media-video/mplayer/files/digest-mplayer-0.50-r2
+++ b/media-video/mplayer/files/digest-mplayer-0.50-r2
@@ -1,3 +1,3 @@
MD5 b8c4fc82db0571a237bbed81c602d48c MPlayer-0.50.tar.bz2 1277952
-MD5 fe5d70fb6d2c2d1291940f947e12d471 default.tar.bz2 167936
+MD5 6382c30598973d05a95c25c723198e28 default.tar.bz2 167936
MD5 ab23f8e01a860a97852b28a3b0b118da mp-arial-iso-8859-1.zip 274432
diff --git a/net-misc/openssh/openssh-3.0_p1-r6.ebuild b/net-misc/openssh/openssh-3.0_p1-r6.ebuild
index c7997f5c0966..a034cf5e1e69 100644
--- a/net-misc/openssh/openssh-3.0_p1-r6.ebuild
+++ b/net-misc/openssh/openssh-3.0_p1-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.0_p1-r6.ebuild,v 1.1 2001/11/09 04:10:42 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.0_p1-r6.ebuild,v 1.2 2001/11/17 07:35:22 drobbins Exp $
P=openssh-3.0p1
S=${WORKDIR}/${P}
@@ -9,13 +9,8 @@ DESCRIPTION="Port of OpenBSD's free SSH release"
SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${P}.tar.gz"
HOMEPAGE="http://www.openssh.com/"
-RDEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-DEPEND="${RDEPEND} sys-devel/perl sys-apps/groff
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="virtual/glibc pam? ( >=sys-libs/pam-0.73 ) >=dev-libs/openssl-0.9.6 sys-libs/zlib "
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/groff tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
src_compile() {
@@ -35,6 +30,12 @@ src_compile() {
--with-ipv4-default \
--host=${CHOST} ${myconf} || die "bad configure"
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
make || die " compile problem"
}
diff --git a/sys-apps/parted/parted-1.4.17.ebuild b/sys-apps/parted/parted-1.4.17.ebuild
index 4843567a8ddd..0b27895daed0 100644
--- a/sys-apps/parted/parted-1.4.17.ebuild
+++ b/sys-apps/parted/parted-1.4.17.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Peter Gavin <pete@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.4.17.ebuild,v 1.2 2001/08/05 22:58:06 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.4.17.ebuild,v 1.3 2001/11/17 07:35:22 drobbins Exp $
#P=
A=${P}.tar.gz
@@ -16,9 +16,7 @@ RDEPEND="virtual/glibc
nls? ( sys-devel/gettext-0.10.38 )
python? ( >=dev-lang/python-2.0 )"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.50
- >=sys-devel/automake-1.4_p5"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild b/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild
new file mode 100644
index 000000000000..8b00d2475813
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-1.3.13.ebuild,v 1.1 2001/11/17 07:35:22 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs filesystem utilities"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/e2fsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/xfsprogs:/usr/share/doc/${PF}:" -e 's:-O1::' include/builddefs.orig > include/builddefs || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild
index b612c9c7139e..7a4fff001ecf 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild,v 1.2 2001/11/16 23:10:14 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.15_pre1.ebuild,v 1.3 2001/11/17 07:35:22 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -33,7 +33,7 @@ fi
# lm-sensors N lm_sensors Need to move this to its own ebuild
# Patch Versions
-ACPIV=20011102
+ACPIV=20011109
LVMV=1.0.1-rc4
EXT3V=0.9.15
LOWLV=2.4.14