summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/byacc/ChangeLog7
-rw-r--r--dev-util/byacc/Manifest4
-rw-r--r--dev-util/byacc/byacc-1.9-r1.ebuild30
-rw-r--r--dev-util/byacc/files/digest-byacc-1.9-r11
-rw-r--r--dev-util/yacc/ChangeLog7
-rw-r--r--dev-util/yacc/Manifest4
-rw-r--r--dev-util/yacc/files/digest-yacc-1.9.1-r21
-rw-r--r--dev-util/yacc/yacc-1.9.1-r2.ebuild42
8 files changed, 92 insertions, 4 deletions
diff --git a/dev-util/byacc/ChangeLog b/dev-util/byacc/ChangeLog
index 66b35219ef8c..f83c43fb0187 100644
--- a/dev-util/byacc/ChangeLog
+++ b/dev-util/byacc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/byacc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.3 2004/04/05 03:53:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.4 2004/04/05 04:14:03 agriffis Exp $
+
+*byacc-1.9-r1 (05 Apr 2004)
+
+ 05 Apr 2004; Aron Griffis <agriffis@gentoo.org> byacc-1.9-r1.ebuild:
+ I should have bumped the rev for the previous change... doing it now.
04 Apr 2004; Aron Griffis <agriffis@gentoo.org> byacc-1.9.ebuild,
files/byacc-1.9-ia64.patch, files/mkstemp.patch:
diff --git a/dev-util/byacc/Manifest b/dev-util/byacc/Manifest
index 5a2547cc2c9e..37ccabad8b50 100644
--- a/dev-util/byacc/Manifest
+++ b/dev-util/byacc/Manifest
@@ -1,5 +1,7 @@
-MD5 83676eb84f97fab9050bc49bbdd970a6 ChangeLog 638
+MD5 6be0055fc1f8baa005f54b6ab8c0a80e ChangeLog 811
MD5 8ba45fa5abb2b72b389a59cd9c375a1e byacc-1.9.ebuild 863
+MD5 8ba45fa5abb2b72b389a59cd9c375a1e byacc-1.9-r1.ebuild 863
MD5 463704e3c68fc5577c576216a24e9932 files/digest-byacc-1.9 61
MD5 df645d0e6382050201af35e3002dfc5b files/mkstemp.patch 413
MD5 c5a221a78a10f6156ea9ddb2ade30598 files/byacc-1.9-ia64.patch 504
+MD5 463704e3c68fc5577c576216a24e9932 files/digest-byacc-1.9-r1 61
diff --git a/dev-util/byacc/byacc-1.9-r1.ebuild b/dev-util/byacc/byacc-1.9-r1.ebuild
new file mode 100644
index 000000000000..8725863ed4c7
--- /dev/null
+++ b/dev-util/byacc/byacc-1.9-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9-r1.ebuild,v 1.1 2004/04/05 04:14:03 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="the best variant of the Yacc parser generator"
+HOMEPAGE="http://dickey.his.com/byacc/byacc.html"
+SRC_URI="http://sources.isc.org/devel/tools/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86 ppc ia64 ~sparc ~alpha ~mips ~hppa"
+
+src_compile() {
+ epatch ${FILESDIR}/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch ${FILESDIR}/byacc-1.9-ia64.patch
+
+ make PROGRAM=byacc CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin byacc
+ mv yacc.1 byacc.1
+ doman byacc.1
+ dodoc ACKNOWLEDGEMENTS MANIFEST NEW_FEATURES NOTES README
+}
diff --git a/dev-util/byacc/files/digest-byacc-1.9-r1 b/dev-util/byacc/files/digest-byacc-1.9-r1
new file mode 100644
index 000000000000..649c5c57da28
--- /dev/null
+++ b/dev-util/byacc/files/digest-byacc-1.9-r1
@@ -0,0 +1 @@
+MD5 7f6103d3f278f063bd75e492551ffec4 byacc-1.9.tar.gz 109892
diff --git a/dev-util/yacc/ChangeLog b/dev-util/yacc/ChangeLog
index ca43f824e027..5265d9d8bbd1 100644
--- a/dev-util/yacc/ChangeLog
+++ b/dev-util/yacc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/yacc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/ChangeLog,v 1.11 2004/04/05 04:03:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/ChangeLog,v 1.12 2004/04/05 04:09:12 agriffis Exp $
+
+*yacc-1.9.1-r2 (05 Apr 2004)
+
+ 05 Apr 2004; Aron Griffis <agriffis@gentoo.org> yacc-1.9.1-r2.ebuild:
+ I should have bumped the rev for the previous change... doing it now.
05 Apr 2004; Aron Griffis <agriffis@gentoo.org> yacc-1.9.1-r1.ebuild,
files/mkstemp.patch, files/yacc-1.9.1-ia64.patch:
diff --git a/dev-util/yacc/Manifest b/dev-util/yacc/Manifest
index d3fc55ef8ec6..66f1e732fc3d 100644
--- a/dev-util/yacc/Manifest
+++ b/dev-util/yacc/Manifest
@@ -1,5 +1,7 @@
-MD5 7751ed920f8a33e1805f84fcee4be183 ChangeLog 1577
+MD5 2390602b443415a6c23e9d3ca2312256 ChangeLog 1752
MD5 85c9b31b808057d03362e15c2daf7935 yacc-1.9.1-r1.ebuild 1074
+MD5 85c9b31b808057d03362e15c2daf7935 yacc-1.9.1-r2.ebuild 1074
MD5 afeab71394d9c421389458f63b2cb173 files/digest-yacc-1.9.1-r1 60
MD5 c5a221a78a10f6156ea9ddb2ade30598 files/yacc-1.9.1-ia64.patch 504
MD5 df645d0e6382050201af35e3002dfc5b files/mkstemp.patch 413
+MD5 afeab71394d9c421389458f63b2cb173 files/digest-yacc-1.9.1-r2 60
diff --git a/dev-util/yacc/files/digest-yacc-1.9.1-r2 b/dev-util/yacc/files/digest-yacc-1.9.1-r2
new file mode 100644
index 000000000000..108a2419a099
--- /dev/null
+++ b/dev-util/yacc/files/digest-yacc-1.9.1-r2
@@ -0,0 +1 @@
+MD5 3bcf50bece4ef1d0fbaf479e25790437 yacc-1.9.1.tar.Z 64805
diff --git a/dev-util/yacc/yacc-1.9.1-r2.ebuild b/dev-util/yacc/yacc-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..4d96e9066401
--- /dev/null
+++ b/dev-util/yacc/yacc-1.9.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/yacc/yacc-1.9.1-r2.ebuild,v 1.1 2004/04/05 04:09:12 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="Yacc"
+HOMEPAGE="http://dinosaur.compilertools.net/#yacc"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/devel/compiler-tools/${P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc ppc64 sparc alpha mips hppa amd64 ia64 s390"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=sys-apps/sed-4"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+
+ # Use our CFLAGS
+ sed -i -e 's: -O : $(CFLAGS) :' Makefile || die 'sed failed'
+
+ # mkstemp patch from byacc ebuild
+ epatch ${FILESDIR}/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch ${FILESDIR}/yacc-1.9.1-ia64.patch
+}
+
+src_compile() {
+ make clean || die
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin yacc || die
+ doman yacc.1
+ dodoc 00README* ACKNOWLEDGEMENTS NEW_FEATURES NO_WARRANTY NOTES README*
+}