summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/procmail/ChangeLog9
-rw-r--r--net-mail/procmail/files/digest-procmail-3.22-r41
-rw-r--r--net-mail/procmail/procmail-3.22-r4.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/net-mail/procmail/ChangeLog b/net-mail/procmail/ChangeLog
index 40be43265e6a..2c18b35b7e0b 100644
--- a/net-mail/procmail/ChangeLog
+++ b/net-mail/procmail/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-mail/procmail
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.6 2002/08/03 17:38:04 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/ChangeLog,v 1.7 2002/09/06 04:29:57 jhhudso Exp $
+*procmail-3.22-r4 (5 Sep 2002)
+
+ 5 Sep 2002; Jared H. Hudson <jhhudso@gentoo.org> procmail-3.22-r4.ebuild :
+
+ Added PROVIDE of virtual/mda. Thanks goes to Eric Renfro
+ <psi-jack@myrealbox.com> in reference to bug #6806.
+
*procmail-3.22-r3 (26 Jul 2002)
3 Aug 2002; Calum Selkirk <cselkirk@gentoo.org> procmail-3.22-r3.ebuild
diff --git a/net-mail/procmail/files/digest-procmail-3.22-r4 b/net-mail/procmail/files/digest-procmail-3.22-r4
new file mode 100644
index 000000000000..d14b9662a1d7
--- /dev/null
+++ b/net-mail/procmail/files/digest-procmail-3.22-r4
@@ -0,0 +1 @@
+MD5 1678ea99b973eb77eda4ecf6acae53f1 procmail-3.22.tar.gz 226817
diff --git a/net-mail/procmail/procmail-3.22-r4.ebuild b/net-mail/procmail/procmail-3.22-r4.ebuild
new file mode 100644
index 000000000000..7a16546685f7
--- /dev/null
+++ b/net-mail/procmail/procmail-3.22-r4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.22-r4.ebuild,v 1.1 2002/09/06 04:29:57 jhhudso Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mail delivery agent/filter"
+SRC_URI="http://www.procmail.org/${P}.tar.gz"
+HOMEPAGE="http://www.procmail.org/"
+
+DEPEND="virtual/glibc
+ virtual/mta"
+
+RDEPEND="virtual/glibc"
+
+PROVIDE="virtual/mda"
+
+SLOT="0"
+LICENSE="Artistic | GPL"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_compile() {
+
+ cp Makefile Makefile.orig
+# Added a -O2 at the end of CFLAGS to overcome what seems to be a
+# gcc-3.1 strstr() bug with more aggressive optimization flags
+# The order of the flags matters as the last flag passed clobbers
+# the first flag. i.e. if -O2 was placed before ${CFLAGS},
+# whatever optimization that is in ${CFLAGS} would clobber -O2
+ sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS} -O2:" \
+ -e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \
+ -e "s:#LOCKINGTEST=/tmp:LOCKINGTEST=/tmp:" Makefile.orig > Makefile
+
+ if [ -z "`use mbox`" ];
+ then
+# echo "# Use maildir-style mailbox in user's home directory" > ${S}/procmailrc
+# echo 'DEFAULT=$HOME/.maildir/' >> ${S}/procmailrc
+
+ # the above doesn't seem to work as MAILSPOOLDIR is still defined .. so
+
+ cd ${S}
+ patch -p1 <${FILESDIR}/gentoo-maildir.diff
+
+ else
+ echo '# Use mbox-style mailbox in /var/spool/mail' > ${S}/procmail
+ echo 'DEFAULT=/var/spool/mail/$LOGNAME' >> ${S}/procmailrc
+ fi
+
+ emake || die
+}
+
+src_install () {
+ cd ${S}/new
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail
+
+ insopts -m 2755
+ doins lockfile
+
+ dobin formail mailstat
+
+ doman *.1 *.5
+
+ cd ${S}
+ dodoc Artistic COPYING FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ insinto /etc
+ doins procmailrc
+
+ docinto examples
+ dodoc examples/*
+}
+