summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/cfengine/cfengine-1.6.3.ebuild26
-rw-r--r--net-misc/cfengine/cfengine-2.0.3.ebuild18
-rw-r--r--net-misc/cfengine/cfengine-2.0.6-r1.ebuild21
-rw-r--r--net-misc/cidr/cidr-2.3.1-r1.ebuild28
-rw-r--r--net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild36
-rw-r--r--net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild27
-rw-r--r--net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild29
-rw-r--r--net-misc/pimpd/pimpd-0.8.ebuild14
-rw-r--r--net-misc/slirp/slirp-1.0.13.ebuild17
-rw-r--r--net-misc/tsocks/tsocks-1.8_beta4.ebuild24
-rw-r--r--net-misc/whatmask/whatmask-1.1.ebuild22
-rw-r--r--net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild15
12 files changed, 121 insertions, 156 deletions
diff --git a/net-misc/cfengine/cfengine-1.6.3.ebuild b/net-misc/cfengine/cfengine-1.6.3.ebuild
index b1be4255eb79..2a78b595ce8a 100644
--- a/net-misc/cfengine/cfengine-1.6.3.ebuild
+++ b/net-misc/cfengine/cfengine-1.6.3.ebuild
@@ -1,32 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-1.6.3.ebuild,v 1.12 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-1.6.3.ebuild,v 1.13 2003/09/08 06:43:56 vapier Exp $
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="An agent/software robot and a high level policy language for
-building expert systems to administrate and configure large computer
-networks"
-
-SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${A}"
+DESCRIPTION="agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks"
HOMEPAGE="http://www.iu.hio.no/cfengine/"
+SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
DEPEND=">=sys-libs/glibc-2.1.3
>=app-text/tetex-1.0.7-r2"
src_compile() {
- cd ${S}
- try ./configure
-
- try make
+ ./configure || die
+ make || die
}
-src_install () {
- cd ${S}
- try make DESTDIR=${D} install
- try make DESTDIR=${D}/doc install
+src_install() {
+ make DESTDIR=${D} install || die
dodoc COPYING ChangeLog README
}
diff --git a/net-misc/cfengine/cfengine-2.0.3.ebuild b/net-misc/cfengine/cfengine-2.0.3.ebuild
index 0cb6dcb7007f..18457585d216 100644
--- a/net-misc/cfengine/cfengine-2.0.3.ebuild
+++ b/net-misc/cfengine/cfengine-2.0.3.ebuild
@@ -1,27 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-2.0.3.ebuild,v 1.11 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-2.0.3.ebuild,v 1.12 2003/09/08 06:43:56 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="An agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks"
-SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
HOMEPAGE="http://www.iu.hio.no/cfengine/"
+SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
DEPEND="virtual/glibc
=sys-libs/db-3.2*
dev-libs/openssl"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
src_compile() {
- local myconf
- myconf="--with-berkeleydb=/usr"
- econf ${myconf} || die
+ econf --with-berkeleydb=/usr || die
emake || die
}
-src_install () {
+src_install() {
emake DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING DOCUMENTATION NEWS README SURVEY TODO
dodoc doc/*.html
diff --git a/net-misc/cfengine/cfengine-2.0.6-r1.ebuild b/net-misc/cfengine/cfengine-2.0.6-r1.ebuild
index cb1cd1f86004..20727a8e6d42 100644
--- a/net-misc/cfengine/cfengine-2.0.6-r1.ebuild
+++ b/net-misc/cfengine/cfengine-2.0.6-r1.ebuild
@@ -1,34 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-2.0.6-r1.ebuild,v 1.2 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/cfengine-2.0.6-r1.ebuild,v 1.3 2003/09/08 06:43:56 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="An agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks"
-SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
HOMEPAGE="http://www.iu.hio.no/cfengine/"
+SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
DEPEND="virtual/glibc
>=sys-libs/db-3.2
dev-libs/openssl"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~ppc"
-
src_unpack(){
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-db4.diff ||die
+ epatch ${FILESDIR}/${P}-db4.diff
}
src_compile() {
- local myconf
- myconf="--with-berkeleydb=/usr"
- econf ${myconf} || die
+ econf --with-berkeleydb=/usr || die
emake || die
}
-src_install () {
+src_install() {
emake DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING DOCUMENTATION NEWS README SURVEY TODO
dodoc doc/*.html
diff --git a/net-misc/cidr/cidr-2.3.1-r1.ebuild b/net-misc/cidr/cidr-2.3.1-r1.ebuild
index b865a748a032..e011f85aef89 100644
--- a/net-misc/cidr/cidr-2.3.1-r1.ebuild
+++ b/net-misc/cidr/cidr-2.3.1-r1.ebuild
@@ -1,31 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cidr/cidr-2.3.1-r1.ebuild,v 1.2 2003/09/05 22:01:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cidr/cidr-2.3.1-r1.ebuild,v 1.3 2003/09/08 06:45:13 vapier Exp $
-TARBALL="cidr-current.tar.gz"
-S=${WORKDIR}/${PN}-2.3
-DESCRIPTION="command line util to assist in calculating subnets."
-SRC_URI="http://home.netcom.com/~naym/cidr/${TARBALL}"
+DESCRIPTION="command line util to assist in calculating subnets"
HOMEPAGE="http://home.netcom.com/~naym/cidr/"
-DEPEND=""
-KEYWORDS="x86 sparc "
+SRC_URI="http://home.netcom.com/~naym/cidr/cidr-current.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc "
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}-2.3
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}.patch || die "patch failed"
+ epatch ${FILESDIR}/${P}.patch
}
src_compile() {
emake || die "make failed"
}
-src_install () {
-
- dobin cidr
- dodoc README ChangeLog
- doman cidr.1
+src_install() {
+ dobin cidr
+ dodoc README ChangeLog
+ doman cidr.1
}
-
diff --git a/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild b/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild
index a473f78e0bdf..5ab8375b857b 100644
--- a/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild
+++ b/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild
@@ -1,40 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild,v 1.8 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/lrzsz/lrzsz-0.12.20-r1.ebuild,v 1.9 2003/09/08 06:47:03 vapier Exp $
+
+inherit flag-o-matic
+append-flags -Wstrict-prototypes
-S=${WORKDIR}/${P}
DESCRIPTION="communication package providing the X, Y, and ZMODEM file transfer protocols"
-SRC_URI="http://www.ohse.de/uwe/releases/${P}.tar.gz"
HOMEPAGE="http://www.ohse.de/uwe/software/lrzsz.html"
-KEYWORDS="x86 sparc "
+SRC_URI="http://www.ohse.de/uwe/releases/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc"
DEPEND=""
-#RDEPEND=""
-
src_compile() {
- local options
-
- use nls || options="${options} --disable-nls"
-
- export CFLAGS="${CFLAGS} -Wstrict-prototypes"
-
- ./configure \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --host=${CHOST} \
- ${options} || die
-
+ econf `use_enable nls` || die
emake || die
}
-src_install () {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
install || die
dosym /usr/bin/lrb /usr/bin/rb
@@ -47,4 +36,3 @@ src_install () {
dodoc ABOUT-NLS AUTHORS COMPATABILITY COPYING ChangeLog NEWS
dodoc README* THANKS TODO
}
-
diff --git a/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild b/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild
index ed882668a7c5..3093f824668d 100644
--- a/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild
+++ b/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild
@@ -1,42 +1,41 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild,v 1.2 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r3.ebuild,v 1.3 2003/09/08 06:49:27 vapier Exp $
MY_P=netkit-ntalk-${PV}
S=${WORKDIR}/netkit-ntalk-${PV}
DESCRIPTION="Netkit - talkd"
-SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
-KEYWORDS="x86 ppc sparc alpha mips"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha mips"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
src_unpack() {
unpack ${A}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
- try ./configure
+ ./configure || die
cp MCONFIG MCONFIG.orig
sed -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG.orig > MCONFIG
- try make
+ make || die
}
src_install() {
insinto /etc/xinetd.d
newins ${FILESDIR}/talk.xinetd talk
into /usr
- dobin talk/talk
- doman talk/talk.1
+ dobin talk/talk
+ doman talk/talk.1
dosbin talkd/talkd
- dosym talkd /usr/sbin/in.talkd
- doman talkd/talkd.8
- dosym talkd.8.gz /usr/share/man/man8/in.talkd.8.gz
- dodoc README ChangeLog BUGS
+ dosym talkd /usr/sbin/in.talkd
+ doman talkd/talkd.8
+ dosym talkd.8.gz /usr/share/man/man8/in.talkd.8.gz
+ dodoc README ChangeLog BUGS
}
-
-
diff --git a/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild b/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild
index b3bc192863ef..08b1664cff9f 100644
--- a/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild
+++ b/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild
@@ -1,45 +1,44 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild,v 1.2 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netkit-talk/netkit-talk-0.17-r4.ebuild,v 1.3 2003/09/08 06:49:27 vapier Exp $
-IUSE="ipv6"
MY_P=netkit-ntalk-${PV}
S=${WORKDIR}/netkit-ntalk-${PV}
DESCRIPTION="Netkit - talkd"
-SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
HOMEPAGE="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+IUSE="ipv6"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
src_unpack() {
unpack ${A}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}
use ipv6 && patch -p1 < ${FILESDIR}/${P}-ipv6.diff
}
src_compile() {
- try ./configure
+ ./configure || die
cp MCONFIG MCONFIG.orig
sed -e "s:-O2 -Wall:-Wall:" -e "s:-Wpointer-arith::" MCONFIG.orig > MCONFIG
- try make
+ make || die
}
src_install() {
insinto /etc/xinetd.d
newins ${FILESDIR}/talk.xinetd talk
into /usr
- dobin talk/talk
- doman talk/talk.1
+ dobin talk/talk
+ doman talk/talk.1
dosbin talkd/talkd
- dosym talkd /usr/sbin/in.talkd
- doman talkd/talkd.8
- dosym talkd.8.gz /usr/share/man/man8/in.talkd.8.gz
- dodoc README ChangeLog BUGS
+ dosym talkd /usr/sbin/in.talkd
+ doman talkd/talkd.8
+ dosym talkd.8.gz /usr/share/man/man8/in.talkd.8.gz
+ dodoc README ChangeLog BUGS
}
-
-
diff --git a/net-misc/pimpd/pimpd-0.8.ebuild b/net-misc/pimpd/pimpd-0.8.ebuild
index 173763378df3..8bfc3e1c30ed 100644
--- a/net-misc/pimpd/pimpd-0.8.ebuild
+++ b/net-misc/pimpd/pimpd-0.8.ebuild
@@ -1,22 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pimpd/pimpd-0.8.ebuild,v 1.10 2003/09/05 22:01:49 msterret Exp $
-# Updated to version 0.8 by Olivier Reisch on Fri Apr 26 11:44:26 CEST 2002
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pimpd/pimpd-0.8.ebuild,v 1.11 2003/09/08 06:50:51 vapier Exp $
-A=pimpd_0.8.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="pimpd is a (hopefully) RFC1413-compliant identd server supporting Linux 2.2.x masqueraded connections and Linux 2.4.x connection tracking for use with NAT."
-SRC_URI="http://cats.meow.at/~peter/${A}"
+DESCRIPTION="RFC1413-compliant identd server supporting masqueraded connections"
HOMEPAGE="http://cats.meow.at/~peter/pimpd.html"
-KEYWORDS="x86 sparc "
+SRC_URI="http://cats.meow.at/~peter/pimpd_${PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc"
src_compile() {
make CFLAGS="$CFLAGS" || die
}
-src_install () {
+src_install() {
dosbin pimpd
dodoc README
}
diff --git a/net-misc/slirp/slirp-1.0.13.ebuild b/net-misc/slirp/slirp-1.0.13.ebuild
index 00dd264007f2..db8fbf932bc0 100644
--- a/net-misc/slirp/slirp-1.0.13.ebuild
+++ b/net-misc/slirp/slirp-1.0.13.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/slirp/slirp-1.0.13.ebuild,v 1.9 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/slirp/slirp-1.0.13.ebuild,v 1.10 2003/09/08 06:51:27 vapier Exp $
-A="${P}.tar.gz"
-S=${WORKDIR}/${P}
DESCRIPTION="Emulates a PPP or SLIP connection over a terminal"
-SRC_URI="http://download.sourceforge.net/slirp/slirp-1.0.13.tar.gz"
-HOMEPAGE="http://slirp.sourceforge.net"
+HOMEPAGE="http://slirp.sourceforge.net/"
+SRC_URI="http://download.sourceforge.net/slirp/${P}.tar.gz"
+
KEYWORDS="x86 sparc "
-LICENSE="slirp"
SLOT="0"
+LICENSE="slirp"
DEPEND="virtual/glibc"
src_compile() {
cd src
- try ./configure
- try make
+ ./configure || die
+ make || die
}
-src_install () {
+src_install() {
dobin src/slirp
cp src/slirp.man slirp.1
doman slirp.1
diff --git a/net-misc/tsocks/tsocks-1.8_beta4.ebuild b/net-misc/tsocks/tsocks-1.8_beta4.ebuild
index 6e4257c86c86..2dec243fc3fa 100644
--- a/net-misc/tsocks/tsocks-1.8_beta4.ebuild
+++ b/net-misc/tsocks/tsocks-1.8_beta4.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tsocks/tsocks-1.8_beta4.ebuild,v 1.11 2003/08/21 23:18:39 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsocks/tsocks-1.8_beta4.ebuild,v 1.12 2003/09/08 06:54:24 vapier Exp $
-DESCRIPTION="Transparent SOCKS v4 proxying library."
+DESCRIPTION="Transparent SOCKS v4 proxying library"
HOMEPAGE="http://tsocks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tsocks/${PN}-${PV/_}.tar.gz"
+
LICENSE="GPL-2"
-DEPEND="virtual/glibc"
-SRC_URI="http://ftp1.sourceforge.net/${PN}/${PN}-1.8beta4.tar.gz"
-KEYWORDS="x86 sparc amd64 ~alpha"
SLOT="0"
+KEYWORDS="x86 sparc amd64 ~alpha"
S=${WORKDIR}/tsocks-1.8
@@ -16,15 +16,16 @@ src_compile() {
# NOTE: the docs say to install it into /lib. If you put it into
# /usr/lib and add it to /etc/ld.so.preload on many systems /usr isn't
# mounted in time :-( (Ben Lutgens) <lamer@gentoo.org>
- try ./configure \
+ ./configure \
--host=${CHOST} \
--prefix=/usr \
--with-conf=/etc/socks/tsocks.conf \
- --mandir=/usr/share/man
- try emake
+ --mandir=/usr/share/man \
+ || die
+ emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dobin validateconf inspectsocks saveme
insinto /etc/socks
@@ -35,7 +36,6 @@ src_install () {
dosym /lib/libtsocks.so /usr/lib/libtsocks.so
}
-pkg_postinst () {
- einfo "Make sure you create /etc/socks/tsocks.conf from on of the
- examples in that directory"
+pkg_postinst() {
+ einfo "Make sure you create /etc/socks/tsocks.conf from on of the examples in that directory"
}
diff --git a/net-misc/whatmask/whatmask-1.1.ebuild b/net-misc/whatmask/whatmask-1.1.ebuild
index f23e4bfaeb52..9d356dec73b3 100644
--- a/net-misc/whatmask/whatmask-1.1.ebuild
+++ b/net-misc/whatmask/whatmask-1.1.ebuild
@@ -1,29 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whatmask/whatmask-1.1.ebuild,v 1.9 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whatmask/whatmask-1.1.ebuild,v 1.10 2003/09/08 06:55:04 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="little C program to compute different subnet mask notations"
-SRC_URI="http://downloads.laffeycomputer.com/current_builds/whatmask/${P}.tar.gz"
HOMEPAGE="http://www.laffeycomputer.com/whatmask.html"
-DEPEND="virtual/glibc"
-KEYWORDS="x86 sparc "
+SRC_URI="http://downloads.laffeycomputer.com/current_builds/whatmask/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc"
-#RDEPEND=""
+DEPEND="virtual/glibc"
src_compile() {
- try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
-
+ econf || die
emake || die
- #make || die
}
-src_install () {
-
- # try make prefix=${D}/usr install
-
- try make DESTDIR=${D} install
+src_install() {
+ make DESTDIR=${D} install || die
dodoc README INSTALL AUTHORS ChangeLog NEWS
}
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild
index 1f498a533c42..5153a543b5e0 100644
--- a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild
+++ b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild,v 1.13 2003/09/05 22:01:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.2-r1.ebuild,v 1.14 2003/09/08 06:55:59 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="X11-based passphrase dialog for use with OpenSSH"
HOMEPAGE="http://www.liquidmeme.net/software/x11-ssh-askpass/"
SRC_URI="http://www.liquidmeme.net/software/${PN}/${P}.tar.gz"
-KEYWORDS="x86 sparc ~alpha ppc"
+
LICENSE="as-is"
SLOT="0"
+KEYWORDS="x86 sparc ~alpha ppc"
-DEPEND="virtual/glibc virtual/x11"
-RDEPEND=">=net-misc/openssh-2.3.0 virtual/x11"
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND=">=net-misc/openssh-2.3.0
+ virtual/x11"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/stupid-imake.diff
+ epatch ${FILESDIR}/stupid-imake.diff
}
src_compile() {
./configure --prefix=/usr --libexecdir=/usr/lib/misc || die
@@ -25,7 +27,6 @@ src_compile() {
make "CDEBUGFLAGS=${CFLAGS}" || die
}
-
src_install() {
newman x11-ssh-askpass.man x11-ssh-askpass.1
dobin x11-ssh-askpass