summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/dspam-web/ChangeLog10
-rw-r--r--net-www/dspam-web/Manifest8
-rw-r--r--net-www/dspam-web/dspam-web-3.0.0.ebuild93
-rw-r--r--net-www/dspam-web/dspam-web-3.1.0_beta11.ebuild94
-rw-r--r--net-www/dspam-web/files/digest-dspam-web-3.0.01
-rw-r--r--net-www/dspam-web/files/digest-dspam-web-3.1.0_beta111
-rw-r--r--net-www/dspam-web/files/htaccess7
-rw-r--r--net-www/dspam-web/files/htpasswd1
-rw-r--r--net-www/dspam-web/metadata.xml9
9 files changed, 224 insertions, 0 deletions
diff --git a/net-www/dspam-web/ChangeLog b/net-www/dspam-web/ChangeLog
new file mode 100644
index 000000000000..251399ceb6ab
--- /dev/null
+++ b/net-www/dspam-web/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/dspam-web
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dspam-web/ChangeLog,v 1.1 2004/07/21 12:59:25 st_lim Exp $
+
+*dspam-web-3.1.0_beta11 (21 Jul 2004)
+
+ 21 Jul 2004; Lim Swee Tat <st_lim@gentoo.org> +files/htaccess,
+ +files/htpasswd, +dspam-web-3.0.0.ebuild, +dspam-web-3.1.0_beta11.ebuild:
+ Initial commit of dspam-web to support the use of dspam.
+
diff --git a/net-www/dspam-web/Manifest b/net-www/dspam-web/Manifest
new file mode 100644
index 000000000000..e3c7892f7fef
--- /dev/null
+++ b/net-www/dspam-web/Manifest
@@ -0,0 +1,8 @@
+MD5 1c5c72933289251b7514d3831c13dc41 dspam-web-3.0.0.ebuild 2465
+MD5 9e10b9b783b22effa2e1497ace7c25ae dspam-web-3.1.0_beta11.ebuild 2497
+MD5 04f9115bf613bbe8404dd2534ea7b805 ChangeLog 447
+MD5 f1ea445d6b4ddf81c55a4e886bc04218 metadata.xml 341
+MD5 ffdfc8d816078f4c58b75b9bed07503f files/htaccess 135
+MD5 b4099a94a52af9abd4ade48d82914c3c files/htpasswd 19
+MD5 05dce5dc8cf516655657aa2a4cc5f1da files/digest-dspam-web-3.0.0 63
+MD5 8fce97b718a95e27f75b811cde060f3c files/digest-dspam-web-3.1.0_beta11 72
diff --git a/net-www/dspam-web/dspam-web-3.0.0.ebuild b/net-www/dspam-web/dspam-web-3.0.0.ebuild
new file mode 100644
index 000000000000..6dfd827a1d53
--- /dev/null
+++ b/net-www/dspam-web/dspam-web-3.0.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dspam-web/dspam-web-3.0.0.ebuild,v 1.1 2004/07/21 12:59:25 st_lim Exp $
+
+inherit webapp
+
+MY_PN=${PN/-web/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://www.nuclearelephant.com/projects/dspam/sources/${MY_P}.tar.gz"
+
+HOMEPAGE="http://www.nuclearelephant.com/projects/dspam/index.html"
+LICENSE="GPL-2"
+DEPEND=">=mail-filter/dspam-3.1.0_beta11
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86"
+S=${WORKDIR}/${MY_P}/cgi
+
+src_compile () {
+ einfo "Nothing to compile"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/cgi/admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/cgi/dspam.cgi
+
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+
+ doins *.css
+ doins *.gif
+ doins rgb.txt
+ doins default.prefs
+ doins admins
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ insopts -m755 -o apache -g apache
+ doins *.cgi
+
+ for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
+ done
+
+ dodir ${MY_HTDOCSDIR}/templates
+
+ insinto ${MY_HTDOCSDIR}/templates
+ doins templates/*.html
+
+ #All files must be owned by server
+ cd ${D}${MY_HTDOCSDIR}
+ for x in `find . -type f -print` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/net-www/dspam-web/dspam-web-3.1.0_beta11.ebuild b/net-www/dspam-web/dspam-web-3.1.0_beta11.ebuild
new file mode 100644
index 000000000000..cd612aa6090a
--- /dev/null
+++ b/net-www/dspam-web/dspam-web-3.1.0_beta11.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dspam-web/dspam-web-3.1.0_beta11.ebuild,v 1.1 2004/07/21 12:59:25 st_lim Exp $
+
+inherit webapp
+
+MY_PN=${PN/-web/}
+MY_PV=${PV/_beta11/.beta.1.1}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Web based administration and user controls for dspam"
+SRC_URI="http://www.nuclearelephant.com/projects/dspam/sources/${MY_P}.tar.gz"
+
+HOMEPAGE="http://www.nuclearelephant.com/projects/dspam/index.html"
+LICENSE="GPL-2"
+DEPEND=">=mail-filter/dspam-3.1.0_beta11
+ >=net-www/apache-1.3
+ >=dev-lang/perl-5.8.2
+ >=dev-perl/GD-2.0
+ dev-perl/GD-Graph3d
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil"
+KEYWORDS="~x86"
+S=${WORKDIR}/${MY_P}/cgi
+
+src_compile () {
+ einfo "Nothing to compile"
+}
+
+src_install () {
+ webapp_src_preinst
+
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/admin.cgi
+ sed -e 's,/var/dspam,/etc/mail/dspam,' \
+ -e 's,/usr/local,/usr,' \
+ -i ${S}/dspam.cgi
+
+ insinto ${MY_HTDOCSDIR}
+ insopts -m644 -o apache -g apache
+
+ doins *.css
+ doins *.gif
+ doins rgb.txt
+ doins default.prefs
+ doins admins
+
+ newins ${FILESDIR}/htaccess .htaccess
+ newins ${FILESDIR}/htpasswd .htpasswd
+
+ insopts -m755 -o apache -g apache
+ doins *.cgi
+
+ for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
+ webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
+ done
+
+ dodir ${MY_HTDOCSDIR}/templates
+
+ insinto ${MY_HTDOCSDIR}/templates
+ doins templates/*.html
+
+ #All files must be owned by server
+ cd ${D}${MY_HTDOCSDIR}
+ for x in `find . -type f -print` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_src_install
+}
+
+pkg_config () {
+ # add apache to the dspam group so the CGIs can access the data
+
+ local groups
+ groups=`groups apache`
+ groups=`echo ${groups} | sed -e 's/ /,/g'`
+ usermod -G "${groups},dspam" apache
+}
+
+pkg_postinst () {
+ einfo "The CGIs need to be executed as group dspam in order to write"
+ einfo "to the dspam data directory. You will need to configure apache"
+ einfo "manually to do this. Another option is to add the user apache"
+ einfo "to the dspam group. You can do this automatically by running:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ echo
+ einfo "This app requires basic auth in order to operate properly."
+ einfo "You will need to add dspam users to the .htpasswd file or"
+ einfo "configure a different authentication mechanism for the user"
+ einfo "accounts."
+}
diff --git a/net-www/dspam-web/files/digest-dspam-web-3.0.0 b/net-www/dspam-web/files/digest-dspam-web-3.0.0
new file mode 100644
index 000000000000..f27f0f265cf9
--- /dev/null
+++ b/net-www/dspam-web/files/digest-dspam-web-3.0.0
@@ -0,0 +1 @@
+MD5 f5b568e8fea50faaf4c1fcabee177934 dspam-3.0.0.tar.gz 575382
diff --git a/net-www/dspam-web/files/digest-dspam-web-3.1.0_beta11 b/net-www/dspam-web/files/digest-dspam-web-3.1.0_beta11
new file mode 100644
index 000000000000..efadddcb0759
--- /dev/null
+++ b/net-www/dspam-web/files/digest-dspam-web-3.1.0_beta11
@@ -0,0 +1 @@
+MD5 2d059a9e94d30c23c8887d0a16892820 dspam-3.1.0.beta.1.1.tar.gz 608509
diff --git a/net-www/dspam-web/files/htaccess b/net-www/dspam-web/files/htaccess
new file mode 100644
index 000000000000..2fcb498667a4
--- /dev/null
+++ b/net-www/dspam-web/files/htaccess
@@ -0,0 +1,7 @@
+Options +ExecCGI
+DirectoryIndex dspam.cgi
+AuthAuthoritative On
+AuthType Basic
+AuthName DSPAM
+AuthUserFile .htpasswd
+Require valid-user
diff --git a/net-www/dspam-web/files/htpasswd b/net-www/dspam-web/files/htpasswd
new file mode 100644
index 000000000000..8dbcfae20848
--- /dev/null
+++ b/net-www/dspam-web/files/htpasswd
@@ -0,0 +1 @@
+root:aylR1sao2D.mE
diff --git a/net-www/dspam-web/metadata.xml b/net-www/dspam-web/metadata.xml
new file mode 100644
index 000000000000..246710b65f6b
--- /dev/null
+++ b/net-www/dspam-web/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<maintainer>
+ <email>st_lim@gentoo.org</email>
+</maintainer>
+<longdescription>Web Administrative interface for a statistical-algorithmic hybrid anti-spam filter</longdescription>
+</pkgmetadata>