summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xdotool/ChangeLog11
-rw-r--r--x11-misc/xdotool/Manifest4
-rw-r--r--x11-misc/xdotool/metadata.xml14
-rw-r--r--x11-misc/xdotool/xdotool-20090609.ebuild27
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
new file mode 100644
index 000000000000..dda2e805d85a
--- /dev/null
+++ b/x11-misc/xdotool/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/xdotool
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.1 2009/06/15 17:13:41 joker Exp $
+
+*xdotool-20090609 (15 Jun 2009)
+
+ 15 Jun 2009; Christian Birchinger <joker@gentoo.org>
+ +xdotool-20090609.ebuild:
+ Initial import. Thanks to Maryasin Semen <marsoft@ya.ru> and Urban
+ <urban82@gmail.com>
+
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
new file mode 100644
index 000000000000..17519e1f29e3
--- /dev/null
+++ b/x11-misc/xdotool/Manifest
@@ -0,0 +1,4 @@
+DIST xdotool-20090609.tar.gz 19061 RMD160 89b6bacb179a4b59db20a4664f7853274de39b4e SHA1 5aa8c218e6de1cc14835cf0fce6da8f985d7c63e SHA256 6a3283178ab72c9eef9ed846627e1d39ff3a9a2a9a77de5400a8f640fa42fa04
+EBUILD xdotool-20090609.ebuild 618 RMD160 396ae89ae0ab32c19b3e028fce60835a09f1823a SHA1 173bc219fed8c58bf1d794a7cc08066bfd7f2677 SHA256 eacb53894f6a595e4ef44be9b2c9df77254790bfad4819360249a1d1764cc663
+MISC ChangeLog 412 RMD160 d2de991cfd43109aed97de87300aa3214f8cd9ce SHA1 da034a30286c6400091375b7346f383865ad522b SHA256 5a976b29e0db9b76a9ec0fb56407c40f9dacebaf024ec2b2ccb8a2d4897134b2
+MISC metadata.xml 481 RMD160 64e577586b777ec3cd0968be05354b2d6edf1790 SHA1 042b6b55dba90dff77d3fa9201d4d62abbb1e251 SHA256 5bfee97d019d9c664ec75a56401eb36710303bb81d82401b01e16a6c2997fbf4
diff --git a/x11-misc/xdotool/metadata.xml b/x11-misc/xdotool/metadata.xml
new file mode 100644
index 000000000000..b1a7380fe0bd
--- /dev/null
+++ b/x11-misc/xdotool/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>joker@gentoo.org</email>
+<name>Christian Birchinger</name>
+</maintainer>
+<herd>no-herd</herd>
+<longdescription>
+This tool lets you programatically (or manually) simulate keyboard input and
+mouse activity, move and resize windows, etc. It does this using X11's XTEST
+extension and other Xlib functions.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-misc/xdotool/xdotool-20090609.ebuild b/x11-misc/xdotool/xdotool-20090609.ebuild
new file mode 100644
index 000000000000..e29618d35f6e
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-20090609.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-20090609.ebuild,v 1.1 2009/06/15 17:13:41 joker Exp $
+
+inherit eutils
+
+DESCRIPTION="Fake keyboard/mouse input"
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xdotool
+ doman xdotool.1
+}