summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/baselayout/ChangeLog7
-rw-r--r--sys-apps/baselayout/files/sysvinit-2.84-selinux1.patch16
-rw-r--r--sys-apps/i2c/Manifest20
3 files changed, 16 insertions, 27 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 3237a00f0edd..a045269cde97 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.209 2005/02/24 13:56:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.210 2005/02/24 23:20:34 pebenito Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 24 Feb 2005; Chris PeBenito <pebenito@gentoo.org>
+ files/sysvinit-2.84-selinux1.patch:
+ Fix paths in selinux patch to permanently fix #77101, since libselinux no
+ longer statically #define's them
+
24 Feb 2005; Chris Gianelloni <wolf31o2@gentoo.org>
files/rc-scripts-1.4.16-livecd.patch:
Updated livecd patch to allow for 19200 baud on serial console and also to
diff --git a/sys-apps/baselayout/files/sysvinit-2.84-selinux1.patch b/sys-apps/baselayout/files/sysvinit-2.84-selinux1.patch
index a82ddaa4ff57..4b80e1555721 100644
--- a/sys-apps/baselayout/files/sysvinit-2.84-selinux1.patch
+++ b/sys-apps/baselayout/files/sysvinit-2.84-selinux1.patch
@@ -20,18 +20,18 @@
+ extern char *selinux_mnt;
+
+ log(L_VB, "Loading security policy\n");
-+ if (mount("none", SELINUXMNT, "selinuxfs", 0, 0) < 0) {
++ if (mount("none", "/selinux/", "selinuxfs", 0, 0) < 0) {
+ if (errno == ENODEV) {
-+ log(L_VB, "SELinux not supported by kernel: %s\n",SELINUXMNT,strerror(errno));
++ log(L_VB, "SELinux not supported by kernel: %s\n","/selinux/",strerror(errno));
+ }
+ else {
-+ log(L_VB, "Failed to mount %s: %s\n",SELINUXMNT,strerror(errno));
++ log(L_VB, "Failed to mount %s: %s\n","/selinux/",strerror(errno));
+ return ret;
+ }
+ return ret; /* Never gets here */
+ }
+
-+ selinux_mnt = SELINUXMNT; /* set manually since we mounted it */
++ selinux_mnt = "/selinux/"; /* set manually since we mounted it */
+
+ policy_version=security_policyvers();
+ if (policy_version < 0) {
@@ -46,16 +46,16 @@
+ }
+ *enforce=rc;
+
-+ snprintf(policy_file,sizeof(policy_file),"%s.%d",SELINUXPOLICY,policy_version);
++ snprintf(policy_file,sizeof(policy_file),"%s.%d","/etc/security/selinux/policy",policy_version);
+ fd = open(policy_file, O_RDONLY);
+ if (fd < 0) {
+ /* Check previous version to see if old policy is available
+ */
-+ snprintf(policy_file,sizeof(policy_file),"%s.%d",SELINUXPOLICY,policy_version-1);
++ snprintf(policy_file,sizeof(policy_file),"%s.%d","/etc/security/selinux/policy",policy_version-1);
+ fd = open(policy_file, O_RDONLY);
+ if (fd < 0) {
+ log(L_VB, "Can't open '%s.%d': %s\n",
-+ SELINUXPOLICY,policy_version,strerror(errno));
++ "/etc/security/selinux/policy",policy_version,strerror(errno));
+ goto UMOUNT;
+ }
+ }
@@ -78,7 +78,7 @@
+ }
+
+ UMOUNT:
-+ /*umount(SELINUXMNT); */
++ /*umount("/selinux/"); */
+ if ( fd >= 0) {
+ close(fd);
+ }
diff --git a/sys-apps/i2c/Manifest b/sys-apps/i2c/Manifest
index 985c27acbd0c..68d7bbc51649 100644
--- a/sys-apps/i2c/Manifest
+++ b/sys-apps/i2c/Manifest
@@ -1,24 +1,8 @@
-MD5 94433f170d621f1d76d4f44f35dbebb3 i2c-2.8.8.ebuild 3496
-MD5 30ead69ab7518b03d75b86411eabf072 i2c-2.8.3.ebuild 3584
-MD5 e0bbf3b9f469dd20820b410c29b1b4e3 i2c-2.6.5-r1.ebuild 1182
-MD5 6dc4471c5d659ffb025d5e5adfe11ba7 i2c-2.8.0.ebuild 3548
MD5 6b68f571173c7911797f9d24a80a027f i2c-2.8.7.ebuild 3505
-MD5 1a0c94ca343d43a0152661b4c8bed187 i2c-2.8.2.ebuild 3599
MD5 83dfbb07a59ba91e17807317df429eb1 i2c-2.9.0.ebuild 2644
-MD5 694e536f25f31ec6f70155ec67871a1e i2c-2.8.4.ebuild 3499
-MD5 6819bd75a0de1cbeeee2184b6c00aa43 i2c-2.8.1.ebuild 3598
-MD5 af2ead6d82342adced31c2ea79efa11c ChangeLog 5715
-MD5 a76f13cb946fc2720c04b189616da2de metadata.xml 159
-MD5 7fb267ba3e7263e5424ba0d8a64e2069 i2c-2.7.0.ebuild 1304
-MD5 3576df9f3c7882d48106168eb8f7d51a files/digest-i2c-2.6.5-r1 61
+MD5 2b7fe2e91a8b5205c57ca427564972eb ChangeLog 5986
+MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
MD5 9a742c848861fdb77a2ece979a81edc3 files/i2c-2.8.0-alphaCompile.patch 353
-MD5 2e2470d20cbace5964fe8d32fd87200e files/digest-i2c-2.7.0 61
-MD5 98815b3534b98fe332ebd0121be2c5c0 files/digest-i2c-2.8.0 61
-MD5 6fd48fab2a59dd0de9299437a6a4ac01 files/digest-i2c-2.8.1 61
-MD5 4a11fc0743bbab53667047d79e3ddb47 files/digest-i2c-2.8.2 61
-MD5 3fcbcb26e62ebb13ccb35be0a7de2f3c files/digest-i2c-2.8.3 61
-MD5 3617d4ccdde4f981beb017ae657d9f5d files/digest-i2c-2.8.4 61
MD5 3d1523487606d28ad6cb49a5f34b1601 files/digest-i2c-2.8.7 61
-MD5 5e9a39e8feddd0556a74c69946cac4ba files/digest-i2c-2.8.8 61
MD5 09a33c917d4a0919bb6aa7d6d83402c0 files/digest-i2c-2.9.0 61
MD5 bf13f28c20a1fb6338fa2ced6fe4862d files/i2c-2.9.0.fix.patch 2570