summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-29 09:57:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-29 09:57:36 +0000
commitc65b76fd073bc2f7d79ab1a7b6020e4baac59e21 (patch)
tree3ec6789f736e69bbd3a0c9773ff95bc8b380ac31 /xfce-base
parentFixed compilation for x64-macos, keyworded, thanks to Jan Rieger in bug #413961 (diff)
downloadhistorical-c65b76fd073bc2f7d79ab1a7b6020e4baac59e21.tar.gz
historical-c65b76fd073bc2f7d79ab1a7b6020e4baac59e21.tar.bz2
historical-c65b76fd073bc2f7d79ab1a7b6020e4baac59e21.zip
Version bump.
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.8.0.ebuild38
-rw-r--r--xfce-base/garcon/ChangeLog7
-rw-r--r--xfce-base/garcon/garcon-0.2.0.ebuild32
-rw-r--r--xfce-base/libxfce4ui/ChangeLog8
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild45
-rw-r--r--xfce-base/libxfcegui4/ChangeLog8
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.10.0.ebuild41
8 files changed, 182 insertions, 4 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 957bc44a35ec..b31bbbc532df 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.75 2012/04/20 20:24:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.76 2012/04/29 09:57:36 ssuominen Exp $
+
+*exo-0.8.0 (29 Apr 2012)
+
+ 29 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +exo-0.8.0.ebuild:
+ Version bump.
20 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -exo-0.7.2.ebuild:
old
diff --git a/xfce-base/exo/exo-0.8.0.ebuild b/xfce-base/exo/exo-0.8.0.ebuild
new file mode 100644
index 000000000000..6255458e2d34
--- /dev/null
+++ b/xfce-base/exo/exo-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.8.0.ebuild,v 1.1 2012/04/29 09:57:36 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.24
+ dev-perl/URI
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}
diff --git a/xfce-base/garcon/ChangeLog b/xfce-base/garcon/ChangeLog
index e3a40518657e..26d9e96ac37e 100644
--- a/xfce-base/garcon/ChangeLog
+++ b/xfce-base/garcon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/garcon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/ChangeLog,v 1.43 2012/04/20 20:24:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/ChangeLog,v 1.44 2012/04/29 09:43:59 ssuominen Exp $
+
+*garcon-0.2.0 (29 Apr 2012)
+
+ 29 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> +garcon-0.2.0.ebuild:
+ Version bump.
20 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -garcon-0.1.10.ebuild,
-garcon-0.1.11.ebuild:
diff --git a/xfce-base/garcon/garcon-0.2.0.ebuild b/xfce-base/garcon/garcon-0.2.0.ebuild
new file mode 100644
index 000000000000..dd10a4aa0cd1
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/garcon-0.2.0.ebuild,v 1.1 2012/04/29 09:43:59 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="http://www.xfce.org/projects/libraries/"
+SRC_URI="mirror://xfce/src/libs/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=xfce-base/libxfce4util-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README STATUS TODO )
+}
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index 46721e1b8cca..5c5cd6dbb2b6 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.40 2012/04/22 18:33:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.41 2012/04/29 09:53:19 ssuominen Exp $
+
+*libxfce4ui-4.10.0 (29 Apr 2012)
+
+ 29 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libxfce4ui-4.10.0.ebuild:
+ Version bump.
22 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> -libxfce4ui-4.8.0.ebuild:
old
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
new file mode 100644
index 000000000000..b15ddc92fb3d
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.10.0.ebuild,v 1.1 2012/04/29 09:53:19 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}
diff --git a/xfce-base/libxfcegui4/ChangeLog b/xfce-base/libxfcegui4/ChangeLog
index 52f07da8b917..7e9d5a7c4347 100644
--- a/xfce-base/libxfcegui4/ChangeLog
+++ b/xfce-base/libxfcegui4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfcegui4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/ChangeLog,v 1.172 2012/04/14 14:53:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/ChangeLog,v 1.173 2012/04/29 09:48:57 ssuominen Exp $
+
+*libxfcegui4-4.10.0 (29 Apr 2012)
+
+ 29 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libxfcegui4-4.10.0.ebuild:
+ Version bump.
14 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
-libxfcegui4-4.8.1-r1.ebuild, -files/libxfcegui4-4.8.1-deprecated.patch:
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.10.0.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.10.0.ebuild
new file mode 100644
index 000000000000..b90001fe84e0
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.10.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/libxfcegui4-4.10.0.ebuild,v 1.1 2012/04/29 09:48:58 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="A compability library for unported Xfce 4.6 plugins"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="glade startup-notification"
+
+RDEPEND="gnome-base/libglade
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.8
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ --with-html-dir="${EPREFIX}"/deprecated
+ )
+}
+
+src_install() {
+ xfconf_src_install
+ rm -rf "${ED}"/deprecated
+}