summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-21 04:32:42 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-21 04:32:42 +0000
commiteee1bd19894fb61755310aed720af25d7aa67795 (patch)
treef5a841230c72e3b70e38c7625b54c181af776507 /xfce-base/thunar/thunar-1.0.1.ebuild
parentVersion bump for xfce-4.6.1 release, remove old (diff)
downloadhistorical-eee1bd19894fb61755310aed720af25d7aa67795.tar.gz
historical-eee1bd19894fb61755310aed720af25d7aa67795.tar.bz2
historical-eee1bd19894fb61755310aed720af25d7aa67795.zip
Version bump for xfce-4.6.1 release, remove old
Package-Manager: portage-2.1.6.11/cvs/Linux x86_64
Diffstat (limited to 'xfce-base/thunar/thunar-1.0.1.ebuild')
-rw-r--r--xfce-base/thunar/thunar-1.0.1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/thunar/thunar-1.0.1.ebuild b/xfce-base/thunar/thunar-1.0.1.ebuild
new file mode 100644
index 000000000000..64d8d5cad87a
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-1.0.1.ebuild,v 1.1 2009/04/21 04:28:48 darkside Exp $
+
+EAPI="2"
+
+MY_PN=${PN/t/T}
+inherit virtualx xfce4
+
+XFCE_VERSION=4.6.1
+
+xfce4_core
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug doc exif gnome hal pcre startup-notification +trash-plugin"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.6:2
+ >=dev-util/desktop-file-utils-0.14
+ >=media-libs/freetype-2
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.0
+ virtual/fam
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libSM
+ >=x11-misc/shared-mime-info-0.20
+ >=xfce-extra/exo-0.3.92[hal?]
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ dbus? ( dev-libs/dbus-glib )
+ exif? ( >=media-libs/libexif-0.6 )
+ hal? ( dev-libs/dbus-glib
+ sys-apps/hal )
+ gnome? ( gnome-base/gconf )
+ pcre? ( >=dev-libs/libpcre-6 )
+ startup-notification? ( x11-libs/startup-notification )
+ trash-plugin? ( dev-libs/dbus-glib
+ >=xfce-base/xfce4-panel-${XFCE_VERSION} )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ XFCE_CONFIG+="$(use_enable dbus) $(use_enable doc gtk-doc)
+ $(use_enable exif) $(use_enable gnome gnome-thumbnailers)
+ $(use_enable pcre)"
+
+ if use hal && ! use dbus; then
+ ewarn "USE hal detected, enabling dbus."
+ fi
+
+ if use hal; then
+ XFCE_CONFIG+=" --enable-dbus --with-volume-manager=hal"
+ else
+ XFCE_CONFIG+=" --with-volume-manager=none"
+ fi
+
+ if use trash-plugin && ! use dbus; then
+ XFCE_CONFIG+=" --enable-dbus"
+ ewarn "USE trash-plugin detected, enabling dbus."
+ fi
+
+ use trash-plugin || XFCE_CONFIG+=" --disable-tpa-plugin"
+}
+
+src_test() {
+ Xemake check || die "emake check failed"
+}
+
+DOCS="AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO"