summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:40:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:40:23 +0000
commita41db787f4517238309da1134b33223aaf2a81fe (patch)
treea4265105b4ac767b383f9af7e5c82301b97b65a1 /xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild
parentVersion bump. (diff)
downloadhistorical-a41db787f4517238309da1134b33223aaf2a81fe.tar.gz
historical-a41db787f4517238309da1134b33223aaf2a81fe.tar.bz2
historical-a41db787f4517238309da1134b33223aaf2a81fe.zip
Version bump.
Package-Manager: portage-2.2.0_alpha174/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild')
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild
new file mode 100644
index 000000000000..0aaac3bd786f
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/libxfce4util-4.10.1.ebuild,v 1.1 2013/05/05 16:31:21 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}