summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-17 12:30:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-17 12:30:57 +0000
commitf84654e84a0bff8c37c7412cefda7162a2536892 (patch)
tree9f7b0310016734284fae7195c13705032584596e /x11-wm
parentThis also hits openldap, so I'm masking a new build for that too (diff)
downloadhistorical-f84654e84a0bff8c37c7412cefda7162a2536892.tar.gz
historical-f84654e84a0bff8c37c7412cefda7162a2536892.tar.bz2
historical-f84654e84a0bff8c37c7412cefda7162a2536892.zip
new revision with the rootmenu patch
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/ChangeLog29
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.1.12-r12
-rw-r--r--x11-wm/fluxbox/files/fluxbox-0.1.9-gentoo.diff26
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.12-r1.ebuild49
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.12.ebuild10
5 files changed, 80 insertions, 36 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index fdbe2a598fe3..4cc73f3e642d 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,33 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.30 2002/09/14 01:53:39 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.31 2002/09/17 12:30:57 seemant Exp $
+
+*fluxbox-0.1.12-r1 (17 Sep 2002)
+
+ 17 Sep 2002; Seemant Kulleen <seemant@gentoo.org> fluxbox-0.1.12-r1.ebuild
+ files/digest-fluxbox-0.1.12-r1 :
+
+ This revision bump incorporates two patches. The first is the Vano patch
+ from bug #5005 which makes the root menu disappear on left click anywhere.
+ The second is the rootmenu patch which was posted many months ago on the
+ fluxbox mailing lists against an older version of fluxbox. The patch was
+ recently foreported to this version of flux by Rachel Holmes. The
+ original patch was BSD licensed, as is Rachel's version of it. Basically,
+ it allows the rootmenu to be bound to a key. So, for instance, in
+ ~/.fluxbox/keys:
+
+ Mod4 :RootMenu
+
+ will cause the fluxbox menu to open when the "windows logo" key is pressed
+ (x86 machine). Use xmodmap etc to flavour as you like it. Seemant is on
+ an x86 and has these entries in his local keys file:
+
+ None Super_L :RootMenu
+ None Super_L :Close
+ Shift Right :OpenSubMenu
+ Shift Return :SelectMenuItem
+ Shift Up :PrevMenuItem
+ Shift Down :NextMenuItem
*fluxbox-0.1.12 (13 Sep 2002)
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.1.12-r1 b/x11-wm/fluxbox/files/digest-fluxbox-0.1.12-r1
new file mode 100644
index 000000000000..a839ab0a9fe4
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.1.12-r1
@@ -0,0 +1,2 @@
+MD5 f90b191af969b49be3dcf901c36d5e13 fluxbox-0.1.12.tar.gz 417680
+MD5 87c91f4c042c4031e7d2be0fda22bb1a fluxbox-gentoo.diff.bz2 2554
diff --git a/x11-wm/fluxbox/files/fluxbox-0.1.9-gentoo.diff b/x11-wm/fluxbox/files/fluxbox-0.1.9-gentoo.diff
deleted file mode 100644
index 3267749c2a93..000000000000
--- a/x11-wm/fluxbox/files/fluxbox-0.1.9-gentoo.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -U1 -r1.59 Window.cc
---- Window.cc 4 Jun 2002 09:50:58 -0000 1.59
-+++ Window.cc 9 Jun 2002 12:31:01 -0000
-@@ -3703,5 +3703,10 @@
-
-- while (tr->client.transient)
-+ while (tr->client.transient) {
- tr = tr->client.transient;
--
-+ if (tr == tr->client.transient) { //ops! something is wrong with transient
-+ tr->client.transient = 0;
-+ }
-+ }
-+
-+
- client.transient_for = tr;
-@@ -3713,4 +3718,8 @@
-
-- while (tr->client.transient)
-+ while (tr->client.transient) {
- tr = tr->client.transient;
-+ if (tr == tr->client.transient) { //ops! somehtin is wrong with transient
-+ tr->client.transient = 0;
-+ }
-+ }
-
diff --git a/x11-wm/fluxbox/fluxbox-0.1.12-r1.ebuild b/x11-wm/fluxbox/fluxbox-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..309d19bba9b5
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-0.1.12-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.12-r1.ebuild,v 1.1 2002/09/17 12:30:57 seemant Exp $
+
+inherit commonbox flag-o-matic
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on Blackbox and pwm -- has tabs."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-gentoo.diff.bz2"
+HOMEPAGE="http://fluxbox.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+
+mydoc="ChangeLog COPYING NEWS"
+myconf="--enable-xinerama"
+filter-flags -fno-exceptions
+export WANT_AUTOMAKE_1_6=1
+export WANT_AUTOCONF_2_5=1
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ bzcat ${DISTDIR}/${PN}-gentoo.diff.bz2 | patch -p1 || die
+}
+
+src_compile() {
+
+ commonbox_src_compile
+
+ cd data
+ make \
+ pkgdatadir=/usr/share/commonbox init
+}
+
+
+src_install() {
+
+ commonbox_src_install
+ cd data
+ insinto /usr/share/commonbox
+ doins init
+ insinto /usr/share/commonbox/fluxbox
+ doins keys
+}
diff --git a/x11-wm/fluxbox/fluxbox-0.1.12.ebuild b/x11-wm/fluxbox/fluxbox-0.1.12.ebuild
index e32751f9e6ca..4e262ae6d9af 100644
--- a/x11-wm/fluxbox/fluxbox-0.1.12.ebuild
+++ b/x11-wm/fluxbox/fluxbox-0.1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.12.ebuild,v 1.1 2002/09/14 01:52:22 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.12.ebuild,v 1.2 2002/09/17 12:30:57 seemant Exp $
inherit commonbox flag-o-matic
@@ -19,14 +19,6 @@ filter-flags -fno-exceptions
export WANT_AUTOMAKE_1_6=1
export WANT_AUTOCONF_2_5=1
-src_unpack() {
-
- unpack ${P}.tar.gz
-
- cd ${S}
- patch -p1 < ${FILESDIR}/${PN}-vano-gentoo.patch || die
-}
-
src_compile() {
commonbox_src_compile