summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
author <jerrya@gentoo.org>2001-11-27 07:43:13 +0000
committer <jerrya@gentoo.org>2001-11-27 07:43:13 +0000
commit8548aa1bed81333d23605fd8e3cad60d7c491d16 (patch)
treecb62a0c62fa4d48d774e9b08ca7f877b55a17b19 /x11-wm
parentoops, small doc typo (diff)
downloadhistorical-8548aa1bed81333d23605fd8e3cad60d7c491d16.tar.gz
historical-8548aa1bed81333d23605fd8e3cad60d7c491d16.tar.bz2
historical-8548aa1bed81333d23605fd8e3cad60d7c491d16.zip
Slew of updates. Updated to the latest versions of the affected
programs, cleaned up the ebuilds to conform to the new standards, and removed the older/stale versions...
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.0-r11
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.31
-rw-r--r--x11-wm/fvwm/fvwm-2.4.3.ebuild (renamed from x11-wm/fvwm/fvwm-2.4.0-r1.ebuild)28
3 files changed, 17 insertions, 13 deletions
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.0-r1 b/x11-wm/fvwm/files/digest-fvwm-2.4.0-r1
deleted file mode 100644
index 5dc2a40fe19e..000000000000
--- a/x11-wm/fvwm/files/digest-fvwm-2.4.0-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 897f7fb2c4f23bc246eeb36d0dd1a2c2 fvwm-2.4.0.tar.bz2 1265664
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.3 b/x11-wm/fvwm/files/digest-fvwm-2.4.3
new file mode 100644
index 000000000000..320e2c496b44
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.4.3
@@ -0,0 +1 @@
+MD5 3fd013d29242570359028ec0096f8ae6 fvwm-2.4.3.tar.bz2 1306624
diff --git a/x11-wm/fvwm/fvwm-2.4.0-r1.ebuild b/x11-wm/fvwm/fvwm-2.4.3.ebuild
index 0a40a89d19ab..fe17ddd52c35 100644
--- a/x11-wm/fvwm/fvwm-2.4.0-r1.ebuild
+++ b/x11-wm/fvwm/fvwm-2.4.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Prakash Shetty <crux@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.0-r1.ebuild,v 1.3 2001/10/12 01:07:55 hallski Exp $
+# /space/gentoo/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.0-r1.ebuild,v 1.3 2001/10/12 01:07:55 hallski Exp
S=${WORKDIR}/${P}
@@ -15,19 +15,23 @@ DEPEND="virtual/glibc
>=dev-libs/libstroke-0.4
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+
src_compile() {
- local myconf
- if [ -n "$( use gnome )" ]
- then
- myconf="--with-gnome"
- else
- myconf="--without-gnome"
- fi
- try ./configure --prefix=/usr --libexecdir=/usr/lib \
- --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST} ${myconf}
- try make
+ local myconf
+ if [ -n "$( use gnome )" ]; then
+ myconf="--with-gnome"
+ else
+ myconf="--without-gnome"
+ fi
+
+ ./configure --prefix=/usr --host=${CHOST} \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info ${myconf}
+
+ emake || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
}