summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-11-11 22:10:44 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-11-11 22:10:44 +0000
commit728c5ea88a12afe6f745ec9ad847c22833ab0a6e (patch)
treeaca8deba486320247b629d4a172b17b15022a044 /x11-wm
parentadded embedded profile topdir, this is not usable yet.. (diff)
downloadhistorical-728c5ea88a12afe6f745ec9ad847c22833ab0a6e.tar.gz
historical-728c5ea88a12afe6f745ec9ad847c22833ab0a6e.tar.bz2
historical-728c5ea88a12afe6f745ec9ad847c22833ab0a6e.zip
perllib fix
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff11
-rw-r--r--x11-wm/fvwm/fvwm-2.5.8.ebuild7
2 files changed, 17 insertions, 1 deletions
diff --git a/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff b/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff
new file mode 100644
index 000000000000..729c9896cf02
--- /dev/null
+++ b/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff
@@ -0,0 +1,11 @@
+diff -ruN fvwm-2.5.8.orig/perllib/FVWM/Module/Tk.pm fvwm-2.5.8/perllib/FVWM/Module/Tk.pm
+--- fvwm-2.5.8.orig/perllib/FVWM/Module/Tk.pm 2003-10-23 13:07:10.000000000 +0100
++++ fvwm-2.5.8/perllib/FVWM/Module/Tk.pm 2003-11-11 21:37:03.000000000 +0000
+@@ -51,6 +51,7 @@
+ $top->fileevent($self->{istream},
+ readable => sub {
+ unless ($self->processPacket($self->readPacket)) {
++ $self->disconnect;
+ $top->destroy;
+ } else {
+ $self->eventLoopPrepared(@params);
diff --git a/x11-wm/fvwm/fvwm-2.5.8.ebuild b/x11-wm/fvwm/fvwm-2.5.8.ebuild
index bfb155fe812e..e49ac7899192 100644
--- a/x11-wm/fvwm/fvwm-2.5.8.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8.ebuild,v 1.10 2003/11/11 21:26:50 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8.ebuild,v 1.11 2003/11/11 22:10:43 taviso Exp $
inherit eutils flag-o-matic
@@ -67,6 +67,11 @@ src_unpack() {
# moving it into ~/.fvwmtabs.state will do for now.
cd ${WORKDIR}; epatch ${FILESDIR}/fvwmtabs-insecure-tmp-handling.diff
+ # this patch was sent to the fvwm-workers mailing list in
+ # <20031111234845.A12314@deepblue.milkyway.com.au>, perllib applications
+ # were getting destroyed before the ON_EXIT handler could be invoked.
+ cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-perllib-disconnect.diff
+
# build fails on alpha with certain options without this.
use alpha && append-flags -fPIC
}