summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2005-10-29 20:35:42 +0000
committerTom William Payne <twp@gentoo.org>2005-10-29 20:35:42 +0000
commit5317e4838d61066028ef89ed85ed5c4cf4bfbde7 (patch)
tree1f30c8f6e461b7336f6a556f52f405fa4fd3947b /x11-wm
parentremoved a lot of old versions (diff)
downloadhistorical-5317e4838d61066028ef89ed85ed5c4cf4bfbde7.tar.gz
historical-5317e4838d61066028ef89ed85ed5c4cf4bfbde7.tar.bz2
historical-5317e4838d61066028ef89ed85ed5c4cf4bfbde7.zip
Version bump.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ion3/ChangeLog7
-rw-r--r--x11-wm/ion3/Manifest4
-rw-r--r--x11-wm/ion3/files/digest-ion3-200510291
-rw-r--r--x11-wm/ion3/ion3-20051029.ebuild68
4 files changed, 78 insertions, 2 deletions
diff --git a/x11-wm/ion3/ChangeLog b/x11-wm/ion3/ChangeLog
index ae6176161e8f..c6360ab4aa77 100644
--- a/x11-wm/ion3/ChangeLog
+++ b/x11-wm/ion3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ion3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.26 2005/10/26 12:00:12 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ChangeLog,v 1.27 2005/10/29 20:35:42 twp Exp $
+
+*ion3-20051029 (29 Oct 2005)
+
+ 29 Oct 2005; Tom Payne <twp@gentoo.org> +ion3-20051029.ebuild:
+ Version bump.
*ion3-20051023-r1 (26 Oct 2005)
diff --git a/x11-wm/ion3/Manifest b/x11-wm/ion3/Manifest
index d56c0a5e7e6e..4042407bb291 100644
--- a/x11-wm/ion3/Manifest
+++ b/x11-wm/ion3/Manifest
@@ -1,11 +1,13 @@
-MD5 c0b8d954a01ff53710f3b954c859460e ChangeLog 3728
+MD5 687833e77731e920a74c58c1e93e421a ChangeLog 3840
MD5 f5a4c637813405c5a7b6a5fa8c68c748 files/digest-ion3-20050116 68
MD5 d2e9b37a47d3fc3cbb27f5da794f4eb2 files/digest-ion3-20050820 68
MD5 6cad8bd6cf9ed6738c455bf359ce1201 files/digest-ion3-20051023-r1 68
+MD5 776df82659ec1f00d3e91d59968d7d01 files/digest-ion3-20051029 68
MD5 09ea5f50bc26d0e5aaf4d81172771233 files/ion3-20051023-r1.patch 7554
MD5 00450ed1292b72e2be71b9860c4db6ee files/ion3.desktop 217
MD5 e5e408ab1f83116c2138a26b20c86653 files/pwm3.desktop 170
MD5 15e7cfd3c18e353dd36647b6e5b2023d ion3-20050116.ebuild 1588
MD5 b3f87a9c4eed784ced6d47f947de5527 ion3-20050820.ebuild 1593
MD5 0cbbd360ffac763e4de376e723f18bab ion3-20051023-r1.ebuild 1629
+MD5 0d5762ba1a825c4549d97d10631b28ef ion3-20051029.ebuild 1593
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
diff --git a/x11-wm/ion3/files/digest-ion3-20051029 b/x11-wm/ion3/files/digest-ion3-20051029
new file mode 100644
index 000000000000..08877a4ad31a
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20051029
@@ -0,0 +1 @@
+MD5 b055eab63623443f6aa80a8274dc761b ion-3ds-20051029.tar.gz 590222
diff --git a/x11-wm/ion3/ion3-20051029.ebuild b/x11-wm/ion3/ion3-20051029.ebuild
new file mode 100644
index 000000000000..5c886c22e3b5
--- /dev/null
+++ b/x11-wm/ion3/ion3-20051029.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion3/ion3-20051029.ebuild,v 1.1 2005/10/29 20:35:42 twp Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p/-}
+MY_PN=ion-3ds-${MY_PV}
+DESCRIPTION="A tiling tabbed window manager designed with keyboard users in mind"
+HOMEPAGE="http://www.iki.fi/tuomov/ion/"
+SRC_URI="http://modeemi.cs.tut.fi/~tuomov/ion/dl/${MY_PN}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="xinerama"
+DEPEND="virtual/x11
+ app-misc/run-mailcap
+ >=dev-lang/lua-5.0.2"
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+
+ autoreconf -i
+
+ local myconf=""
+
+ if has_version '>=x11-base/xfree-4.3.0'; then
+ myconf="${myconf} --disable-xfree86-textprop-bug-workaround"
+ fi
+
+ use hppa && myconf="${myconf} --disable-shared"
+
+ econf \
+ --sysconfdir=/etc/X11 \
+ `use_enable xinerama` \
+ ${myconf} || die
+
+ make \
+ DOCDIR=/usr/share/doc/${PF} || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ ETCDIR=${D}/etc/X11/ion3 \
+ SHAREDIR=${D}/usr/share/ion3 \
+ MANDIR=${D}/usr/share/man \
+ DOCDIR=${D}/usr/share/doc/${PF} \
+ LOCALEDIR=${D}/usr/share/locale \
+ LIBDIR=${D}/usr/lib \
+ MODULEDIR=${D}/usr/lib/ion3/mod \
+ LCDIR=${D}/usr/lib/ion3/lc \
+ VARDIR=${D}/var/cache/ion3 \
+ install || die
+
+ prepalldocs
+
+ echo -e "#!/bin/sh\n/usr/bin/ion3" > ${T}/ion3
+ echo -e "#!/bin/sh\n/usr/bin/pwm3" > ${T}/pwm3
+ exeinto /etc/X11/Sessions
+ doexe ${T}/ion3 ${T}/pwm3
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/ion3.desktop ${FILESDIR}/pwm3.desktop
+
+}