summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-03 10:48:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-03 10:48:03 +0000
commit27d567483917e74bbeedf68ae28a965374cf6c6f (patch)
treebc8516374c88c6344bf8c2b1f5d8bd5a0e9861ee /x11-wm
parentResolves bug #7399. Version bump. Repoman fix. Gcc3.2 patch. (diff)
downloadhistorical-27d567483917e74bbeedf68ae28a965374cf6c6f.tar.gz
historical-27d567483917e74bbeedf68ae28a965374cf6c6f.tar.bz2
historical-27d567483917e74bbeedf68ae28a965374cf6c6f.zip
new aspell unmasked as well as apps which can make use of it
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/openbox-2.0.0.ebuild32
-rw-r--r--x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild26
2 files changed, 42 insertions, 16 deletions
diff --git a/x11-wm/openbox/openbox-2.0.0.ebuild b/x11-wm/openbox/openbox-2.0.0.ebuild
index 1a841b28a1a5..2ab9839a39ac 100644
--- a/x11-wm/openbox/openbox-2.0.0.ebuild
+++ b/x11-wm/openbox/openbox-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0.ebuild,v 1.1 2002/08/17 05:29:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0.ebuild,v 1.2 2002/09/03 10:48:03 seemant Exp $
inherit commonbox
@@ -15,10 +15,38 @@ KEYWORDS="x86 sparc sparc64"
MYBIN="${PN}"
mydoc="CHANGE* TODO LICENSE data/README*"
-myconf="--program-suffix=-dev --enable-xinerama"
+myconf="--enable-xinerama"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ cp Makefile.am Makefile.am.orig
+ sed 's/data //' Makefile.am.orig > Makefile.am
+
+ cd ${S}/util
+ cp Makefile.am Makefile.am.orig
+ sed -e 's/bsetbg//' \
+ -e 's/bsetroot//' \
+ Makefile.am.orig > Makefile.am
+}
+
+
src_compile() {
${S}/bootstrap
+
+ commonise=""
commonbox_src_compile
}
+
+src_install() {
+
+ commonbox_src_install
+ mv ${D}/usr/bin/openbox ${D}/usr/bin/openbox-dev
+ mv ${D}/usr/share/man/man1/openbox.1.gz \
+ {D}/usr/share/man/man1/openbox-dev.1.gz
+
+}
diff --git a/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild b/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild
index a36d46c73f38..5dc9add92fd6 100644
--- a/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild
+++ b/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild
@@ -1,5 +1,8 @@
# Copyright 2001 theLeaf sprl/bvba
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild,v 1.5 2002/08/14 15:45:39 murphy Exp $
+# Distributed under the terms of the GNU General Public License, v2.
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish-merlin/sawfish-merlin-1.0.1-r2.ebuild,v 1.6 2002/09/03 10:48:03 seemant Exp $
+
+inherit libtool
MY_P=${P/-merlin/}
S=${WORKDIR}/${MY_P}
@@ -35,9 +38,7 @@ src_unpack() {
cd ${S}/src
patch -p1 < ${FILESDIR}/x.c.patch-merlin-1.0.2 || die
- #update libtool for "relink" bug fix
- libtoolize --copy --force
- aclocal
+ elibtoolize
}
@@ -45,24 +46,21 @@ src_compile() {
local myconf
- use esd \
- && myconf="--with-esd" \
+ use esd \
+ && myconf="--with-esd" \
|| myconf="--without-esd"
- use gnome \
- && myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet" \
+ use gnome \
+ && myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet" \
|| myconf="${myconf} --disable-gnome-widgets --disable-capplet"
use nls || myconf="${myconf} --disable-linguas"
- use gtk || use gnome \
- && myconf="${myconf} --with-gdk-pixbuf" \
+ use gtk || use gnome \
+ && myconf="${myconf} --with-gdk-pixbuf" \
|| myconf="${myconf} --without-gdk-pixbuf"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
+ econf \
--libexecdir=/usr/lib \
--with-audiofile \
${myconf} || die