summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2008-01-02 20:35:14 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2008-01-02 20:35:14 +0000
commit3893c12aaa2360040d1a6956429f2ce9532c3ba2 (patch)
tree7c29b48b9e86c399e5899f26e3bef47270c35328 /x11-wm/xmonad/xmonad-0.5-r1.ebuild
parentadded a missing letter, pointed out by ikelos via mail (diff)
downloadhistorical-3893c12aaa2360040d1a6956429f2ce9532c3ba2.tar.gz
historical-3893c12aaa2360040d1a6956429f2ce9532c3ba2.tar.bz2
historical-3893c12aaa2360040d1a6956429f2ce9532c3ba2.zip
Install instructions and config sample for x11-wm/xmonad
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'x11-wm/xmonad/xmonad-0.5-r1.ebuild')
-rw-r--r--x11-wm/xmonad/xmonad-0.5-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/xmonad/xmonad-0.5-r1.ebuild b/x11-wm/xmonad/xmonad-0.5-r1.ebuild
new file mode 100644
index 000000000000..bc420063d6e4
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xmonad/xmonad-0.5-r1.ebuild,v 1.1 2008/01/02 20:35:13 kolmodin Exp $
+
+CABAL_FEATURES="bin lib profile haddock"
+CABAL_MIN_VERSION=1.2
+
+inherit haskell-cabal
+
+DESCRIPTION="A lightweight X11 window manager"
+HOMEPAGE="http://www.xmonad.org/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="dev-haskell/mtl
+ >=dev-haskell/x11-1.4
+ >=dev-lang/ghc-6.6"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ # -Wall -Werror is really fragile.
+ # portage strips, packages should not do it themselves.
+ sed -i -e 's/-Wall -Werror -optl-Wl,-s//' "${S}/xmonad.cabal"
+}
+
+src_install() {
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/xmonad" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ doman man/xmonad.1
+
+ dodoc CONFIG README man/xmonad.hs
+}