summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-04-20 23:15:10 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-04-20 23:15:10 +0000
commit8ca61ca05987a0dabdbaa3e5f14137b14caa7a63 (patch)
tree7e1a184d45461ae96759c5f71bcdb9b1b5ebe185 /x11-wm/metacity/metacity-2.14.3.ebuild
parentRelease of webapp-config 1.50.14 (diff)
downloadhistorical-8ca61ca05987a0dabdbaa3e5f14137b14caa7a63.tar.gz
historical-8ca61ca05987a0dabdbaa3e5f14137b14caa7a63.tar.bz2
historical-8ca61ca05987a0dabdbaa3e5f14137b14caa7a63.zip
new version. cleanup old 2.14 ebuilds. fixes #129731
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'x11-wm/metacity/metacity-2.14.3.ebuild')
-rw-r--r--x11-wm/metacity/metacity-2.14.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.14.3.ebuild b/x11-wm/metacity/metacity-2.14.3.ebuild
new file mode 100644
index 000000000000..c9c28949f254
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.14.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.14.3.ebuild,v 1.1 2006/04/20 23:15:10 allanonjl Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome default windowmanager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+# not parallel-safe; see bug #14405
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.2
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ !x11-misc/expocity"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+
+pkg_setup() {
+ # Compositor is too unreliable
+ G2CONF="$(use_enable xinerama) --disable-compositor"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Metacity & Xorg X11 with composite enabled may cause unwanted"
+ einfo "border effects"
+}