summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-05-31 09:42:57 +0000
committerMatti Bickel <mabi@gentoo.org>2007-05-31 09:42:57 +0000
commit640690238e65a15ab4a77ce813730c3aa56b6ed8 (patch)
treed841f15ddcbbac3c652e29a6b6f11d2e7ebe687b /x11-wm/ion3/files
parentFix javadoc installation. (diff)
downloadhistorical-640690238e65a15ab4a77ce813730c3aa56b6ed8.tar.gz
historical-640690238e65a15ab4a77ce813730c3aa56b6ed8.tar.bz2
historical-640690238e65a15ab4a77ce813730c3aa56b6ed8.zip
version bump
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'x11-wm/ion3/files')
-rw-r--r--x11-wm/ion3/files/20070506/200_all_fix_includes.patch22
-rw-r--r--x11-wm/ion3/files/20070506/201_all_fix-paths.patch90
-rw-r--r--x11-wm/ion3/files/20070506/202_all_fix-menus.patch13
-rw-r--r--x11-wm/ion3/files/20070506/205_all_ion-lock.patch22
-rw-r--r--x11-wm/ion3/files/20070506/208_all_as-needed.patch12
-rw-r--r--x11-wm/ion3/files/digest-ion3-2007050615
6 files changed, 174 insertions, 0 deletions
diff --git a/x11-wm/ion3/files/20070506/200_all_fix_includes.patch b/x11-wm/ion3/files/20070506/200_all_fix_includes.patch
new file mode 100644
index 000000000000..19f7edc512db
--- /dev/null
+++ b/x11-wm/ion3/files/20070506/200_all_fix_includes.patch
@@ -0,0 +1,22 @@
+diff -uNr ion-3rc-20070506.orig/ioncore/ioncore.c ion-3rc-20070506/ioncore/ioncore.c
+--- ion-3rc-20070506.orig/ioncore/ioncore.c 2007-05-12 22:04:33.000000000 +0200
++++ ion-3rc-20070506/ioncore/ioncore.c 2007-05-12 22:23:30.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <string.h>
++#include <strings.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <ctype.h>
+diff -uNr ion-3rc-20070506.orig/utils/ion-completefile/ion-completefile.c ion-3rc-20070506/utils/ion-completefile/ion-completefile.c
+--- ion-3rc-20070506.orig/utils/ion-completefile/ion-completefile.c 2007-05-12 22:04:33.000000000 +0200
++++ ion-3rc-20070506/utils/ion-completefile/ion-completefile.c 2007-05-12 22:05:13.000000000 +0200
+@@ -54,6 +54,7 @@
+
+ #include <sys/param.h>
+ #include <sys/types.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <dirent.h>
+ #include <string.h>
diff --git a/x11-wm/ion3/files/20070506/201_all_fix-paths.patch b/x11-wm/ion3/files/20070506/201_all_fix-paths.patch
new file mode 100644
index 000000000000..7f8f228fed40
--- /dev/null
+++ b/x11-wm/ion3/files/20070506/201_all_fix-paths.patch
@@ -0,0 +1,90 @@
+diff -Nur ion-3ds-20060519.orig/system.mk ion-3ds-20060519/system.mk
+--- ion-3ds-20060519.orig/system.mk 2006-05-18 18:06:53.000000000 -0500
++++ ion-3ds-20060519/system.mk 2006-05-18 23:51:23.000000000 -0500
+@@ -7,7 +7,7 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ # Unless you are creating a package conforming to some OS's standards, you
+ # probably do not want to modify the following directories:
+@@ -15,7 +15,7 @@
+ # Main binaries
+ BINDIR=$(PREFIX)/bin
+ # Configuration .lua files
+-ETCDIR=$(PREFIX)/etc/ion3
++ETCDIR=/etc/X11/ion3
+ # Some .lua files and ion-* shell scripts
+ SHAREDIR=$(PREFIX)/share/ion3
+ # Manual pages
+@@ -27,11 +27,11 @@
+ # Nothing at the moment
+ LIBDIR=$(PREFIX)/lib
+ # Modules
+-MODULEDIR=$(LIBDIR)/ion3/mod
++MODULEDIR=$(LIBDIR)/ion3/mod
+ # Compiled Lua source code
+ LCDIR=$(LIBDIR)/ion3/lc
+ # ion-completefile (does not belong in SHAREDIR being a binary file)
+-EXTRABINDIR=$(LIBDIR)/ion3/bin
++EXTRABINDIR=$(LIBDIR)/ion3/bin
+ # For ion-completeman system-wide cache
+ VARDIR=/var/cache/ion3
+ # Message catalogs
+@@ -56,18 +56,18 @@
+
+ # If you have installed Lua 5.1 from the official tarball without changing
+ # paths, this should do it.
+-LUA_DIR=/usr/local
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+-LUA_INCLUDES = -I$(LUA_DIR)/include
+-LUA=$(LUA_DIR)/bin/lua
+-LUAC=$(LUA_DIR)/bin/luac
++#LUA_DIR=/usr/local
++#LUA_LIBS = -L$(LUA_DIR)/lib -llua
++#LUA_INCLUDES = -I$(LUA_DIR)/include
++#LUA=$(LUA_DIR)/bin/lua
++#LUAC=$(LUA_DIR)/bin/luac
+
+ # If you are using the Debian packages, the following settings should be
+ # what you want.
+-#LUA_LIBS=`pkg-config --libs lua5.1`
+-#LUA_INCLUDES=`pkg-config --cflags lua5.1`
+-#LUA=`which lua5.1`
+-#LUAC=`which luac5.1`
++LUA_LIBS=`pkg-config --libs lua`
++LUA_INCLUDES=`pkg-config --cflags lua`
++LUA=`which lua`
++LUAC=`which luac`
+
+
+ ##
+@@ -107,7 +107,7 @@
+ # asprintf and vasprintf in the c library. (gnu libc has.)
+ # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
+ # in sprintf_2.2/ is used.
+-#HAS_SYSTEM_ASPRINTF=1
++HAS_SYSTEM_ASPRINTF=1
+
+
+ # If you're on an archaic system (such as relatively recent *BSD releases)
+@@ -144,14 +144,14 @@
+
+ #C89_SOURCE=-ansi
+
+-#POSIX_SOURCE=-D_POSIX_SOURCE
++POSIX_SOURCE=-D_POSIX_SOURCE
+
+ # Most systems
+-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
++XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+ # SunOS, (Irix)
+ #XOPEN_SOURCE=-D__EXTENSIONS__
+
+-#C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
++C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
+
+ # The -DCF_HAS_VA_COPY option should allow for some optimisations, and
+ # in some cases simply defining
diff --git a/x11-wm/ion3/files/20070506/202_all_fix-menus.patch b/x11-wm/ion3/files/20070506/202_all_fix-menus.patch
new file mode 100644
index 000000000000..c2d77c89cfa6
--- /dev/null
+++ b/x11-wm/ion3/files/20070506/202_all_fix-menus.patch
@@ -0,0 +1,13 @@
+diff -Naur ../work/ion-3ds-20061223/etc/cfg_ioncore.lua ion-3ds-20061223/etc/cfg_ioncore.lua
+--- ../work/ion-3ds-20061223/etc/cfg_ioncore.lua 2006-12-23 17:59:43.000000000 +0300
++++ ion-3ds-20061223/etc/cfg_ioncore.lua 2006-12-31 15:35:59.000000000 +0300
+@@ -331,7 +331,8 @@
+ defmenu("mainmenu", {
+ menuentry("Run...", "mod_query.query_exec(_)"),
+ menuentry("Terminal", "ioncore.exec_on(_, XTERM or 'xterm')"),
+- menuentry("Lock screen", "ioncore.exec_on(_, 'xlock')"),
++ menuentry("Lock screen",
++ "ioncore.exec_on(_, ioncore.lookup_script('ion-lock'))"),
+ menuentry("Help", "mod_query.query_man(_)"),
+ menuentry("About Ion", "mod_query.show_about_ion(_)"),
+ submenu("Styles", "stylemenu"),
diff --git a/x11-wm/ion3/files/20070506/205_all_ion-lock.patch b/x11-wm/ion3/files/20070506/205_all_ion-lock.patch
new file mode 100644
index 000000000000..dda201612800
--- /dev/null
+++ b/x11-wm/ion3/files/20070506/205_all_ion-lock.patch
@@ -0,0 +1,22 @@
+diff -Nur ion3-20050322.orig/utils/Makefile ion3-20050322/utils/Makefile
+--- ion3-20050322.orig/utils/Makefile 2005-03-22 14:31:06.000000000 +0000
++++ ion3-20050322/utils/Makefile 2005-03-22 16:29:37.197355881 +0000
+@@ -11,7 +11,7 @@
+ SUBDIRS=ion-completefile
+ INSTALL_SUBDIRS=$(SUBDIRS)
+
+-SHELLSCRIPTS = ion-runinxterm ion-completeman
++SHELLSCRIPTS = ion-runinxterm ion-completeman ion-lock
+
+ TARGETS = ion-completeman
+
+diff -Nur ion3-20050322.orig/utils/ion-lock ion3-20050322/utils/ion-lock
+--- ion3-20050322.orig/utils/ion-lock 1970-01-01 00:00:00.000000000 +0000
++++ ion3-20050322/utils/ion-lock 2005-03-22 16:29:19.550092305 +0000
+@@ -0,0 +1,6 @@
++#!/bin/sh
++if xscreensaver-command -version >/dev/null 2>&1; then
++ exec xscreensaver-command -lock
++else
++ exec xlock
++fi
diff --git a/x11-wm/ion3/files/20070506/208_all_as-needed.patch b/x11-wm/ion3/files/20070506/208_all_as-needed.patch
new file mode 100644
index 000000000000..662a078df303
--- /dev/null
+++ b/x11-wm/ion3/files/20070506/208_all_as-needed.patch
@@ -0,0 +1,12 @@
+diff -uNr ion-3ds-20070318.orig/de/Makefile ion-3ds-20070318/de/Makefile
+--- ion-3ds-20070318.orig/de/Makefile 2007-03-18 21:31:37.000000000 +0100
++++ ion-3ds-20070318/de/Makefile 2007-04-30 17:30:23.000000000 +0200
+@@ -17,6 +17,8 @@
+
+ MAKE_EXPORTS=de
+
++LDFLAGS+=-lXext
++
+ ######################################
+
+ include $(TOPDIR)/build/rules.mk
diff --git a/x11-wm/ion3/files/digest-ion3-20070506 b/x11-wm/ion3/files/digest-ion3-20070506
new file mode 100644
index 000000000000..bfefeec9b528
--- /dev/null
+++ b/x11-wm/ion3/files/digest-ion3-20070506
@@ -0,0 +1,15 @@
+MD5 c005ebeb89894eefbb414897d874cee6 ion-3rc-20070506.tar.gz 640482
+RMD160 b5dda6a7a48c1f3d433b2a2b1c37294ece79a259 ion-3rc-20070506.tar.gz 640482
+SHA256 850dce3bd1be5d200fda5ba3e6085f397b35c720f7758dc5481bf503fe5d2f56 ion-3rc-20070506.tar.gz 640482
+MD5 45dc4b83f2badbade8389953b3c49da7 ion-doc-3rc-20070506.tar.gz 669471
+RMD160 aa9e75b60c121d3cd62f60afed4592fe1bc0da87 ion-doc-3rc-20070506.tar.gz 669471
+SHA256 9dac4f5e69121b98cf6e5da455d6185f00605cf237f14fc4f8578446f622476e ion-doc-3rc-20070506.tar.gz 669471
+MD5 c8c2d7b039f751db017275f5f977702e ion3-mod-ionflux-20070512.tar.bz2 12770
+RMD160 8e834de0c3048b676bc5c5d5454aedac09129eb3 ion3-mod-ionflux-20070512.tar.bz2 12770
+SHA256 63c4902159923aa02921e39aa7746ca8819ba1c216efa8fa6384fd093f60d18c ion3-mod-ionflux-20070512.tar.bz2 12770
+MD5 dcb17665b215d0891be40392f57197c1 ion3-mod-xrandr-20070410.tar.bz2 10833
+RMD160 8542c0dfebfd1536e6a1ad89a3b791609ca8f16e ion3-mod-xrandr-20070410.tar.bz2 10833
+SHA256 80f23a435b21f8691fc63b78394fa29b25b5304f46895dd961ac905bcc76c82f ion3-mod-xrandr-20070410.tar.bz2 10833
+MD5 33495ed87edd9c5734a1c413847a3b3d ion3-scripts-20070510.tar.bz2 100952
+RMD160 4ac0fff86a039d5890bd934d80c33bb5a78fb02d ion3-scripts-20070510.tar.bz2 100952
+SHA256 53c4705ab6f880404aae92cef3018a956ee1b55d0e22ef93c12d30527a419a61 ion3-scripts-20070510.tar.bz2 100952