summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 09:22:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 09:22:19 +0000
commit60dd71892f7e1a3721f8984ba5d56169713950ce (patch)
treee49a1bf52ecb1ea11bde968b14f4124537feef9d /x11-wm/afterstep
parentrepoman'd (diff)
downloadhistorical-60dd71892f7e1a3721f8984ba5d56169713950ce.tar.gz
historical-60dd71892f7e1a3721f8984ba5d56169713950ce.tar.bz2
historical-60dd71892f7e1a3721f8984ba5d56169713950ce.zip
modernised
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/afterstep-1.8.11-r1.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/x11-wm/afterstep/afterstep-1.8.11-r1.ebuild b/x11-wm/afterstep/afterstep-1.8.11-r1.ebuild
index 46059ae83be6..45a17e4ff6f3 100644
--- a/x11-wm/afterstep/afterstep-1.8.11-r1.ebuild
+++ b/x11-wm/afterstep/afterstep-1.8.11-r1.ebuild
@@ -20,7 +20,6 @@ RDEPEND="${DEPEND}
src_unpack() {
-
unpack ${A}
cd ${S}
patch -p0 < ${FILESDIR}/${P}-gentoo.diff
@@ -31,25 +30,22 @@ src_compile() {
local myconf
use nls && myconf="${myconf} --enable-i18n"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --libdir=/usr/lib \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --sysconfdir=/etc/X11 \
- --with-helpcommand="xterm -e man" \
- --disable-availability \
- --disable-staticlibs \
- --with-xpm \
- ${myconf} || die
+ econf \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc/X11 \
+ --with-helpcommand="xterm -e man" \
+ --disable-availability \
+ --disable-staticlibs \
+ --with-xpm \
+ ${myconf} || die
emake || die
}
src_install() {
- make DESTDIR=${D} \
- GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ make DESTDIR=${D} \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
install || die
rm -f ${D}/usr/bin/sessreg
@@ -62,5 +58,4 @@ src_install() {
exeinto /etc/X11/Sessions
doexe ${FILESDIR}/afterstep
-
}