summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-19 01:51:40 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-19 01:51:40 +0000
commitb02a7d422eef1acc8e979e1b7bdb22d098310eb1 (patch)
tree45649f413fc17a2142eed78103514a917507ceca /x11-plugins
parentPackage "app-sci/staden-emboss" was removed from Portage. (diff)
downloadhistorical-b02a7d422eef1acc8e979e1b7bdb22d098310eb1.tar.gz
historical-b02a7d422eef1acc8e979e1b7bdb22d098310eb1.tar.bz2
historical-b02a7d422eef1acc8e979e1b7bdb22d098310eb1.zip
closing bug #64556, thanks Magnade
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmtz/ChangeLog6
-rw-r--r--x11-plugins/wmtz/Manifest7
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch18
-rw-r--r--x11-plugins/wmtz/wmtz-0.7.ebuild15
4 files changed, 40 insertions, 6 deletions
diff --git a/x11-plugins/wmtz/ChangeLog b/x11-plugins/wmtz/ChangeLog
index d44fd863d3c4..79475ce54065 100644
--- a/x11-plugins/wmtz/ChangeLog
+++ b/x11-plugins/wmtz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmtz
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.8 2004/09/02 18:22:40 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.9 2004/09/19 01:51:40 morfic Exp $
+
+ 18 Sep 2004; Daniel Goller <morfic@gentoo.org> +files/wmtz-0.7-gcc34.patch,
+ wmtz-0.7.ebuild:
+ applying Magnade's gcc3.4 patch to close bug #64556
02 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> wmtz-0.7.ebuild:
Masked wmtz-0.7.ebuild stable for ppc
diff --git a/x11-plugins/wmtz/Manifest b/x11-plugins/wmtz/Manifest
index e0189478c580..a2e5b6cde14b 100644
--- a/x11-plugins/wmtz/Manifest
+++ b/x11-plugins/wmtz/Manifest
@@ -1,5 +1,6 @@
-MD5 0f8045f58251bf7d4ba05ff67f044b9f ChangeLog 997
+MD5 904e9bbf6a5a6517b421579aee9dfe9b wmtz-0.7.ebuild 929
+MD5 b7e60260d53289d4532cef958924d5d0 ChangeLog 1147
MD5 62ba71d3b2fa785a4cbd5d47fdbd0eb6 metadata.xml 165
-MD5 9c6f90461f3d1e6e958237ca0ded2c50 wmtz-0.7.ebuild 703
-MD5 6efb0655a3f8a17ecd56106d4d39ebda files/digest-wmtz-0.7 59
MD5 87d237cba796423d80d030a210401ed0 files/wmtz.c.patch 465
+MD5 6efb0655a3f8a17ecd56106d4d39ebda files/digest-wmtz-0.7 59
+MD5 f44970f0cb57d7fca808329d20d45902 files/wmtz-0.7-gcc34.patch 336
diff --git a/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch b/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch
new file mode 100644
index 000000000000..2eeb153626a0
--- /dev/null
+++ b/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch
@@ -0,0 +1,18 @@
+--- wmtz-0.7/wmtz/wmtz.c.old 2004-09-18 11:52:09.487481335 -0700
++++ wmtz-0.7/wmtz/wmtz.c 2004-09-18 11:52:45.805696921 -0700
+@@ -478,6 +478,7 @@
+ but_stat = -1;
+ break;
+ default:
++ break;
+ }
+ }
+
+@@ -528,6 +529,7 @@
+ exit(0);
+ break;
+ default:
++ break;
+ }
+ return;
+ }
diff --git a/x11-plugins/wmtz/wmtz-0.7.ebuild b/x11-plugins/wmtz/wmtz-0.7.ebuild
index 6884b888266c..1e0d7b22068a 100644
--- a/x11-plugins/wmtz/wmtz-0.7.ebuild
+++ b/x11-plugins/wmtz/wmtz-0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.9 2004/09/02 18:22:40 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.10 2004/09/19 01:51:40 morfic Exp $
-inherit eutils
+inherit eutils gcc
IUSE=""
DESCRIPTION="dockapp that shows the time in multiple timezones."
@@ -15,6 +15,17 @@ KEYWORDS="x86 amd64 ppc"
DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #apply both patches to compile with gcc-3.4 closing bug #
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
+ fi
+}
+
src_compile() {
cd ${S}/wmtz
epatch ${FILESDIR}/wmtz.c.patch