summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-12 20:47:20 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-12 20:47:20 +0000
commit4f16a23ec6f0ad49e860825306628b97e6127327 (patch)
treee8fa9ff7ebd0ca711a334d56156b0126e34d60ae /x11-plugins
parentMarked stable on amd64 (diff)
downloadhistorical-4f16a23ec6f0ad49e860825306628b97e6127327.tar.gz
historical-4f16a23ec6f0ad49e860825306628b97e6127327.tar.bz2
historical-4f16a23ec6f0ad49e860825306628b97e6127327.zip
Add patch to fix compilation with gcc-4; bug #99063
Package-Manager: portage-2.0.53
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/autoprofile/ChangeLog8
-rw-r--r--x11-plugins/autoprofile/Manifest17
-rw-r--r--x11-plugins/autoprofile/autoprofile-2.10.ebuild12
-rw-r--r--x11-plugins/autoprofile/files/autoprofile-2.10-gcc4.patch13
4 files changed, 43 insertions, 7 deletions
diff --git a/x11-plugins/autoprofile/ChangeLog b/x11-plugins/autoprofile/ChangeLog
index 0c593ac6508b..7cf820e77a48 100644
--- a/x11-plugins/autoprofile/ChangeLog
+++ b/x11-plugins/autoprofile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/autoprofile
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/ChangeLog,v 1.16 2004/10/21 15:41:33 rizzo Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/ChangeLog,v 1.17 2005/12/12 20:47:20 halcy0n Exp $
+
+ 12 Dec 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/autoprofile-2.10-gcc4.patch, autoprofile-2.10.ebuild:
+ Add patch to fix compilation with gcc-4; bug #99063
21 Oct 2004; Don Seiler <rizzo@gentoo.org> -autoprofile-2.07.ebuild,
-autoprofile-2.08.ebuild, -autoprofile-2.09.ebuild,
diff --git a/x11-plugins/autoprofile/Manifest b/x11-plugins/autoprofile/Manifest
index ee6e343b8dd2..784615332e40 100644
--- a/x11-plugins/autoprofile/Manifest
+++ b/x11-plugins/autoprofile/Manifest
@@ -1,4 +1,15 @@
-MD5 786175ea2cf0504e823130f8a5ea1d7c ChangeLog 2380
-MD5 a574ec2607edf5e80117d65415e01d3c metadata.xml 159
-MD5 de5a11ebca6897a0689cbd6a0ca04e1d autoprofile-2.10.ebuild 706
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 003409082bed0466ea65b3f8e59dd4be ChangeLog 2548
+MD5 875ed65003f782006c1c12331b8cc5cd autoprofile-2.10.ebuild 802
+MD5 b8d50badedaf287c6641087f9d026999 files/autoprofile-2.10-gcc4.patch 579
MD5 9f9da3e76cfe1523d4a7af98bf241abd files/digest-autoprofile-2.10 67
+MD5 a574ec2607edf5e80117d65415e01d3c metadata.xml 159
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDneHlCRZPokWLroQRAliqAJ4hqLcapgv7MYmOVJy6j9DEsAifegCdHiOB
+l93xc+vY57a4XpM0Np6PfpE=
+=iFZi
+-----END PGP SIGNATURE-----
diff --git a/x11-plugins/autoprofile/autoprofile-2.10.ebuild b/x11-plugins/autoprofile/autoprofile-2.10.ebuild
index 157d537b578d..9e1a5e07e1dd 100644
--- a/x11-plugins/autoprofile/autoprofile-2.10.ebuild
+++ b/x11-plugins/autoprofile/autoprofile-2.10.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/autoprofile-2.10.ebuild,v 1.2 2004/10/21 15:41:33 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/autoprofile-2.10.ebuild,v 1.3 2005/12/12 20:47:20 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="AutoProfile is a fully-featured profile manager for the popular instant messenger client Gaim."
HOMEPAGE="http://hkn.eecs.berkeley.edu/~casey/autoprofile/"
@@ -11,6 +13,12 @@ KEYWORDS="x86 ppc"
IUSE=""
DEPEND=">=net-im/gaim-1.0.0"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile() {
emake || die
}
diff --git a/x11-plugins/autoprofile/files/autoprofile-2.10-gcc4.patch b/x11-plugins/autoprofile/files/autoprofile-2.10-gcc4.patch
new file mode 100644
index 000000000000..833769df4267
--- /dev/null
+++ b/x11-plugins/autoprofile/files/autoprofile-2.10-gcc4.patch
@@ -0,0 +1,13 @@
+diff -ur autoprofile-2.10-orig/src/gtk_away_msgs.c autoprofile-2.10/src/gtk_away_msgs.c
+--- autoprofile-2.10-orig/src/gtk_away_msgs.c 2005-12-09 04:07:33.000000000 -0500
++++ autoprofile-2.10/src/gtk_away_msgs.c 2005-12-09 04:12:33.000000000 -0500
+@@ -61,6 +61,9 @@
+
+ /* Queue variables */
+ static GtkWidget *awayqueuebox = NULL;
++#define awayqueue local_awayqueue
++#define awayqueuesw local_awayqueuesw
++#define awayqueuestore local_awayqueuestore
+ static GtkWidget *awayqueue = NULL;
+ static GtkWidget *awayqueuesw = NULL;
+ static GtkListStore *awayqueuestore = NULL;