summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-01-31 21:24:02 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-01-31 21:24:02 +0000
commit07fd1d8ecd9a917313e53982a9ed2d24a23be199 (patch)
tree02c0e3b1eba605be75cf41cc480a4cb67955b3e1 /x11-plugins/wmtz/wmtz-0.7.ebuild
parentMark 1.89 stable on alpha (diff)
downloadhistorical-07fd1d8ecd9a917313e53982a9ed2d24a23be199.tar.gz
historical-07fd1d8ecd9a917313e53982a9ed2d24a23be199.tar.bz2
historical-07fd1d8ecd9a917313e53982a9ed2d24a23be199.zip
Fixed DEPEND for modular X.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'x11-plugins/wmtz/wmtz-0.7.ebuild')
-rw-r--r--x11-plugins/wmtz/wmtz-0.7.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/x11-plugins/wmtz/wmtz-0.7.ebuild b/x11-plugins/wmtz/wmtz-0.7.ebuild
index 8441cae4339e..e6f7cff8dbd4 100644
--- a/x11-plugins/wmtz/wmtz-0.7.ebuild
+++ b/x11-plugins/wmtz/wmtz-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.14 2005/11/13 07:18:42 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.15 2006/01/31 21:01:53 nelchael Exp $
inherit eutils toolchain-funcs
@@ -13,14 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ppc ~sparc"
-DEPEND="virtual/x11"
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
src_unpack() {
unpack ${A}
cd ${S}
#apply both patches to compile with gcc-3.4 closing bug #64556
- epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
+ epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
}
src_compile() {