summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-30 15:52:58 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-30 15:52:58 +0000
commit283d255d0ad8250e7847e28b40e1535ce55e4fcb (patch)
tree9e6c924d40a168f32d5b95c25901a7a22fc32efa /x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild
parentfix libimobiledevice dependency, it's also a RDEPEND (diff)
downloadhistorical-283d255d0ad8250e7847e28b40e1535ce55e4fcb.tar.gz
historical-283d255d0ad8250e7847e28b40e1535ce55e4fcb.tar.bz2
historical-283d255d0ad8250e7847e28b40e1535ce55e4fcb.zip
Respect LDFLAGS, see bug #335047
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild')
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild
index e0326042196a..71c857b621e7 100644
--- a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild,v 1.12 2010/07/22 14:33:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon+smp/wmmon+smp-1.0-r1.ebuild,v 1.13 2010/08/30 15:52:58 s4t4n Exp $
IUSE=""
@@ -20,6 +20,15 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xextproto"
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # Respect LDFLAGS, see bug #335047
+ sed -i 's/cc -o/${CC} ${LDFLAGS} -o/' "${S2}/Makefile"
+}
+
src_compile() {
cd "${S2}"
emake || die