summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-13 11:42:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-13 11:42:21 +0000
commit6bd18397f323de115e216ea3071d41e7c1fed120 (patch)
treed7bd2e997a9225312051301cdf7aba96bba9b2db /x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
parentStable on x86 wrt #205517 (diff)
downloadhistorical-6bd18397f323de115e216ea3071d41e7c1fed120.tar.gz
historical-6bd18397f323de115e216ea3071d41e7c1fed120.tar.bz2
historical-6bd18397f323de115e216ea3071d41e7c1fed120.zip
Version bump to GTK+-2.0 version and mark it stable for amd64 because current stable is broken wrt #204550
Package-Manager: portage-2.1.4 RepoMan-Options: --force
Diffstat (limited to 'x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild')
-rw-r--r--x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild b/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
new file mode 100644
index 000000000000..4801ec57c378
--- /dev/null
+++ b/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild,v 1.1 2008/01/13 11:42:20 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="a nice digital clock with 7 different styles either in LCD or LED style."
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/sample*
+ newdoc debian/changelog ChangeLog.debian
+}