summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-03 09:12:56 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-03 09:12:56 +0000
commitc8e44db4b15570fcb156d940505d9c55168a9ca1 (patch)
tree772d32566c8210f6ec33a137e558d077f4ec7576 /x11-plugins/wmclock/wmclock-1.0.13.ebuild
parentRemove old. (diff)
downloadhistorical-c8e44db4b15570fcb156d940505d9c55168a9ca1.tar.gz
historical-c8e44db4b15570fcb156d940505d9c55168a9ca1.tar.bz2
historical-c8e44db4b15570fcb156d940505d9c55168a9ca1.zip
Do not call gcc directly, reported by k01 in bug #401955
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/wmclock/wmclock-1.0.13.ebuild')
-rw-r--r--x11-plugins/wmclock/wmclock-1.0.13.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-plugins/wmclock/wmclock-1.0.13.ebuild b/x11-plugins/wmclock/wmclock-1.0.13.ebuild
index eb78f7e4b0e5..f66c9a49a111 100644
--- a/x11-plugins/wmclock/wmclock-1.0.13.ebuild
+++ b/x11-plugins/wmclock/wmclock-1.0.13.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclock/wmclock-1.0.13.ebuild,v 1.2 2012/02/02 17:45:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclock/wmclock-1.0.13.ebuild,v 1.3 2012/02/03 09:12:56 voyageur Exp $
EAPI=3
+inherit toolchain-funcs
+
DESCRIPTION="a dockapp that displays time and date (same style as NEXTSTEP(tm) operating systems)"
SRC_URI="http://www.bluestop.org/wmclock/${P}.tar.gz"
HOMEPAGE="http://www.bluestop.org/wmclock/"
@@ -23,7 +25,7 @@ DEPEND="${RDEPEND}
x11-misc/imake"
src_compile() {
- emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "make failed"
+ emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "make failed"
}
src_install() {