summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-01-07 04:46:10 +0000
committerOlivier Crête <tester@gentoo.org>2008-01-07 04:46:10 +0000
commite3af1a937969fff34cb5454e1303f6a555d880c9 (patch)
tree91b6b3d5dfbb06c35406f9aa74ea762698cbc3d1 /x11-plugins/pidgin-otr
parentAdd DEPEND on pkgconfig (diff)
downloadhistorical-e3af1a937969fff34cb5454e1303f6a555d880c9.tar.gz
historical-e3af1a937969fff34cb5454e1303f6a555d880c9.tar.bz2
historical-e3af1a937969fff34cb5454e1303f6a555d880c9.zip
Add build-time dep on pkgconfig
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'x11-plugins/pidgin-otr')
-rw-r--r--x11-plugins/pidgin-otr/ChangeLog6
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild7
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild7
3 files changed, 15 insertions, 5 deletions
diff --git a/x11-plugins/pidgin-otr/ChangeLog b/x11-plugins/pidgin-otr/ChangeLog
index 082b9439dffd..dff3a6c00b75 100644
--- a/x11-plugins/pidgin-otr/ChangeLog
+++ b/x11-plugins/pidgin-otr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-otr
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.8 2008/01/07 04:27:26 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.9 2008/01/07 04:46:10 tester Exp $
+
+ 07 Jan 2008; <tester@gentoo.org> pidgin-otr-3.0.0.ebuild,
+ pidgin-otr-3.1.0.ebuild:
+ Add build-time dep on pkgconfig
07 Jan 2008; <tester@gentoo.org> pidgin-otr-3.0.0.ebuild,
pidgin-otr-3.1.0.ebuild:
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
index a1e748dd8059..013a091be15a 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild,v 1.8 2008/01/07 04:32:33 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild,v 1.9 2008/01/07 04:46:10 tester Exp $
inherit flag-o-matic eutils autotools
@@ -16,10 +16,13 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-DEPEND=">=net-libs/libotr-3.0.0
+RDEPEND=">=net-libs/libotr-3.0.0
>=x11-libs/gtk+-2
net-im/pidgin"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
S="${WORKDIR}"/${MY_P}
pkg_setup() {
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
index 3e963887ab9a..82d3b964c61f 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild,v 1.3 2008/01/07 04:32:33 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild,v 1.4 2008/01/07 04:46:10 tester Exp $
inherit flag-o-matic eutils autotools
@@ -13,10 +13,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
-DEPEND=">=net-libs/libotr-3.1.0
+RDEPEND=">=net-libs/libotr-3.1.0
>=x11-libs/gtk+-2
net-im/pidgin"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
pkg_setup() {
if ! built_with_use net-im/pidgin gtk; then
eerror "You need to compile net-im/pidgin with USE=gtk"