summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-01-24 16:48:28 +0000
committerJim Ramsay <lack@gentoo.org>2011-01-24 16:48:28 +0000
commit297033a9c29d93f7d3321fc75e07cd6499c9d95b (patch)
tree19cd4472b21afa1ef7f35df6b64105d4ff30fa5d /x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
parentPin to webkit slot 2. (diff)
downloadhistorical-297033a9c29d93f7d3321fc75e07cd6499c9d95b.tar.gz
historical-297033a9c29d93f7d3321fc75e07cd6499c9d95b.tar.bz2
historical-297033a9c29d93f7d3321fc75e07cd6499c9d95b.zip
Applied user patch to fix CFLAGS and LDFLAGS (Bug #333989)
Package-Manager: portage-2.1.9.34/cvs/Linux i686
Diffstat (limited to 'x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild')
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..cef9fef9cb02
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild,v 1.1 2011/01/24 16:48:28 lack Exp $
+
+EAPI=2
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="=app-admin/gkrellm-2*[X=]"
+DEPEND="${RDEPEND}
+ =dev-libs/glib-2*
+ X? ( =x11-libs/gtk+-2* )"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
+ -e 's/-shared/$(LDFLAGS) &/' \
+ Makefile || die
+}
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}