summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-02 07:44:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-02 07:44:00 +0000
commite30cf75784db6c0b696ed56c47cab53f1772c74b (patch)
tree1b4d966d7cd9ffeb4bb52a5dc4fb1d8572ce0c72 /x11-plugins/gkrellsun
parentversion bump (diff)
downloadhistorical-e30cf75784db6c0b696ed56c47cab53f1772c74b.tar.gz
historical-e30cf75784db6c0b696ed56c47cab53f1772c74b.tar.bz2
historical-e30cf75784db6c0b696ed56c47cab53f1772c74b.zip
version bump
Diffstat (limited to 'x11-plugins/gkrellsun')
-rw-r--r--x11-plugins/gkrellsun/ChangeLog10
-rw-r--r--x11-plugins/gkrellsun/files/digest-gkrellsun-0.9.11
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/x11-plugins/gkrellsun/ChangeLog b/x11-plugins/gkrellsun/ChangeLog
index b3c766407199..067d6df31be6 100644
--- a/x11-plugins/gkrellsun/ChangeLog
+++ b/x11-plugins/gkrellsun/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/gkrellsun
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.3 2002/11/10 04:52:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.4 2002/12/02 07:44:00 seemant Exp $
+
+*gkrellsun-0.9.1 (01 Dec 2002)
+
+ 01 Dec 2002; Seemant Kulleen <seemant@gentoo.org> gkrellsun-0.9.1.ebuild
+ files/digest-gkrellsun-0.9.1 :
+
+ Version bump, which now works with gkrellmoon-0.5 for gkrellm2. Thanks
+ to: ejwahl@cox.net (Erich Wahl) in bug #10837.
*gkrellsun-0.9 (09 Nov 2002)
diff --git a/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9.1 b/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9.1
new file mode 100644
index 000000000000..00bd7c30422c
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9.1
@@ -0,0 +1 @@
+MD5 641dae36dba2689a1aad6d891833bb68 gkrellsun-0.9.1.tar.gz 68505
diff --git a/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild b/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild
new file mode 100644
index 000000000000..40893f2aeffe
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-0.9.1.ebuild,v 1.1 2002/12/02 07:44:00 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="app-admin/gkrellm
+ >=media-libs/imlib-1.9.10-r1"
+
+src_compile() {
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ cd ${S}/src
+ emake || die
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ cd ${S}/src20
+ emake || die
+ fi
+
+}
+
+src_install () {
+
+ dodoc README AUTHORS COPYING
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ cd ${S}/src
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellsun.so
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ cd ${S}/src20
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellsun.so
+ fi
+}