summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2006-10-24 00:05:05 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2006-10-24 00:05:05 +0000
commit7c568d723d08d7f5c776eed88e34a26a04c5e228 (patch)
treed057dce58ae72e60b99ed041dd906fda261cc5ca /x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild
parentStable on x86, bug #152333. (diff)
downloadhistorical-7c568d723d08d7f5c776eed88e34a26a04c5e228.tar.gz
historical-7c568d723d08d7f5c776eed88e34a26a04c5e228.tar.bz2
historical-7c568d723d08d7f5c776eed88e34a26a04c5e228.zip
update to work with beta4 gaim, rolled from cvs
Package-Manager: portage-2.1.2_pre3-r6
Diffstat (limited to 'x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild')
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild
new file mode 100644
index 000000000000..2ba69367509a
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta6.ebuild,v 1.1 2006/10/24 00:05:05 gothgirl Exp $
+
+inherit flag-o-matic debug eutils
+
+MY_PV="${PV/_beta/beta}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://gentoo/${PN}/${MY_P}.tar.gz
+ http://dev.gentoo.org/~gothgirl/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nss-3.11"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+ econf \
+ $(use_enable nls) || die "failed running configure"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}