summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:01:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 08:01:56 +0000
commitd0ee3d6ec66313ac2c3418a981809960f0d9b139 (patch)
treee4b953a21effa4f6a2a085fae407588c39651aa6 /x11-misc
parentenhanced description (diff)
downloadhistorical-d0ee3d6ec66313ac2c3418a981809960f0d9b139.tar.gz
historical-d0ee3d6ec66313ac2c3418a981809960f0d9b139.tar.bz2
historical-d0ee3d6ec66313ac2c3418a981809960f0d9b139.zip
re-added wmakerconf to here
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wmakerconf/ChangeLog25
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r21
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.91
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild53
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.9.ebuild52
5 files changed, 132 insertions, 0 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
new file mode 100644
index 000000000000..e5c208a1a1d6
--- /dev/null
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for x11-misc/wmakerconf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.5 2002/08/30 08:01:56 seemant Exp $
+
+*wmakerconf-2.9 (16 Jul 2002)
+
+ 16 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ wmakerconf-2.9.ebuild, files/digest-wmakerconf-2.9 :
+
+ Updated to latest version. We don't have libwmfun support yet.
+
+*wmakerconf-2.8.1-r2 (19 Jun 2002)
+
+ 19 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
+ wmakerconf-2.8.1-r2.ebuild files/digest-wmakerconf-2.8.1-r2 :
+
+ Fixed bug #3909 by info@cs-ol.de (Udo Mu"ller) to make the Gnome1 DEPEND
+ listing a little cleaner.
+
+*wmakerconf-2.8.1-r1
+
+ 1 Apr 2002; Seemant Kulleen <seemant@gentoo.org> wmakerconf-2.8.1-r1.ebuild :
+
+ Fixed sandbox violations and corrected the dependencies and USE dependent
+ compilations.
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2
new file mode 100644
index 000000000000..f3b723c38256
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2
@@ -0,0 +1 @@
+MD5 03749f08953638ed2a0ab260a407d264 wmakerconf-2.8.1.tar.gz 666175
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.9 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.9
new file mode 100644
index 000000000000..f5f56ab84608
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.9
@@ -0,0 +1 @@
+MD5 da02991fc9e8e09c99c1d159f45afe1e wmakerconf-2.9.tar.bz2 499800
diff --git a/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild b/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild
new file mode 100644
index 000000000000..6c56226627b3
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild,v 1.8 2002/08/30 08:01:56 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://wmaker.orcon.net.nz/current/${P}.tar.gz"
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ x11-wm/WindowMaker
+ x11-libs/libPropList
+ gnome? ( =gnome-base/gnome-libs-1.4* )
+ imlib? ( media-libs/imlib )"
+
+
+RDEPEND="nls? ( sys-devel/gettext )
+ perl? ( sys-devel/perl
+ net-misc/wget )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use imlib || myconf="${myconf} --disable-imlibtest"
+
+ use gnome || myconf="${myconf} --without-gnome"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-wmakerdataprefix=/usr/share \
+ --sysconfdir=/etc \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ GNOMEDIR=${D}/usr/share/gnome/apps/Settings \
+ install || die
+
+ dodoc README MANUAL AUTHORS TODO COPYING ChangeLog
+ dohtml -r .
+}
diff --git a/x11-misc/wmakerconf/wmakerconf-2.9.ebuild b/x11-misc/wmakerconf/wmakerconf-2.9.ebuild
new file mode 100644
index 000000000000..582188691cc1
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.9.ebuild,v 1.5 2002/08/30 08:01:56 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://www.windowmaker.org/pub/contrib/source/wmakerconf/${P}.tar.bz2"
+# Homepage appears not to be up anymore
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ x11-wm/WindowMaker
+ gnome? ( =gnome-base/gnome-libs-1.4* )
+ imlib? ( media-libs/imlib )"
+
+
+RDEPEND="nls? ( sys-devel/gettext )
+ perl? ( sys-devel/perl
+ net-misc/wget )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use imlib || myconf="${myconf} --disable-imlibtest"
+
+ use gnome || myconf="${myconf} --without-gnome"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --sysconfdir=/etc \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ GNOMEDIR=${D}/usr/share/gnome/apps/Settings \
+ install || die
+
+ dodoc README MANUAL AUTHORS TODO COPYING ChangeLog
+ dohtml -r .
+}