summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-31 00:18:42 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-31 00:18:42 +0000
commit8fcd3437670122a2ad255ed77a3aa44be77b9a01 (patch)
treed78b5e84e88113f07b8f8ae0468b3cc000fc8aca /x11-misc
parent*** empty log message *** (diff)
downloadhistorical-8fcd3437670122a2ad255ed77a3aa44be77b9a01.tar.gz
historical-8fcd3437670122a2ad255ed77a3aa44be77b9a01.tar.bz2
historical-8fcd3437670122a2ad255ed77a3aa44be77b9a01.zip
*** empty log message ***
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbrun/bbrun-1.1-r1.ebuild35
-rw-r--r--x11-misc/bbrun/files/digest-bbrun-1.1-r11
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/bbrun/bbrun-1.1-r1.ebuild b/x11-misc/bbrun/bbrun-1.1-r1.ebuild
new file mode 100644
index 000000000000..61542e2afd5a
--- /dev/null
+++ b/x11-misc/bbrun/bbrun-1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbrun/bbrun-1.1-r1.ebuild,v 1.1 2001/08/31 00:18:42 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox program execution dialog box"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/contrib/${P}.tar.gz"
+HOMEPAGE="http://bbtools.thelinuxcommunity.org/contrib.phtml"
+
+DEPEND=">=x11-wm/blackbox-0.61
+ >=x11-libs/gtk+-1.2.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/bbrun
+ mv Makefile Makefile.orig
+ try sed '/CFLAGS =/ s:$: -I/usr/X11R6/include/gtk-1.2 -I/usr/include/glib-1.2 '"${CFLAGS}"':' Makefile.orig > Makefile
+}
+
+src_compile() {
+ cd ${S}/bbrun
+ emake || die
+}
+
+src_install () {
+ into /usr/X11R6
+ dobin bbrun/bbrun
+ dodoc README COPYING
+}
+
+pkg_postinst() {
+ cd ${ROOT}usr/X11R6/bin/wm
+ sed -e "s/.*blackbox/exec \/usr\/X11R6\/bin\/bbrun \&\n&/" blackbox | cat > blackbox
+}
diff --git a/x11-misc/bbrun/files/digest-bbrun-1.1-r1 b/x11-misc/bbrun/files/digest-bbrun-1.1-r1
new file mode 100644
index 000000000000..318980890c4f
--- /dev/null
+++ b/x11-misc/bbrun/files/digest-bbrun-1.1-r1
@@ -0,0 +1 @@
+MD5 19264424d472d4de7336429ce507b206 bbrun-1.1.tar.gz