summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-08-20 15:53:01 +0000
committerDaniel Goller <morfic@gentoo.org>2004-08-20 15:53:01 +0000
commit8128f07eec8a575f7c66b2a9e28ce040e75da090 (patch)
treeb04dbb9237ac08c5cba6272ecf5e45578aa56ab1 /x11-misc
parentAdded x11-libs/qt:immqt and x11-libs/qt:immqt-bc. (diff)
downloadhistorical-8128f07eec8a575f7c66b2a9e28ce040e75da090.tar.gz
historical-8128f07eec8a575f7c66b2a9e28ce040e75da090.tar.bz2
historical-8128f07eec8a575f7c66b2a9e28ce040e75da090.zip
New Version
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/icewmcp/ChangeLog7
-rw-r--r--x11-misc/icewmcp/Manifest4
-rw-r--r--x11-misc/icewmcp/files/digest-icewmcp-3.21
-rw-r--r--x11-misc/icewmcp/icewmcp-3.2.ebuild54
4 files changed, 64 insertions, 2 deletions
diff --git a/x11-misc/icewmcp/ChangeLog b/x11-misc/icewmcp/ChangeLog
index b71367c7a579..78b4c71b1cee 100644
--- a/x11-misc/icewmcp/ChangeLog
+++ b/x11-misc/icewmcp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/icewmcp
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/ChangeLog,v 1.4 2004/06/24 22:24:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/ChangeLog,v 1.5 2004/08/20 15:53:01 morfic Exp $
+
+*icewmcp-3.2 (20 Aug 2004)
+
+ 20 Aug 2004; Daniel Goller <morfic@gentoo.org> +icewmcp-3.2.ebuild:
+ Bumped to 3.2 closing bug #60496
01 Jun 2004; Brandon Hale <tseng@gentoo.org> icewmcp-3.1.ebuild:
Stable on x86
diff --git a/x11-misc/icewmcp/Manifest b/x11-misc/icewmcp/Manifest
index 20ee44b0abf7..e154c5ef6abe 100644
--- a/x11-misc/icewmcp/Manifest
+++ b/x11-misc/icewmcp/Manifest
@@ -1,4 +1,6 @@
MD5 b2efc43bd9822bae37440bca38688b35 icewmcp-3.1.ebuild 2408
-MD5 0118297272b3e7e6d92dfe3f72292d52 ChangeLog 527
+MD5 b8447c43a802744ef61b85b57ea75438 ChangeLog 659
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
+MD5 0117269895e742f28982ce51acd133e7 icewmcp-3.2.ebuild 2407
MD5 2180d0e3edcb1dd9b00cb79e2f1d951d files/digest-icewmcp-3.1 74
+MD5 c7292bd9381f8b320cefa8dcf243278b files/digest-icewmcp-3.2 74
diff --git a/x11-misc/icewmcp/files/digest-icewmcp-3.2 b/x11-misc/icewmcp/files/digest-icewmcp-3.2
new file mode 100644
index 000000000000..348d7349f434
--- /dev/null
+++ b/x11-misc/icewmcp/files/digest-icewmcp-3.2
@@ -0,0 +1 @@
+MD5 4607568ae45634f2b561a254ce4c7ea7 IceWMControlPanel-3.2.tar.bz2 586044
diff --git a/x11-misc/icewmcp/icewmcp-3.2.ebuild b/x11-misc/icewmcp/icewmcp-3.2.ebuild
new file mode 100644
index 000000000000..4130b978aecc
--- /dev/null
+++ b/x11-misc/icewmcp/icewmcp-3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/icewmcp/icewmcp-3.2.ebuild,v 1.1 2004/08/20 15:53:01 morfic Exp $
+
+S=${WORKDIR}/INSTALL-IceWMCP
+MY_PN=IceWMControlPanel
+MY_DEST=usr/lib/${P}
+MY_BIN=usr/bin
+
+DESCRIPTION="A complete control panel for IceWM using gtk & python"
+HOMEPAGE="http://icesoundmanager.sourceforge.net/index.php"
+SRC_URI="mirror://sourceforge/icesoundmanager/${MY_PN}-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="x11-wm/icewm
+ >=dev-python/pygtk-1.99
+ >=x11-libs/gtk+-2.0.0
+ >=dev-lang/python-2.2"
+
+src_install() {
+ dodir ${MY_DEST}/
+ dodir ${MY_BIN}/
+ dodoc ${S}/doc/* ${S}/licenses/*
+ cp ${S}/* ${D}/${MY_DEST}
+ cp -R ${S}/applets ${S}/applet-icons ${S}/help ${S}/icons ${S}/locale ${S}/pixmaps ${D}/${MY_DEST}/
+ # create executable shortcuts to the python scripts
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP.py" > ${T}/IceWMCP
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPKeyboard.py" > ${T}/IceWMCP-Keyboard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPMouse.py" > ${T}/IceWMCP-Mouse
+ echo -e "#!/bin/bash \n python /${MY_DEST}/pyspool.py" > ${T}/IceWMCP-PySpool
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWallpaper.py" > ${T}/IceWMCP-Wallpaper
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPWinOptions.py" > ${T}/IceWMCP-WinOptions
+ echo -e "#!/bin/bash \n python /${MY_DEST}/phrozenclock.py" > ${T}/PhrozenClock
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icesound.py" > ${T}/IceSoundManager
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCP_GtkPCCard.py" > ${T}/GtkPCCard
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceMe.py" > ${T}/iceme
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref.py" > ${T}/icepref
+ echo -e "#!/bin/bash \n python /${MY_DEST}/icepref_td.py" > ${T}/icepref_td
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPGtkIconSelection.py" > ${T}/IceWMCP-Icons
+ echo -e "#!/bin/bash \n python /${MY_DEST}/IceWMCPEnergyStar.py" > ${T}/IceWMCP-EnergyStar
+ dobin ${T}/*
+}
+
+pkg_postinst() {
+ einfo "Some of the icons displayed by IceWMCP may be pointing to"
+ einfo "programs which are not on your system! You can hide them"
+ einfo "using the Configuration window (Ctrl+C) or change them"
+ einfo "by editing the files in"
+ einfo "/${MY_DEST}/applets and"
+ einfo "/${MY_DEST}/applet-icons."
+}