summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-08-23 15:42:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-08-23 15:42:17 +0000
commit3f0584a347067a6c281713fd17aac532a21296d2 (patch)
treea79f1cfb7cd65c8ca3790137bc3fed1cae926a0c /x11-misc
parentupgraded dictionaries for newest stable aspell (diff)
downloadhistorical-3f0584a347067a6c281713fd17aac532a21296d2.tar.gz
historical-3f0584a347067a6c281713fd17aac532a21296d2.tar.bz2
historical-3f0584a347067a6c281713fd17aac532a21296d2.zip
fixed gcc3.2 include re-ordering bug
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xplanet/ChangeLog9
-rw-r--r--x11-misc/xplanet/files/digest-xplanet-0.94-r11
-rw-r--r--x11-misc/xplanet/xplanet-0.94-r1.ebuild74
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-misc/xplanet/ChangeLog b/x11-misc/xplanet/ChangeLog
index 8af07f894a35..c1d884d3bc4b 100644
--- a/x11-misc/xplanet/ChangeLog
+++ b/x11-misc/xplanet/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for x11-misc/xplanet
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.3 2002/07/16 02:57:50 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/ChangeLog,v 1.4 2002/08/23 15:42:17 mkennedy Exp $
+*xplanet-0.94-r1 (23 Aug 2002)
+
+ 23 Aug 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ xplanet-0.94-r1.ebuild, files/digest-xplanet-0.94-r1 :
+
+ Fixed GCC3.2 include re-ordering bug.
+
*xplanet-0.94 (27 May 2002)
15 Jul 2002; Mark Guertin <gerk@gentoo.org>
diff --git a/x11-misc/xplanet/files/digest-xplanet-0.94-r1 b/x11-misc/xplanet/files/digest-xplanet-0.94-r1
new file mode 100644
index 000000000000..ea3842cde3a5
--- /dev/null
+++ b/x11-misc/xplanet/files/digest-xplanet-0.94-r1
@@ -0,0 +1 @@
+MD5 10faa5934cc24f3d913ea100b1df915d xplanet-0.94.tar.gz 1192336
diff --git a/x11-misc/xplanet/xplanet-0.94-r1.ebuild b/x11-misc/xplanet/xplanet-0.94-r1.ebuild
new file mode 100644
index 000000000000..4d6b37c56b66
--- /dev/null
+++ b/x11-misc/xplanet/xplanet-0.94-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xplanet/xplanet-0.94-r1.ebuild,v 1.1 2002/08/23 15:42:17 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A program to render images of the earth into the X root window"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://xplanet.sourceforge.net/"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl
+ media-libs/glut )
+ gif? ( media-libs/giflib
+ media-libs/libungif )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ truetype? ( =media-libs/freetype-2* )"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_unpack() {
+ unpack ${A}
+ # fix GCC3.2 include re-ordering bug.
+ D=${S}/ dosed 's,-I$prefix/include,,' configure
+}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="$myconf --with-x" \
+ || myconf="$myconf --with-x=no"
+
+ use opengl \
+ && myconf="--with-gl --with-glut --with-animation" \
+ || myconf="--with-gl=no --with-glut=no --with-animation=no"
+
+ use gif \
+ && myconf="$myconf --with-gif" \
+ || myconf="$myconf --with-gif=no"
+
+ use jpeg \
+ && myconf="${myconf} --with-jpeg" \
+ || myconf="${myconf} --with-jpeg=no"
+
+ use tiff \
+ && myconf="${myconf} --with-tiff" \
+ || myconf="${myconf} --with-tiff=no"
+
+ use png \
+ && myconf="${myconf} --with-png --with-pnm" \
+ || myconf="${myconf} --with-png=no --with-pnm=no"
+
+# Compilation fails with freetype enabled, checking upstream
+# use truetype \
+# && myconf="${myconf} --with-freetype" \
+# || myconf="${myconf} --with-freetype=no"
+ myconf="${myconf} --with-freetype=no"
+
+ econf ${myconf} || die
+
+ # xplanet doesn't like to build parallel
+ make || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc README COPYING CREDITS FAQ INSTALL
+}