summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-04-22 22:06:56 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-04-22 22:06:56 +0000
commitee805cc570627c8be64bacd5bc1f47a944ec4f9a (patch)
tree75fa6e3758d2316470ec729b49fa9455e931062c /x11-misc/xsnap
parentAdded to ~ppc (diff)
downloadhistorical-ee805cc570627c8be64bacd5bc1f47a944ec4f9a.tar.gz
historical-ee805cc570627c8be64bacd5bc1f47a944ec4f9a.tar.bz2
historical-ee805cc570627c8be64bacd5bc1f47a944ec4f9a.zip
~amd64, BUG #48707
Diffstat (limited to 'x11-misc/xsnap')
-rw-r--r--x11-misc/xsnap/ChangeLog6
-rw-r--r--x11-misc/xsnap/Manifest5
-rw-r--r--x11-misc/xsnap/files/xsnap-1.3-gentoo.patch19
-rw-r--r--x11-misc/xsnap/xsnap-1.3.ebuild10
4 files changed, 35 insertions, 5 deletions
diff --git a/x11-misc/xsnap/ChangeLog b/x11-misc/xsnap/ChangeLog
index d822c7eabbdf..98e516597727 100644
--- a/x11-misc/xsnap/ChangeLog
+++ b/x11-misc/xsnap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xsnap
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/ChangeLog,v 1.4 2004/04/11 17:47:08 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/ChangeLog,v 1.5 2004/04/22 22:06:56 kugelfang Exp $
+
+ 23 Apr 2004; Danny van Dyk <kugelfang@gentoo.org>
+ +files/xsnap-1.3-gentoo.patch, xsnap-1.3.ebuild:
+ Added minor patch on amd64 only. Fixes BUG #48707
11 Apr 2004; Markus Nigbur <pyrania@gentoo.org> xsnap-1.3.ebuild:
Ebuild fixups.
diff --git a/x11-misc/xsnap/Manifest b/x11-misc/xsnap/Manifest
index c185b8297fff..06c01e4aed05 100644
--- a/x11-misc/xsnap/Manifest
+++ b/x11-misc/xsnap/Manifest
@@ -1,4 +1,5 @@
-MD5 9494ac55d0a2e1f4a204c255b0fc800b xsnap-1.3.ebuild 647
-MD5 af98e31c085f48eaf86bdc9aeee55dc6 ChangeLog 1116
+MD5 aaf68aa66c6ca5680f20d4db13677e59 ChangeLog 1274
MD5 6b2f8ecd3ad0e55432fa394deb816e86 metadata.xml 174
+MD5 4ceaae518afe897c1f7d8f3f86afeee8 xsnap-1.3.ebuild 753
MD5 8935756ffcda63188f1df02d678f8cb5 files/digest-xsnap-1.3 57
+MD5 bbc0ee7ce1ca06fc97a84d9769713c98 files/xsnap-1.3-gentoo.patch 406
diff --git a/x11-misc/xsnap/files/xsnap-1.3-gentoo.patch b/x11-misc/xsnap/files/xsnap-1.3-gentoo.patch
new file mode 100644
index 000000000000..8991e4df255a
--- /dev/null
+++ b/x11-misc/xsnap/files/xsnap-1.3-gentoo.patch
@@ -0,0 +1,19 @@
+--- xsnap-1.3/xsnap.c.orig 2004-04-23 00:00:48.323212832 +0200
++++ xsnap-1.3/xsnap.c 2004-04-23 00:01:15.564071592 +0200
+@@ -17,6 +17,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
+ #include <X11/Xlib.h>
+@@ -693,7 +694,7 @@
+ int i, notfound;
+ struct stat buf;
+
+- if (*filename = '?')
++ if (*filename == '?')
+ {
+ i=0;
+ notfound=0;
diff --git a/x11-misc/xsnap/xsnap-1.3.ebuild b/x11-misc/xsnap/xsnap-1.3.ebuild
index f8798cefab7d..9fc9dd432fd1 100644
--- a/x11-misc/xsnap/xsnap-1.3.ebuild
+++ b/x11-misc/xsnap/xsnap-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.3.ebuild,v 1.3 2004/04/11 17:47:08 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.3.ebuild,v 1.4 2004/04/22 22:06:56 kugelfang Exp $
DESCRIPTION="Program to interactively take a 'snapshot' of a region of
the screen"
@@ -9,10 +9,16 @@ HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="x86 ppc ~sparc"
+KEYWORDS="x86 ppc ~sparc ~amd64"
DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ use amd64 && epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
src_compile() {
xmkmf || die
make || die