summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-02-28 20:05:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-02-28 20:05:39 +0000
commit65d000c6fd66a39275acf6fb2d6f2d352364aff5 (patch)
treec7efa0bef84ac3a733711761919882afd3170523 /x11-misc/xsel/xsel-1.1.0.ebuild
parentx86 stable, security bug #208128 (diff)
downloadhistorical-65d000c6fd66a39275acf6fb2d6f2d352364aff5.tar.gz
historical-65d000c6fd66a39275acf6fb2d6f2d352364aff5.tar.bz2
historical-65d000c6fd66a39275acf6fb2d6f2d352364aff5.zip
bumb
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-misc/xsel/xsel-1.1.0.ebuild')
-rw-r--r--x11-misc/xsel/xsel-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-1.1.0.ebuild b/x11-misc/xsel/xsel-1.1.0.ebuild
new file mode 100644
index 000000000000..5d108de0f233
--- /dev/null
+++ b/x11-misc/xsel/xsel-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsel/xsel-1.1.0.ebuild,v 1.1 2008/02/28 20:05:39 drac Exp $
+
+DESCRIPTION="XSel is a command-line program for getting and setting the contents of the X selection."
+HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
+SRC_URI="http://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-libs/libXt"
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README
+}