summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:22:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:22:51 +0000
commitc8e6690897dc17d6aa7d7d3d9730f13df9de215f (patch)
tree9528ee183f34213352ffa01d2327e01edc5ad071 /x11-misc/xnview
parentUpdate Copyright years (diff)
downloadhistorical-c8e6690897dc17d6aa7d7d3d9730f13df9de215f.tar.gz
historical-c8e6690897dc17d6aa7d7d3d9730f13df9de215f.tar.bz2
historical-c8e6690897dc17d6aa7d7d3d9730f13df9de215f.zip
new viewer for X
Diffstat (limited to 'x11-misc/xnview')
-rw-r--r--x11-misc/xnview/ChangeLog16
-rw-r--r--x11-misc/xnview/files/99XnView2
-rw-r--r--x11-misc/xnview/files/digest-xnview-1.502
-rw-r--r--x11-misc/xnview/xnview-1.50.ebuild50
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/xnview/ChangeLog b/x11-misc/xnview/ChangeLog
new file mode 100644
index 000000000000..6eb00e950cd7
--- /dev/null
+++ b/x11-misc/xnview/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for x11-misc/xnview
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnview/ChangeLog,v 1.1 2003/02/12 10:22:51 seemant Exp $
+
+*xnview-1.50 (12 Feb 2003)
+
+ 12 Feb 2003; Seemant Kulleen <seemant@gentoo.org> ChangeLog
+ xnview-1.50.ebuild files/digest-xnview-1.50 :
+
+ An image viewer/converter application, freeware, binary only. I
+ changed the ebuild that Mark Mealman <mmealman@tarsis.org> submitted in
+ bug #13584 to download the rpms instead since they are statically
+ linked with *motif, removing the necessity of restricting the user to a
+ specific version of openmotif (there are binaries for 2.1 and 2.2 and
+ lesstif for the dynamically linked ones). Also, with the rpm's it is
+ easier to install for ppc or x86.
diff --git a/x11-misc/xnview/files/99XnView b/x11-misc/xnview/files/99XnView
new file mode 100644
index 000000000000..d15d87bf9d84
--- /dev/null
+++ b/x11-misc/xnview/files/99XnView
@@ -0,0 +1,2 @@
+LDPATH=/opt/XnView/lib
+ROOTPATH=/opt/XnView
diff --git a/x11-misc/xnview/files/digest-xnview-1.50 b/x11-misc/xnview/files/digest-xnview-1.50
new file mode 100644
index 000000000000..b31f6db43910
--- /dev/null
+++ b/x11-misc/xnview/files/digest-xnview-1.50
@@ -0,0 +1,2 @@
+MD5 988a83f8798436d19a3c9da0fa949f1a XnView-static.ppc.rpm 1547839
+MD5 299fda4a8b2fc06aad3da16e005c60a1 XnView-static.i386.rpm 1332093
diff --git a/x11-misc/xnview/xnview-1.50.ebuild b/x11-misc/xnview/xnview-1.50.ebuild
new file mode 100644
index 000000000000..6bfaae30e226
--- /dev/null
+++ b/x11-misc/xnview/xnview-1.50.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xnview/xnview-1.50.ebuild,v 1.1 2003/02/12 10:22:51 seemant Exp $
+
+MY_P=XnView-static
+S=${WORKDIR}/usr
+DESCRIPTION="XnView image viewer/converter"
+HOMEPAGE="http://www.xnview.com/"
+SRC_URI="x86? http://perso.wanadoo.fr/pierre.g/download/viewer/${MY_P}.i386.rpm
+ ppc? http://perso.wanadoo.fr/pierre.g/download/viewer/${MY_P}.ppc.rpm"
+
+SLOT="0"
+LICENSE="Freeware"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="app-arch/rpm2targz"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${A}
+
+ use x86 && MY_P=${MY_P}.i386
+ use ppc && MY_P=${MY_P}.ppc
+
+ tar zxvf ${WORKDIR}/${MY_P}.tar.gz &>/dev/null
+}
+
+src_install() {
+ BASE_DIR=/opt/XnView
+
+ into /opt
+ dobin ${S}/X11R6/bin/{xnview,nview,nconvert}
+
+ into ${BASE_DIR}
+ dolib lib/libformat.so.3.87
+ dosym ${BASE_DIR}/lib/libformat.so.3.87 ${BASE_DIR}/lib/libformat.so
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/99XnView
+
+ insinto /usr/lib/X11/app-defaults/XnView
+ doins ${S}/X11R6/lib/X11/app-defaults/XnView
+ fperms 444 /usr/lib/X11/app-defaults/XnView
+
+ doman local/man/man1/*.1
+
+ dodoc doc/XnView-${PV}/*.txt
+
+ insinto ${BASE_DIR}/Filters/
+ doins usr/share/XnView/Filters/*.dat
+}